Bug 494346 - gnome-screensaver does not power off displays when idle
gnome-screensaver does not power off displays when idle
Status: CLOSED DUPLICATE of bug 485601
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-06 10:04 EDT by Kevin DeKorte
Modified: 2015-01-14 18:22 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-07 14:25:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci output (1.99 KB, text/plain)
2009-04-06 21:02 EDT, Jim Hayward
no flags Details

  None (edit)
Description Kevin DeKorte 2009-04-06 10:04:48 EDT
Description of problem:
gnome-screensaver will not turn off the backlight on displays when after the correct time period. The GDM screensaver does work correctly

Version-Release number of selected component (if applicable):
gnome-screensaver-2.26.0-1.fc11.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Set screensaver to 10mins
2. Set "turn display off in gnome-power-manager" to 10 mins
3.
  
Actual results:
screen goes blank (screensaver is using the blank option)
but backlight never goes out

Expected results:
backlight should go out on displays (I have two)

Additional info:
radeon driver but using nomodeset
xorg-x11-drv-ati-6.12.1-4.fc11.x86_64
Comment 1 Tom Horsley 2009-04-06 13:40:54 EDT
I think I've observed this same behavior with the nouveau driver. The screen
will go black, but the signal does not shut off completely (doesn't matter
much since my monitor doesn't actually respond to DPMS, but I see a box
that says "no signal" in fedora 10, and just get a blank screen in
fedora 11).
Comment 2 Kevin DeKorte 2009-04-06 13:56:58 EDT
If I run "xset dpms force suspend" my displays will power off as expected and come back on when I move the mouse.

Thinking this bug might be related to gnome-power-manager as well. Gonna add rhughes to it. If it is not related he can drop off.
Comment 3 Adam Williamson 2009-04-06 17:06:40 EDT
I believe this is a known issue - someone mentioned it to me in the context of a recent graphics card test day, and suggested changing the DPMS test case from g-p-m to xset - but I can't find another report for it in Bugzilla, so it may not have been reported otherwise yet. Assigning.
Comment 4 Jim Hayward 2009-04-06 21:02:51 EDT
Created attachment 338420 [details]
lspci output
Comment 5 Jim Hayward 2009-04-06 21:04:20 EDT
I'm having the same issue. The screensaver will activate, but my monitor never powers off. If needed, the lspci output for my video card is attached.
Comment 6 Joachim Frieben 2009-04-07 03:26:34 EDT
*** This is a duplicate of bug 485601. The latest svn version of g-p-m fixes this issue. ***
Comment 7 Matthias Clasen 2009-04-07 14:25:09 EDT

*** This bug has been marked as a duplicate of bug 485601 ***
Comment 8 Adam Williamson 2009-04-08 18:04:58 EDT
ah, thanks - I never managed to hit the magic phrase "display sleep" in my searches :\

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.