Bug 494350 - Certificate verification failure with intermediate certificates
Certificate verification failure with intermediate certificates
Status: CLOSED DUPLICATE of bug 502451
Product: Fedora
Classification: Fedora
Component: neon (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-06 10:14 EDT by Alexander Boström
Modified: 2009-09-01 08:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-01 08:57:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Boström 2009-04-06 10:14:35 EDT
For cadaver or neon.

Description of problem:
Certificate verification failure for servers with an intermediate certificate.

Version-Release number of selected component (if applicable):
cadaver-0.23.2-4.x86_64
neon-0.28.3-2.x86_64
gnutls-2.4.2-3.fc10.x86_64

How reproducible:
Always.

Steps to Reproduce:

Success:
$ gnutls-cli </dev/null --x509cafile /etc/pki/tls/certs/ca-bundle.crt \
   -V -p 443 www.kth.se|grep 'certificate is'
- Peer's certificate is trusted

Failure:
$ cadaver </dev/null https://www.kth.se/|head -1
WARNING: Untrusted server certificate presented for `www.kth.se':

Success:
$ cadaver </dev/null https://bugzilla.redhat.com/|head -1
Could not access / (not WebDAV-enabled?):

Actual results:
cadaver fails for www.kth.se

Expected results:
cadaver should be able to verify the certificate.
Comment 1 Joe Orton 2009-04-06 11:28:30 EDT
This is pretty odd - I can't see that cadaver/neon are doing anything different/wrong to gnutls-cli here.
Comment 2 Joe Orton 2009-09-01 08:57:23 EDT
This was an X.509v1 root cert, so, it was caused by a neon bug, now fixed.  Thanks for the report.

*** This bug has been marked as a duplicate of bug 502451 ***

Note You need to log in before you can comment on or make changes to this bug.