Bug 494356 - NTFS-3g corrupted my filesystem
NTFS-3g corrupted my filesystem
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ntfs-3g (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-06 10:37 EDT by Jason Waggoner
Modified: 2009-05-11 17:36 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-11 17:36:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Waggoner 2009-04-06 10:37:04 EDT
Description of problem:


Version-Release number of selected component (if applicable): latest ntfs-36 as part of Fedora 11 Beta on 03/06/09. I don't want to boot back into linux for now. 


How reproducible: Every time I log back in I get more corruption.


Steps to Reproduce:
1. Mount a ntfs drive
2. browse the files with nautilus
3. notice that some expected files aren't appearing.
4. do an ls -a and see that they appear in console
5. try to manually open them from console
6. input/output error
  
Actual results:


Expected results:


Additional info: Here is what is showing up in my log. I ran a checkdisk in windows which found lots of problems. It cleaned things up, but some file have completely disappeared.

Apr 5 18:47:36 LinPC ntfs-3g[1811]: ntfs_mst_post_read_fixup: magic: 0x00000000 size: 1024 usa_ofs: 0 usa_count: 65535: Invalid argument
Apr 5 18:47:36 LinPC ntfs-3g[1811]: Record 33556 has no FILE magic (0x0)
Apr 5 18:47:36 LinPC ntfs-3g[1811]: ntfs_mst_post_read_fixup: magic: 0x00000000 size: 1024 usa_ofs: 0 usa_count: 65535: Invalid argument
Apr 5 18:47:36 LinPC ntfs-3g[1811]: Record 34130 has no FILE magic (0x0)
Apr 5 18:47:36 LinPC ntfs-3g[1811]: ntfs_mst_post_read_fixup: magic: 0x00000000 size: 1024 usa_ofs: 0 usa_count: 65535: Invalid argument
Apr 5 18:47:36 LinPC ntfs-3g[1811]: Record 39490 has no FILE magic (0x0)
Apr 5 18:47:36 LinPC ntfs-3g[1811]: ntfs_mst_post_read_fixup: magic: 0x00000000 size: 1024 usa_ofs: 0 usa_count: 65535: Invalid argument
Apr 5 18:47:36 LinPC ntfs-3g[1811]: Record 39245 has no FILE magic (0x0)
Apr 5 18:47:36 LinPC ntfs-3g[1811]: ntfs_mst_post_read_fixup: magic: 0x00000000 size: 1024 usa_ofs: 0 usa_count: 65535: Invalid argument
Apr 5 18:47:36 LinPC ntfs-3g[1811]: Record 39247 has no FILE magic (0x0)
Apr 5 18:47:36 LinPC ntfs-3g[1811]: ntfs_mst_post_read_fixup: magic: 0x00000000 size: 1024 usa_ofs: 0 usa_count: 65535: Invalid argument
Apr 5 18:47:36 LinPC ntfs-3g[1811]: Record 39481 has no FILE magic (0x0)
Apr 5 18:47:36 LinPC ntfs-3g[1811]: ntfs_mst_post_read_fixup: magic: 0xd16be2be size: 4096 usa_ofs: 16261 usa_count: 9840: Invalid argument
Apr 5 18:47:36 LinPC ntfs-3g[1811]: Actual VCN (0xfccfb1645c7c5118) of index buffer is different from expected VCN (0x0) in inode 0x8359.
Apr 5 18:47:39 LinPC ntfs-3g[1811]: ntfs_mst_post_read_fixup: magic: 0x00000000 size: 1024 usa_ofs: 0 usa_count: 65535: Invalid argument
Apr 5 18:47:39 LinPC ntfs-3g[1811]: Record 39245 has no FILE magic (0x0)
Apr 5 18:47:39 LinPC ntfs-3g[1811]: ntfs_mst_post_read_fixup: magic: 0x00000000 size: 1024 usa_ofs: 0 usa_count: 65535: Invalid argument
Apr 5 18:47:39 LinPC ntfs-3g[1811]: Record 39247 has no FILE magic (0x0)
Apr 5 18:47:39 LinPC ntfs-3g[1811]: ntfs_mst_post_read_fixup: magic: 0x00000000 size: 1024 usa_ofs: 0 usa_count: 65535: Invalid argument
Apr 5 18:47:39 LinPC ntfs-3g[1811]: Record 33848 has no FILE magic (0x0)
Apr 5 18:47:39 LinPC ntfs-3g[1811]: ntfs_mst_post_read_fixup: magic: 0x00000000 size: 1024 usa_ofs: 0 usa_count: 65535: Invalid argument
Apr 5 18:47:39 LinPC ntfs-3g[1811]: Record 33556 has no FILE magic (0x0)
Apr 5 18:47:39 LinPC ntfs-3g[1811]: ntfs_mst_post_read_fixup: magic: 0x00000000 size: 1024 usa_ofs: 0 usa_count: 65535: Invalid argument
Apr 5 18:47:39 LinPC ntfs-3g[1811]: Record 34130 has no FILE magic (0x0)
Apr 5 18:47:39 LinPC ntfs-3g[1811]: ntfs_mst_post_read_fixup: magic: 0x00000000 size: 1024 usa_ofs: 0 usa_count: 65535: Invalid argument
Apr 5 18:47:39 LinPC ntfs-3g[1811]: Record 39490 has no FILE magic (0x0)
Apr 5 18:47:42 LinPC ntfs-3g[1811]: ntfs_mst_post_read_fixup: magic: 0x00000000 size: 1024 usa_ofs: 0 usa_count: 65535: Invalid argument
Apr 5 18:47:42 LinPC ntfs-3g[1811]: Record 33848 has no FILE magic (0x0)
Apr 5 18:47:43 LinPC ntfs-3g[1811]: ntfs_mst_post_read_fixup: magic: 0x00000000 size: 1024 usa_ofs: 0 usa_count: 65535: Invalid argument
Apr 5 18:47:43 LinPC ntfs-3g[1811]: Record 33994 has no FILE magic (0x0)
Apr 5 18:47:43 LinPC ntfs-3g[1811]: ntfs_mst_post_read_fixup: magic: 0x00000000 size: 1024 usa_ofs: 0 usa_count: 65535: Invalid argument
Apr 5 18:47:43 LinPC ntfs-3g[1811]: Record 39245 has no FILE magic (0x0)
Apr 5 18:47:43 LinPC ntfs-3g[1811]: ntfs_mst_post_read_fixup: magic: 0x00000000 size: 1024 usa_ofs: 0 usa_count: 65535: Invalid argument
Apr 5 18:47:43 LinPC ntfs-3g[1811]: Record 39247 has no FILE magic (0x0)
Apr 5 18:47:43 LinPC ntfs-3g[1811]: ntfs_mst_post_read_fixup: magic: 0x00000000 size: 1024 usa_ofs: 0 usa_count: 65535: Invalid argument
Apr 5 18:47:43 LinPC ntfs-3g[1811]: Record 41988 has no FILE magic (0x0)
Apr 5 18:47:43 LinPC ntfs-3g[1811]: ntfs_mst_post_read_fixup: magic: 0x00000000 size: 1024 usa_ofs: 0 usa_count: 65535: Invalid argument
Apr 5 18:47:43 LinPC ntfs-3g[1811]: Record 41989 has no FILE magic (0x0)
Apr 5 18:47:46 LinPC ntfs-3g[1811]: ntfs_mst_post_read_fixup: magic: 0x00000000 size: 1024 usa_ofs: 0 usa_count: 65535: Invalid argument
Apr 5 18:47:46 LinPC ntfs-3g[1811]: Record 34050 has no FILE magic (0x0)
Apr 5 18:47:46 LinPC ntfs-3g[1811]: ntfs_mst_post_read_fixup: magic: 0x00000000 size: 1024 usa_ofs: 0 usa_count: 65535: Invalid argument
Apr 5 18:47:46 LinPC ntfs-3g[1811]: Record 39230 has no FILE magic (0x0)
Apr 5 18:47:46 LinPC ntfs-3g[1811]: ntfs_mst_post_read_fixup: magic: 0x00000000 size: 1024 usa_ofs: 0 usa_count: 65535: Invalid argument
Apr 5 18:47:46 LinPC ntfs-3g[1811]: Record 34007 has no FILE magic (0x0)
Apr 5 18:47:46 LinPC ntfs-3g[1811]: ntfs_mst_post_read_fixup: magic: 0x00000000 size: 1024 usa_ofs: 0 usa_count: 65535: Invalid argument
Apr 5 18:47:46 LinPC ntfs-3g[1811]: Record 41311 has no FILE magic (0x0)
Apr 5 18:47:47 LinPC ntfs-3g[1811]: ntfs_mst_post_read_fixup: magic: 0x00000000 size: 1024 usa_ofs: 0 usa_count: 65535: Invalid argument
Apr 5 18:47:47 LinPC ntfs-3g[1811]: Record 39451 has no FILE magic (0x0)
(...)
Apr 5 18:47:52 LinPC ntfs-3g[1811]: Index root attribute missing in directory inode 33699: Input/output error
Apr 5 18:47:52 LinPC ntfs-3g[1811]: ntfs_mst_post_read_fixup: magic: 0x00000000 size: 1024 usa_ofs: 0 usa_count: 65535: Invalid argument
Apr 5 18:47:52 LinPC ntfs-3g[1811]: Record 33208 has no FILE magic (0x0)
(...)
Apr 5 18:52:15 LinPC ntfs-3g[1811]: ntfs_mst_post_read_fixup: magic: 0x00000000 size: 1024 usa_ofs: 0 usa_count: 65535: Invalid argument
Apr 5 18:52:15 LinPC ntfs-3g[1811]: Record 39490 has no FILE magic (0x0)
Apr 5 18:52:15 LinPC ntfs-3g[1811]: ntfs_mst_post_read_fixup: magic: 0x00000000 size: 1024 usa_ofs: 0 usa_count: 65535: Invalid argument
Apr 5 18:52:15 LinPC ntfs-3g[1811]: Record 39538 has no FILE magic (0x0)
Apr 5 18:52:15 LinPC ntfs-3g[1811]: ntfs_mst_post_read_fixup: magic: 0x00000000 size: 1024 usa_ofs: 0 usa_count: 65535: Invalid argument
Apr 5 18:52:15 LinPC ntfs-3g[1811]: Record 33556 has no FILE magic (0x0)
Apr 5 18:52:15 LinPC ntfs-3g[1811]: ntfs_mst_post_read_fixup: magic: 0x00000000 size: 1024 usa_ofs: 0 usa_count: 65535: Invalid argument
Apr 5 18:52:15 LinPC ntfs-3g[1811]: Record 34130 has no FILE magic (0x0)
Comment 1 Tom "spot" Callaway 2009-04-06 10:46:01 EDT
There is a newer ntfs-3g update in rawhide (ntfs-3g-2009.4.4-1.fc11) that has some corruption fixes... try to update to that and see if you still get the same errors?
Comment 2 Jason Waggoner 2009-04-06 21:31:07 EDT
I logged into my computer in single-user mode and commented out my ntfs drive to prevent any possible further corruption. 
I checked the version of ntfs-3g and it was ntfs-3g-2:2009.4.4-1.fc11 (x86_64). 
I am fairly certain that this version caused my problems. After I did the initial install of Fedora 11 Beta I did a full update before mounting my ntfs drives via fstab. 
Should I wait for the next ntfs-3g update before I start using it again?
Comment 3 Szabolcs Szakacsits 2009-04-07 06:43:01 EDT
It seems you have only one problem: one segment of the NTFS superblock is invalid (uninitialized, empty disk space) between file numbers 33,000-42,000. There can be several reasons for this:

1. One lower layer is temporarily or permanently broken (device driver, disk).
2. If the relevant NTFS info is at the end of the NTFS superblock then the volume was not safely unmounted (i.e. the data was not written to the disk).
3. The issue could be also not NTFS but RAID related. Sometimes they are doing funny things.

You should check your logs not only for NTFS but all kind of disk, I/O, RAID, USB errors in the past: http://ntfs-3g.org/support.html#ioerror
Comment 4 Szabolcs Szakacsits 2009-04-08 21:09:49 EDT
The reason for the errors is something (apparently rawhide update?) unexpectedly unmounting the NTFS volume: http://forums.fedoraforum.org/showpost.php?p=1198150&postcount=14
Comment 5 Tom "spot" Callaway 2009-04-08 21:45:14 EDT
gnome-keyring-daemon? doing an unmount of a volume? that looks very odd to me.
Comment 6 Szabolcs Szakacsits 2009-04-08 22:07:28 EDT
gnome-keyring-daemon doesn't unmount volumes. It logged that the volume was unmounted/detached/removed/disconnected/etc by something else. Partial logs, like 'grep ntfs' are usually useless because those are symptoms, not reasons.
Comment 7 Tom "spot" Callaway 2009-05-11 17:36:11 EDT
Based on szaka's feedback, I don't think this is a fixable bug in the software. Closing out.

Note You need to log in before you can comment on or make changes to this bug.