Bug 494357 - Numeric.reshape raises ValueError exception when newshape has more than 1 dimension
Numeric.reshape raises ValueError exception when newshape has more than 1 dim...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: python-numeric (Show other bugs)
5.3
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Matthew Barnes
Desktop QE
: ZStream
Depends On:
Blocks: 807971 703160
  Show dependency treegraph
 
Reported: 2009-04-06 10:37 EDT by Casey Dahlin
Modified: 2014-06-18 04:46 EDT (History)
9 users (show)

See Also:
Fixed In Version: python-numeric-23.7-3.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-03 12:53:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for issue (388 bytes, patch)
2010-08-11 11:10 EDT, Jeremy West
no flags Details | Diff

  None (edit)
Description Casey Dahlin 2009-04-06 10:37:10 EDT
Description of problem:
Numeric.reshape raises ValueError exception when newshape has more than 1 dimension. This problem is observed only on x86_64 machines.

Version-Release number of selected component (if applicable):
python-2.4.3-24.el5
python-numeric-23.7-2.2.2

How reproducible:
Only reproducible on x86_64. 32-bit machines are correct.

Steps to Reproduce:
On a RHEL 5 x86_64 machine:
[root@dhcp6-118 ~]# python
Python 2.4.3 (#1, Sep 17 2008, 16:07:08)
[GCC 4.1.2 20071124 (Red Hat 4.1.2-41)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import Numeric
>>> print Numeric.__version__
23.7
>>> a = Numeric.array([x for x in xrange(20)])
>>> Numeric.reshape(a, (4,5))
Traceback (most recent call last):
 File "<stdin>", line 1, in ?
ValueError: total size of new array must be unchanged
>>>

Expected results:
As seen on a 32 bit RHEL 5 machine :

>>> Numeric.reshape(a, (4,5))
array([[ 0,  1,  2,  3,  4],
      [ 5,  6,  7,  8,  9],
      [10, 11, 12, 13, 14],
      [15, 16, 17, 18, 19]])

Additional info:
Bug was fixed in Fedora in bug 192895, by rebasing to 24.2. Customer would prefer that solution for RHEL if possible. 24.2 was released in 2005.
Comment 1 RHEL Product and Program Management 2009-04-06 10:46:56 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 3 RHEL Product and Program Management 2009-11-06 14:02:52 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 4 Bob Arendt 2010-05-13 12:11:44 EDT
Will python-numeric be updated in RHEL6 to the later version?  Or at least remove the buggy version?  Thanks.
Comment 6 RHEL Product and Program Management 2010-08-09 15:12:49 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 8 Jeremy West 2010-08-11 11:10:59 EDT
Created attachment 438212 [details]
Patch for issue
Comment 20 Bob Arendt 2012-03-07 17:06:10 EST
This bug was fixed by the patch for Bug 703160, which was just a dup of this bug.  This bug can be closed based on http://rhn.redhat.com/errata/RHBA-2011-0508.html

Note You need to log in before you can comment on or make changes to this bug.