Bug 494359 - OpenOffice Impress, xrandr, presenter plugin == crash of OOo
OpenOffice Impress, xrandr, presenter plugin == crash of OOo
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-06 10:37 EDT by Jan Wildeboer
Modified: 2009-04-17 18:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-17 18:17:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Wildeboer 2009-04-06 10:37:45 EDT
Description of problem:

Trying to leave a running presentation with ESC key causes OOo to crash (32bit only, seems to work with x86_64)

Version-Release number of selected component (if applicable):

openoffice.org-impress-core-3.0.1-15.3.fc10.i386

How reproducible:

Open presentation with two screens using the presenter plugin, go to some slide, hit ESC. Poof.

Steps to Reproduce:
1. Set dual screens with xrandr
2. Open a presentation
3. Start the slideshow (with F5)
4. Hit ESC
  
Actual results:

OOo crashes with the following error message (when started from a terminal):

  X-Error: RenderBadPicture (invalid Picture parameter)
          Major opcode: 149
          Minor opcode: 7
          Resource ID:  0x3a018f9
          Serial No:    92244 (92244)

NOTE: The resource id and serial no change everytime, the major/minor however is always 149/7

NOTE2: Seems to work with 64bit Fedora, couldn't reproduce there.

Expected results:

Slideshow stops and Openoffice returns to normal editing mode

Additional info:
Comment 1 Caolan McNamara 2009-04-06 11:04:55 EDT
What's the video driver ?


(hackarounds might include
a. export SAL_IGNOREXERRORS=1
b. export SAL_DISABLE_CAIROTEXT=1
c. tools->options-view and toggling off "hardware acceleration" (i.e. cairo drawing)
Comment 2 Jan Wildeboer 2009-04-06 12:02:07 EDT
Your first suggestion already works!

As this is on a small netbook (Acer Aspire One A110L) I will not dive into removing hardware acceleration support.

I will test more and should this be sufficient, I am a happy Fedora User again :-)

Jan
Comment 3 Caolan McNamara 2009-04-06 16:30:41 EDT
The first one just makes OOo ignore any X errors and carry on, so its possibly something of the nature of a mismatching depth on drawing or sommat like that.

Knowing the hardware driver might help, i.e. run

/usr/lib/openoffice.org3/program/crash_report -stack /dev/null

to collect possibly useful info
Comment 4 Caolan McNamara 2009-04-07 05:30:02 EDT
FWIW checked on 32bit openoffice.org-core-3.0.1-15.3.fc10.i386 with i915 intel driver and got working dual head with XRandr without XErrors on showing a simple presentation.
Comment 5 Caolan McNamara 2009-04-17 18:17:59 EDT
I'm going to close this one for now, unless there is some more information that would help reproduce it. Its probably some depth mismatch issue I'd guess, hopefully sorted out in 3.1 for F-11

Note You need to log in before you can comment on or make changes to this bug.