Bug 494364 - Psi 0.12.1 2.fc11 problems
Psi 0.12.1 2.fc11 problems
Status: CLOSED DUPLICATE of bug 497950
Product: Fedora
Classification: Fedora
Component: psi (Show other bugs)
rawhide
i386 Linux
low Severity low
: ---
: ---
Assigned To: Sven Lankes
Fedora Extras Quality Assurance
http://forums.fedoraforum.org/showthr...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-06 11:03 EDT by Tom
Modified: 2009-06-05 15:37 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-05 15:37:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenscast of Psi behaviour (1.19 MB, video/ogg)
2009-04-07 04:48 EDT, Tom
no flags Details

  None (edit)
Description Tom 2009-04-06 11:03:42 EDT
Description of problem:
Package is
Name : psi
Arch : i586
Version : 0.12.1
Release : 2.fc11
Size : 5.9 M

Although i see that history files are updated in ~/.psi/profiles/default/history directory when i try to see this history in application it it empty. So history files are written but can load them in application Psi.

Second very ANNOYING problem is, that roster does not have focus.
If i want to write to someone, i click on him, it should be highlated. But it is not. So i have to resize window to highlight it.
Or change view and turn off offline users. It is refreshed when roster window is resized.

I hope you understand me and i am wondering if anyone else experienced this behaviour. 


Version-Release number of selected component (if applicable):
yum deplist psi
Loaded plugins: refresh-packagekit
Finding dependencies: 
package: psi.i586 0.12.1-2.fc11
  dependency: libz.so.1
   provider: zlib.i586 1.2.3-22.fc11
  dependency: libgcc_s.so.1
   provider: libgcc.i586 4.4.0-0.31
  dependency: libstdc++.so.6
   provider: libstdc++.i586 4.4.0-0.31
  dependency: libm.so.6
   provider: glibc.i686 2.9.90-12
   provider: glibc.i586 2.9.90-12
  dependency: libstdc++.so.6(GLIBCXX_3.4)
   provider: libstdc++.i586 4.4.0-0.31
  dependency: libc.so.6(GLIBC_2.1.3)
   provider: glibc.i686 2.9.90-12
   provider: glibc.i586 2.9.90-12
  dependency: libc.so.6
   provider: glibc.i686 2.9.90-12
   provider: glibc.i586 2.9.90-12
  dependency: qca-ossl
   provider: qca-ossl.i586 2.0.0-0.6.beta3.fc11
  dependency: libc.so.6(GLIBC_2.4)
   provider: glibc.i686 2.9.90-12
   provider: glibc.i586 2.9.90-12
  dependency: /bin/sh
   provider: bash.i586 4.0-5.fc11
  dependency: libQtDBus.so.4
   provider: qt.i586 1:4.5.0-12.fc11
  dependency: libQtNetwork.so.4
   provider: qt.i586 1:4.5.0-12.fc11
  dependency: libc.so.6(GLIBC_2.1)
   provider: glibc.i686 2.9.90-12
   provider: glibc.i586 2.9.90-12
  dependency: libc.so.6(GLIBC_2.7)
   provider: glibc.i686 2.9.90-12
   provider: glibc.i586 2.9.90-12
  dependency: libQtSql.so.4
   provider: qt.i586 1:4.5.0-12.fc11
  dependency: libc.so.6(GLIBC_2.3.4)
   provider: glibc.i686 2.9.90-12
   provider: glibc.i586 2.9.90-12
  dependency: libpthread.so.0(GLIBC_2.0)
   provider: glibc.i686 2.9.90-12
   provider: glibc.i586 2.9.90-12
  dependency: libqca.so.2
   provider: qca2.i586 2.0.0-4.fc11
  dependency: qca-gnupg
   provider: qca-gnupg.i586 2.0.0-0.3.beta1.fc11
  dependency: libm.so.6(GLIBC_2.0)
   provider: glibc.i686 2.9.90-12
   provider: glibc.i586 2.9.90-12
  dependency: libXss.so.1
   provider: libXScrnSaver.i586 1.1.3-2.fc11
  dependency: rtld(GNU_HASH)
   provider: glibc.i686 2.9.90-12
   provider: glibc.i586 2.9.90-12
  dependency: sox
   provider: sox.i586 14.2.0-2.fc11
  dependency: gnupg
   provider: gnupg.i586 1.4.9-5.fc11
  dependency: libgcc_s.so.1(GCC_3.0)
   provider: libgcc.i586 4.4.0-0.31
  dependency: libQtGui.so.4
   provider: qt-x11.i586 1:4.5.0-12.fc11
  dependency: libQtXml.so.4
   provider: qt.i586 1:4.5.0-12.fc11
  dependency: libXext.so.6
   provider: libXext.i586 1.0.99.1-2.fc11
  dependency: libaspell.so.15
   provider: aspell.i586 12:0.60.6-5.fc11
  dependency: libgcc_s.so.1(GLIBC_2.0)
   provider: libgcc.i586 4.4.0-0.31
  dependency: libstdc++.so.6(CXXABI_1.3)
   provider: libstdc++.i586 4.4.0-0.31
  dependency: libX11.so.6
   provider: libX11.i586 1.2-3.fc11
  dependency: libQt3Support.so.4
   provider: qt-x11.i586 1:4.5.0-12.fc11
  dependency: libQtCore.so.4
   provider: qt.i586 1:4.5.0-12.fc11
  dependency: libc.so.6(GLIBC_2.0)
   provider: glibc.i686 2.9.90-12
   provider: glibc.i586 2.9.90-12
  dependency: libpthread.so.0
   provider: glibc.i686 2.9.90-12
   provider: glibc.i586 2.9.90-12
  dependency: libc.so.6(GLIBC_2.1.2)
   provider: glibc.i686 2.9.90-12
   provider: glibc.i586 2.9.90-12





Steps to Reproduce:
1.Check history of comunication with user in application
2.check history files in ~/.psi/profiles/default/history

Second thing. 
Click to enable offline users and resize roster window.

I am not sure those are bugs. Could be there some setting problem.
Comment 1 Sven Lankes 2009-04-06 13:54:39 EDT
Hello Tom,

thanks for reporting the issues you have been seeing.

Some remarks wrt. filing bugs first:

1. Please file separate bugs for separate issues in the future - having separate bugs is the only way to track which issues are being worked on / fixed

2. Please try to use descriptive summaries - 'psi problems' doesn't give any clue what the problem could be - so there is no way someone with the same issue would be able to find this bug.

On the reported issues:

I cannot reproduce any of those on my x86_64 rawhide system. I'll leave this bug open and in status needinfo for a while in case anyone else is able to reproduce it.
Comment 2 Tom 2009-04-07 03:19:50 EDT
Sorry about that. 
And thing is much weirder. 
If i start Psi in Offline mode, i can see history of chat and focus is ok. User is highlighted when i click on him, and refresh of roster is correct when i turn off/on offline users. 

But when i put Psi Online, history dissappear and refresh and focus of application is lost. 

I promise i will try to create some screencast. 

!!!!!!!!!!!!!!!!!!!!!
I FOUND IT. 
Problem was in AUTOJOIN of IRC channel via transport. When it is off, Psi has auto refresh of roster and focus :-)
!!!!!!!!!!!!!!!!!!!!!
Comment 3 Tom 2009-04-07 04:15:50 EDT
Well it is not permanent solution. It happened again after using application several minutes. 

Focus and history is lost. 
It is inteferred by some behaviour i did not find yet. 
Maybe status icon in gnome panel ? 

It works sometimes sometimes did not. But if it is in offline, everything is ok, troubles start after connection :-(
Comment 4 Tom 2009-04-07 04:48:27 EDT
Created attachment 338473 [details]
Screenscast of Psi behaviour
Comment 5 Tom 2009-04-07 04:49:19 EDT
Weird behaviour started after clicking on gadu-gadu exclamation mark.
Comment 6 Aurelien Bompard 2009-04-07 07:02:40 EDT
Thanks for digging into this. But I'm pretty sure the psi devs would do a better job than us with all this information. I recommand you open a ticket in Psi's bugtracker, since this does not seem to be a bug in the Fedora packaging of Psi.

Here's the tracker : http://flyspray.psi-im.org/

Thanks !
Comment 7 Sven Lankes 2009-04-07 08:24:48 EDT
This could be a qt4.5-issue. According to the psi-forums there are some fixes in the (not yet released) qt 4.5.1 tree that will make psi work better with qt 4.5.
Comment 8 Tom 2009-04-07 08:49:12 EDT
I raised http://flyspray.psi-im.org/task/953 and i will inform you if anything appear. 
Thank you
Comment 9 Sven Lankes 2009-06-05 15:37:30 EDT

*** This bug has been marked as a duplicate of bug 497950 ***

Note You need to log in before you can comment on or make changes to this bug.