Bug 494401 - NetworkManager ignores the dhclient configuration
NetworkManager ignores the dhclient configuration
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-06 13:56 EDT by daniel flesner
Modified: 2009-04-09 16:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-08 21:09:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description daniel flesner 2009-04-06 13:56:40 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. start networkmanager
2.
3.
  
Actual results:

# Generated by NetworkManager
domain mydomain.com
search mydomain.com
nameserver 192.168.1.2
nameserver 207.69.188.172


Expected results:

# Generated by NetworkManager
domain mydomain.com
search workdomain.com otherwork.com mydomain.com
nameserver 192.168.1.2
nameserver 207.69.188.172

Additional info:

the /var/run/nm-dhclient-eth0.conf file appears to be correct:

:# Created by NetworkManager
:# Merged from /etc/dhclient-eth0.conf
:
:prepend domain-name "workdomain.com otherwork.com ";
:send host-name "myhostname";  # temporary RHL ifup addition

from dhclient-eth0.conf:

:prepend domain-name "workdomain.com otherwork.com ";
:send host-name "myhostname";  # temporary RHL ifup addition
Comment 1 daniel flesner 2009-04-06 14:15:46 EDT
rpm versions:

dhclient-4.0.0-33.fc10.x86_64
NetworkManager-glib-0.7.0.99-5.git20090326.fc10.x86_64
NetworkManager-0.7.0.99-5.git20090326.fc10.x86_64
NetworkManager-gnome-0.7.0.99-5.git20090326.fc10.x86_64
Comment 2 Dan Williams 2009-04-08 21:09:27 EDT
you want:

prepend domain-search "workdomain.com otherwork.com";

Note that I just fixed parsing of spaces in domain-search in NetworkManager (dhclient does some odd mangling when you have spaces in the variable) so you'll have to wait until that build comes out to get it to really work.  But in any case, using 'domain-name' like that is invalid.

The reason you're getting 'mydomain.com' is likely becuase your DHCP server sends that in the 'domain-search' option, which overrides the 'domain-name' option.
Comment 3 daniel flesner 2009-04-09 16:34:21 EDT
my dhclient only lists these options:

                  subnet-mask, broadcast-address, time-offset, routers,
                  domain-name, domain-name-servers, host-name, nis-domain,
                  nis-servers, ntp-servers

and domain-name was working until i installed NetworkManager. domain-search does seem to work, but inserts "\032" for the spaces. which version should is see that fix in?

thanks,
daniel
Comment 4 Dan Williams 2009-04-09 16:48:41 EDT
(In reply to comment #3)
> and domain-name was working until i installed NetworkManager. domain-search
> does seem to work, but inserts "\032" for the spaces. which version should is
> see that fix in?

https://admin.fedoraproject.org/updates/F10/FEDORA-2009-3448
https://admin.fedoraproject.org/updates/F9/FEDORA-2009-3488

Note You need to log in before you can comment on or make changes to this bug.