Bug 494413 - io apic resources could not be allocated
io apic resources could not be allocated
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Neil Horman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-06 15:14 EDT by Ray Todd Stevens
Modified: 2009-04-07 09:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-07 09:43:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ray Todd Stevens 2009-04-06 15:14:00 EDT
Getting a message during bootup that resources could not be allocated.

The system also keeps hanging up after 10 or 15 minutes.   Don't know if this is related.
Comment 1 Neil Horman 2009-04-06 15:50:17 EDT
looks like rawhide is short on this commit:
04c93ce4991fce731dab346d03964504339347db

Looks like a simple cleanup, probably best to just treat the message as harmless, and wait for the next pull from upstream to incorporate it.

The hang is bad though, does it still happen if you use linus' tree?
Comment 2 Ray Todd Stevens 2009-04-06 16:25:43 EDT
Not sure about the linus' tree you mentioned could you explain?

Also the hang is usually (but not always proceeded by several quick beeps of the server, and several kernel errors)   The first error is something about kernelopps:000    some more information and then SMP.   I can't find anywhere that this stuff is being dumped to print out and it generally goes by to fast to read well.

It also complains about /dev/md0 a whole bunch.   This is my / device.   I also ahve a boot partition on /boot (/dev/sda1)
Comment 3 Neil Horman 2009-04-06 16:33:59 EDT
I'm referring to this tree:
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=summary

I figured since you were using rawhide, you'd be familiar with building your own kernels.  I'd like to see if this same problem happens upstream.  The code is not too different, but its undergone some refactoring, so I'd like to see what the error looks like on the latest kernel.

If you're getting a bunch of oopses though, lets start there.  See if you can capture the console via serial cable, and attach that here.  That will give us some indication of whats going on.
Comment 4 Ray Todd Stevens 2009-04-06 16:45:37 EDT
By the way this is the same machine which experienced bug 493724.
Comment 5 Neil Horman 2009-04-07 06:50:16 EDT
ok, that doesn't help me a whole lot, as theres no detail in there. 

Regardless, set up a serial console (instructions are here: 

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=blob_plain;f=Documentation/serial-console.txt;hb=HEAD

And attach a capture of what you're seeing.  That will give us some data to work with.
Comment 6 Ray Todd Stevens 2009-04-07 09:32:00 EDT
Well the problem appears to have gone away after I did some upgrading.   I had to manually select the packages to upgrade, as several call for a version of the kernal that doesn't seem to exist.   Should I file that here or as a new bug?
Comment 7 Neil Horman 2009-04-07 09:43:31 EDT
If you upgraded and the problem wen't away, thats great, I'll close this bug as fixed.

If you want to open a new bug on your kernel issues, thats fine, but please try to provide as much detail in it as you can (logs, specific error messages, version numbers, etc).  Given this bug report and the other one you reference, no one is going to be able to help you unless you provide those details.

Note You need to log in before you can comment on or make changes to this bug.