Bug 494448 - Make memtest86+ use bzImage format
Make memtest86+ use bzImage format
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: memtest86+ (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Paulo Roma Cavalcanti
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-06 17:53 EDT by Warren Togami
Modified: 2009-09-10 18:24 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 18:24:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2009-04-06 17:53:42 EDT
Bug #494157 it became necessary to ship a second build of memtest86+ in the package because the original build works with syslinux, while it fails on some systems when booted from grub.  The second build should work from grub.

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=319837#21
This bug explains the reason for this, essentially memtest86+ uses the old zImage kernel format.  It must be fixed to build into the new kernel format.  When this is fixed, our memtest86+ can eliminate the second binary.
Comment 1 Warren Togami 2009-06-02 13:52:30 EDT
memtest86+ is based on a fork of an ancient Linux kernel.  It builds into the zImage format.  We need to make it build as the newer bzImage format which is capable of booting with both syslinux and grub on all systems.
Comment 2 Paulo Roma Cavalcanti 2009-06-02 15:22:09 EDT
memtes86+ only has a forum ("features requests and bug fixes requests" both point
to the forum).

I posted a message in the forum in 04/15/2009, which has been viewed 275 times.
In this post, I described the problem, and mentioned the patch we are using.
However, I only got one reply:


"Is the patch provided there solve your problem ?"


In my opinion, the developers do not consider this a bug.
Comment 3 Bug Zapper 2009-06-09 09:22:13 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Jarod Wilson 2009-08-18 17:56:45 EDT
Moving back to rawhide. Starting to investigate.
Comment 5 Jarod Wilson 2009-09-10 18:24:45 EDT
So after looking at this fairly extensively... Converting from zImage to bzImage is NOT trivial. Like many other folks apparently, I'd assumed a big part of the change was the compression type used (i.e. gzip -> bzip2). Not so. bzImage is short for 'big zImage', the difference is how the image is decompressed into system memory. A bzImage is split into multiple areas of memory when its decompressed, and requires a fair amount of assembly-level changes to implement this. To make it more interesting, memtest86+ would have to be adapted as well, to understand where things are now being decompressed, so as to not overwrite those areas when doing memory testing. In short, this involves a LOT of work and a lot of regression-testing, to the point where I don't think its worth the effort. The current two-image solution works and really doesn't cause any major hardships on anyone.

Note You need to log in before you can comment on or make changes to this bug.