Bug 494449 - Fedora11 Beta: Segmentation fault in qemu (error in libSDL)
Fedora11 Beta: Segmentation fault in qemu (error in libSDL)
Status: CLOSED DUPLICATE of bug 487720
Product: Fedora
Classification: Fedora
Component: SDL (Show other bugs)
rawhide
x86_64 All
low Severity high
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-06 18:01 EDT by IBM Bug Proxy
Modified: 2009-04-08 10:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-08 10:50:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2009-04-06 18:01:15 EDT
=Comment: #0=================================================
Pavan Naregundi <pavan.naregundi@in.ibm.com> - 
When trying kvm installation on f11beta with qemu, got a segmentation fault as below,  

# qemu-kvm -cdrom Fedora-11-Alpha-x86_64-DVD.iso -hda Fedora-11-Alpha.qcow2  -m 512 
Segmentation fault

# dmesg 
kvm: 10716: cpu0 unhandled wrmsr: 0xc0010117 data 0
qemu-kvm[10716]: segfault at 14696010 ip 0000003207617f07 sp 00007fff3ea6bfd0 error 4 in
libSDL-1.2.so.0.11.2[3207600000+6b000]

# uname -a
Linux llm43.in.ibm.com 2.6.29-0.258.2.3.rc8.git2.fc11.x86_64 #1 SMP Tue Mar 24 18:39:53 EDT 2009
x86_64 x86_64 x86_64 GNU/Linux

# rpm -qa "qemu*"
qemu-system-x86-0.10-0.9.kvm20090310git.fc11.x86_64
qemu-common-0.10-0.9.kvm20090310git.fc11.x86_64
qemu-img-0.10-0.9.kvm20090310git.fc11.x86_64
qemu-system-ppc-0.10-0.9.kvm20090310git.fc11.x86_64

Machine: x3550
=Comment: #3=================================================
Edjunior Barbosa Machado <emachado@linux.vnet.ibm.com> - 
gdb backtrace (unfortunately, couldn't find *-debuginfo rpm packages):

# gdb --args qemu-kvm -cdrom Fedora-11-Alpha-x86_64-DVD.iso 
(...)
Program received signal SIGSEGV, Segmentation fault.
0x0000003207617f07 in ?? () from /usr/lib64/libSDL-1.2.so.0
(gdb) bt
#0  0x0000003207617f07 in ?? () from /usr/lib64/libSDL-1.2.so.0
#1  0x0000003207617d4a in ?? () from /usr/lib64/libSDL-1.2.so.0
#2  0x000000320762e0ec in SDL_LowerBlit () from /usr/lib64/libSDL-1.2.so.0
#3  0x000000320762e2c7 in SDL_UpperBlit () from /usr/lib64/libSDL-1.2.so.0
#4  0x000000000049646f in pthread_attr_setdetachstate ()
#5  0x000000000043b9ba in pthread_attr_setdetachstate ()
#6  0x00000000004964da in pthread_attr_setdetachstate ()
#7  0x00000000004091be in pthread_attr_setdetachstate ()
#8  0x0000000000409a9a in pthread_attr_setdetachstate ()
#9  0x000000000052050a in pthread_attr_setdetachstate ()
#10 0x000000000040e6f7 in pthread_attr_setdetachstate ()
#11 0x00000031fae1e5ed in __libc_start_main () from /lib64/libc.so.6
#12 0x0000000000407329 in pthread_attr_setdetachstate ()
#13 0x00007fff5ae093b8 in ?? ()
#14 0x000000000000001c in ?? ()
#15 0x0000000000000003 in ?? ()
#16 0x00007fff5ae0a81b in ?? ()
#17 0x00007fff5ae0a82d in ?? ()
#18 0x00007fff5ae0a834 in ?? ()
#19 0x0000000000000000 in ?? ()

=================================================
Hello Red Hat,

it seems this issue has been already reported in Red Hat Bugzilla:

https://bugzilla.redhat.com/show_bug.cgi?id=487720

Please let us know if you need any additional information.

Thanks.
Comment 1 Thomas Woerner 2009-04-08 05:56:50 EDT
Please have a look at SDL-1.2.3-9.fc11 in rawhide:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1283010
Comment 2 IBM Bug Proxy 2009-04-08 10:00:46 EDT
------- Comment From pavan.naregundi@in.ibm.com 2009-04-08 09:53 EDT-------
(In reply to comment #9)
> Please have a look at SDL-1.2.3-9.fc11 in rawhide:
>
> http://koji.fedoraproject.org/koji/taskinfo?taskID=1283010
>

After installing above mentioned build Segmentation fault is not produced.

Thanks
Pavan
Comment 3 Thomas Woerner 2009-04-08 10:50:34 EDT

*** This bug has been marked as a duplicate of bug 487720 ***

Note You need to log in before you can comment on or make changes to this bug.