Bug 494450 - errors in system.config.createOrUpdatePath api doc
errors in system.config.createOrUpdatePath api doc
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: API (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Brad Buckingham
Sayli Karmarkar
:
Depends On:
Blocks: 456996
  Show dependency treegraph
 
Reported: 2009-04-06 18:04 EDT by Sayli Karmarkar
Modified: 2015-03-22 21:09 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:55:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sayli Karmarkar 2009-04-06 18:04:05 EDT
Description of problem:

1. Sequence of arguments in api doc are wrong. 

Parameters:

    * string sessionKey
    * int serverId
    * boolean isDir
          o True - if the path is a directory
          o False - if the path is a file
    * string path - the configuration file/directory path 

Actual api seems to accept String path before boolean isDir

2. api is accepting file permission as a string but returning it as an Integer. This is not too much of a problem, but something to consider.
Comment 1 Brad Buckingham 2009-04-16 17:27:42 EDT
master git commit: db61151ee7eabbf4d70c3ad0f5a8739a02fd7c87
vader git commit: 8a0e54c0f33cbb6818f61c36c0df1d8caf66c462

Fixed #1.
Fixed #2 by deprecating the 'int permissions' and adding 'string permissions_mode'

The change for #2 was to the serializer.  Since this serializer was used by multiple APIs, they will all now return this new parameter.  The APIs impacted are:
- system.config.createOrUpdatePath
- system.config.lookupFileInfo
- configchannel.createOrUpdatePath
- configchannel.lookupFileInfo
- system.provisioning.snapshot.listSnapshotConfigFiles

These APIs were all marked as updated since API version 10.2.
Comment 2 Sayli Karmarkar 2009-04-28 18:17:34 EDT
Verified and updated automation tests.
Comment 3 Miroslav Suchý 2009-08-24 10:47:52 EDT
Parameters:

    * string sessionKey
    * int serverId
    * string path - the configuration file/directory path
    * boolean isDir
          o True - if the path is a directory
          o False - if the path is a file
    * struct - path info  ....

verified in stage on xen5
Comment 4 Brandon Perkins 2009-09-10 15:55:20 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.