Bug 494527 - NetworkManager ignores directive not to handle eth0
NetworkManager ignores directive not to handle eth0
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-07 06:30 EDT by Walter Neumann
Modified: 2009-05-12 00:13 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.7.1-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-12 00:13:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
messages from boot to soon after NetworkManager disables eth0 (48.86 KB, text/plain)
2009-04-07 17:01 EDT, Walter Neumann
no flags Details
ifcfg-eth0 as requested (246 bytes, text/plain)
2009-04-09 17:57 EDT, Walter Neumann
no flags Details

  None (edit)
Description Walter Neumann 2009-04-07 06:30:14 EDT
Description of problem: NetworkManager stopped eth0 despite NM_CONTROLLED=no in 
/etc/sysconfig/network-scripts/ifcfg-eth0

Version-Release number of selected component (if applicable):
NetworkManager-0.7.0.99-3.fc9.i386

Expected results:

NetworkManager should respect the directive not to control eth0

Additional info:

I only have NetworkManager because it is a dependency for evolution. I don't want it and it is normally turned off. 

The March upgrade to NetworkManager-0.7.0.99-3.fc9.i386 turned on the service without my noticing (I am 4000 miles from the machine) and when I restarted Fedora two days ago networking first came on as it should, but then NetworkManager started and killed eth0 again. I had to get someone to go to my office and fix it.

NetworkManger should not have touched eth0: /etc/sysconfig/network-scripts/ifcfg-eth0 has "NM_CONTROLLED=no"

(In addition the package update should not have changed the status of the service -- I have filed a separate bug for this)
Comment 1 Niels Haase 2009-04-07 16:09:09 EDT
Reporter, could you please attach your /var/log/messages while NM changed the status of eth0. Thank you.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Walter Neumann 2009-04-07 17:01:28 EDT
Created attachment 338608 [details]
messages from boot to soon after NetworkManager disables eth0
Comment 3 Niels Haase 2009-04-08 18:14:28 EDT
Reporter, can you please update to NetworkManager-0.7.0.100-1.fc9 and attach your /etc/sysconfig/network-scripts/ifcfg-eth0 file? Thank you.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Walter Neumann 2009-04-09 17:57:15 EDT
Created attachment 339006 [details]
ifcfg-eth0 as requested

You asked me also to update to NetworkManager-0.7.0.100-1.fc9. Can you give a link for this? It does not seem to be yet on fedora-updates or fedora-updates-testing.
Comment 5 Niels Haase 2009-04-09 20:55:03 EDT
Thank you for reporting this bug.

This bug report might be a duplicate of
https://bugzilla.redhat.com/show_bug.cgi?id=457098


-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Walter Neumann 2009-04-10 04:51:37 EDT
I don't think it is a duplicate. Bug 457098 refers to behaviour on changing status of the service from on to off. In my case service came on (unintentionally) and was not turned off. But both seem to refer to NetworkManager touching an interface that it had been told not to touch, so maybe it is a duplicate.
Comment 7 Dan Williams 2009-04-11 08:12:21 EDT
Found and fixed upstream:

10bf56b0d6db7281505ca020d1a35ab943dd6b62 (0.7)
e5146b8f82bfb68bcdf43f99dddbfaec516a37a3 (head)

Was going to tag and release 0.7.1 today, and you seem to have found the last bug before release :)  Thanks for helping make the release better.
Comment 8 Fedora Update System 2009-04-14 21:04:27 EDT
NetworkManager-0.7.1-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/NetworkManager-0.7.1-1.fc10
Comment 9 Fedora Update System 2009-04-14 21:23:07 EDT
NetworkManager-0.7.1-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/NetworkManager-0.7.1-1.fc9
Comment 10 Fedora Update System 2009-04-15 13:58:53 EDT
NetworkManager-0.7.1-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-3686
Comment 11 Walter Neumann 2009-04-16 16:34:23 EDT
Tested on a laptop with fc10 and bug seems to be fixed.  

I won't test on the machine where the bug first hit me, since I can't rescue it if a network problem does occur (I'm 4000 miles away), but I'm pretty confident there would be no problem.
Comment 12 Fedora Update System 2009-05-12 00:06:21 EDT
NetworkManager-0.7.1-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2009-05-12 00:13:07 EDT
NetworkManager-0.7.1-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.