Bug 494562 - F-Spot fails to launch under F11
F-Spot fails to launch under F11
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: f-spot (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Nigel Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-07 09:13 EDT by Duncan Innes
Modified: 2009-07-08 04:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-08 04:23:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Duncan Innes 2009-04-07 09:13:53 EDT
Description of problem: F-Spot fails to launch


Version-Release number of selected component (if applicable): f-spot-0.5.0.3-7.fc11.x86_64


How reproducible: Every time


Steps to Reproduce:
1. Launch f-spot
  
Actual results: Nothing


Expected results: F-Spot to launch


Additional info: When executing f-spot from the console as a normal user I get the following:

[duncan@Fedora11 ~]$ f-spot
[Info  14:08:33.627] Initializing DBus
[Info  14:08:33.759] Initializing Mono.Addins
[Info  14:08:33.972] Starting new FSpot server
XXXXX
System.Exception: org.freedesktop.DBus.Error.AccessDenied: Connection ":1.93" is not allowed to own the service "org.gnome.FSpot" due to SELinux policy
  at IBusProxy.RequestName (System.String flags, NameFlag ) [0x00000] 
  at NDesk.DBus.Bus.RequestName (System.String name, NameFlag flags) [0x00000] 
  at FSpot.Core.RegisterServer () [0x00000] 
  at FSpot.Driver.Main (System.String[] args) [0x00000] 
XXXXX
[Warn  14:08:34.044] Can't get a connection to the dbus. Trying again...
[Info  14:08:34.045] Starting new FSpot server
[Warn  14:08:34.045] Can't get a connection to the dbus. Trying again...
[Info  14:08:34.046] Starting new FSpot server
[Warn  14:08:34.046] Can't get a connection to the dbus. Trying again...
[Info  14:08:34.047] Starting new FSpot server
[Warn  14:08:34.047] Can't get a connection to the dbus. Trying again...
[Info  14:08:34.048] Starting new FSpot server
[Warn  14:08:34.048] Can't get a connection to the dbus. Trying again...
[Info  14:08:34.049] Starting new FSpot server
[Warn  14:08:34.049] Can't get a connection to the dbus. Trying again...
[Error 14:08:34.050] Sorry, couldn't start F-Spot
[duncan@Fedora11 ~]$
Comment 1 Bug Zapper 2009-06-09 09:25:13 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Sven Lankes 2009-07-03 16:54:30 EDT
I tried to reproduce this on a fully up-to-date f11 instance with selinux in enforcing mode and f-spot starts fine for me.

Does it still fail for you?
Comment 3 Duncan Innes 2009-07-08 04:23:33 EDT
Looks to be working to me now as well.  Hadn't tried it since rawhide.

Closed.

Note You need to log in before you can comment on or make changes to this bug.