Bug 494574 - Installation using Yum fails
Installation using Yum fails
Status: CLOSED WORKSFORME
Product: 389
Classification: Community
Component: Install/Uninstall (Show other bugs)
1.2.0
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Nathan Kinder
Chandrasekar Kannan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-07 10:07 EDT by gmiller
Modified: 2015-01-04 18:37 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-07 12:08:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description gmiller 2009-04-07 10:07:38 EDT
Description of problem:
Attempting to install on clean install of CentOS 5.3 using the instructions provided at http://directory.fedoraproject.org/wiki/Download

Yum returns the following errror:
http://directory.fedoraproject.org/yum/dirsrv/fedora/6/noarch/RPMS/repodata/filelists.xml.gz: [Errno -1] Metadata file does not match checksum
Trying other mirror.
Error: failure: repodata/filelists.xml.gz from dirsrv-noarch: [Errno 256] No more mirrors to try.

Tried running yum clean all - didn't help.

Version-Release number of selected component (if applicable):


How reproducible:
Has occurred every time I have tried on 4/6/2009 and 4/7/2009.

Steps to Reproduce:
1. Start with a clean installation of CentOS 5.3
2. Download and modify the repo files on the FDS download page as documented
3. Run yum install fedora-ds
  
Actual results:
Error

Expected results:
Successful installation

Additional info:
Comment 1 Rich Megginson 2009-04-07 11:17:16 EDT
I cannot reproduce - I've got a clean install of CentOS 5.3 x86 32-bit
could be a problem with the squid cache on directory.fedoraproject.org - try it again
Comment 2 gmiller 2009-04-07 12:08:19 EDT
I tried it again - same thing.  I rebooted the server, ran yum clean all again, and still the same thing.  I was called away from my desk for 15 minutes.  When I returned, I tried it again and this time it worked perfectly.  I guess the problem cleared itself up...

Thanks!
Comment 3 Rich Megginson 2009-04-07 12:11:39 EDT
yes, I had messed up the repo - sorry about that
Comment 4 gmiller 2009-04-07 12:25:30 EDT
Thanks for all of the help!!!

I may have spoken too soon, though.

Yum was able to download everything properly except for one rpm:

fedora-ds-admin-1.1.7-2.fc6.i386.rpm                     | 360 kB     00:01
http://directory.fedoraproject.org/yum/dirsrv/fedora/6/i386/RPMS/fedora-ds-admin-1.1.7-2.fc6.i386.rpm: [Errno -1] Package does not match intended download
Trying other mirror.


Error Downloading Packages:
  fedora-ds-admin-1.1.7-2.fc6.i386: failure: fedora-ds-admin-1.1.7-2.fc6.i386.rpm from dirsrv: [Errno 256] No more mirrors to try.

I have retried this several times, and have even tried yum clean all again.
Comment 5 Rich Megginson 2009-04-07 12:49:58 EDT
Try it again - should be fixed now.

There seems to be a lot of traffic today.  It took me 3 tries to download all of the packages due to network timeouts and other network failures.

Note You need to log in before you can comment on or make changes to this bug.