Bug 494592 - F11 beta installation fails, no driver for installation device.
F11 beta installation fails, no driver for installation device.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-07 11:26 EDT by Colin Leavett-Brown
Modified: 2010-06-28 07:43 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 07:43:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
smolt list created with smoltSendProfile. (6.47 KB, text/plain)
2009-04-07 11:28 EDT, Colin Leavett-Brown
no flags Details
lshal output run under Fedora7 (141.32 KB, text/plain)
2009-04-10 01:17 EDT, Colin Leavett-Brown
no flags Details
jpg of F11-Beta-i686-Live.iso output. (2.45 MB, image/jpeg)
2009-04-24 10:41 EDT, Colin Leavett-Brown
no flags Details
Live CD boot sequence jpgs (1.82 MB, application/x-gzip)
2009-04-24 20:32 EDT, Colin Leavett-Brown
no flags Details

  None (edit)
Description Colin Leavett-Brown 2009-04-07 11:26:11 EDT
Description of problem: F11 Beta installation, after selecting language and keyboard, "Install Method" dialog displayed, "Local CD/DVD" selected, then "No Driver Found" dialog displayed. 


Version-Release number of selected component (if applicable):
F11 Beta.

How reproducible:
Very.

Steps to Reproduce:
1. Insert installation dvd and reboot.
2. Select install/upgrade option from menu.
3. Select language, keyboard, install from local cd/dvd.
  
Actual results:
No driver available for local cd/dvd?


Expected results:
Not expecting to see dialog to select installation method.


Additional info:
Smolt list attached.
Comment 1 Colin Leavett-Brown 2009-04-07 11:28:08 EDT
Created attachment 338519 [details]
smolt list created with smoltSendProfile.
Comment 2 Chris Lumens 2009-04-09 10:29:48 EDT
Is there anything unusual about your drive?  If you pick a non-CD method and get into stage2, can you switch to tty2, run lshal, and attach the results of that to this bug report?  Thanks.
Comment 3 Colin Leavett-Brown 2009-04-10 01:17:58 EDT
Created attachment 339058 [details]
lshal output run under Fedora7
Comment 4 Colin Leavett-Brown 2009-04-10 01:25:16 EDT
Sata dvd-rw, nothing unusual. When selecting the DVD drive as the boot drive, it appears as the third sata hard drive in the list.

This time I picked "Install from NFS". Tried to access TTYs via Alt-F1, Alt-F2, etc. TTYs unresponsive and could not run lshal from F11 beta installation. Alt-F3 accessed a progress log containing the following error:

ERROR    :   got to setup CDROM without a CD drive.

Last message of log also indicated that Stage2 had been started.

After reverting to F7 to file this report, ran "lshal >/tmp/F7-lshal" and attached it to this report.
Comment 5 Colin Leavett-Brown 2009-04-10 16:30:59 EDT
If "install from hard drive" is selected, then the partition dialog lists only sda1, sda2, and sdb. It does not list a third hard drive (sdc) for the dvd device as might be implied by the boot list dialog (see first para from comment #4).
Comment 6 Colin Leavett-Brown 2009-04-16 00:34:54 EDT
Any update?
Comment 7 Chris Lumens 2009-04-23 17:31:40 EDT
This is a bit of a long shot, but I wonder if it would be possible for you to boot up the livecd and see if the drive is detected there.  It'd be interesting to see what modules are loaded (use lsmod), what a more recent lshal thinks, etc.  I don't really see anything in your attached information right now that indicates why your drive isn't detected.
Comment 8 Colin Leavett-Brown 2009-04-24 10:37:41 EDT
Downloaded F11-Beta-i686-Live.iso, cut a DVD and rebooted from the DVD - light blue Fedora splash screen with white progression bar growing from the bottom left corner toward the bottom right corner of the screen. When progression bar completed (reached bottom right) waited for somewhere between 30 and 60 seconds before display replaced with black screen and "Cannot find root file system" warning message (see attached jpg for this and other messages) and shell prompt. Issued "lshal" (command not found) and "lsmod" (half a dozen modules listed). Please see attached jpg for details of output.
Comment 9 Colin Leavett-Brown 2009-04-24 10:41:08 EDT
Created attachment 341182 [details]
jpg of F11-Beta-i686-Live.iso output.
Comment 10 Chris Lumens 2009-04-24 12:21:12 EDT
This looks more and more like whatever drivers required to support your DVD drive are not present.  Dave - could you comment about what drivers are required and perhaps if we've somehow even lost support for this device?  Thanks.
Comment 11 Chris Lumens 2009-04-24 16:32:48 EDT
Colin - this is going to be a little weird.  When you are booting up the DVD, do you get a dialog telling you it can't find the media, followed by the option to reboot or retry?  If so, could you hit retry over and over again to see if it eventually works?  Dave says he's seen this before and sometimes the drive will figure things out if asked to retry a whole bunch of times.

We've seen a couple bugs now where the drive spins down and then when it needs to spin back up again for a read, it isn't able to and the reads start to fail.  We don't know what's going on with that, but that appears to be the common factor.  Perhaps you are one of the lucky people hitting this problem.  Does the drive spin down at some point and then sound like it's having trouble spinning back up later, or not spinning back up at all?
Comment 12 Colin Leavett-Brown 2009-04-24 20:31:33 EDT
Hi Chris, I have not been getting the "can't find media dialog" or options to reboot or retry. Also once the drive spins up, it seems to stay spinning for the entire boot sequence. My next update (once I get through with this one) will be a set of 7 jpgs showing the major interactions when booting the Live CD. The following is a commentary related to those pictures and the boot sequence:

1.jpg - AMIBIOS display showing that I have already requested the "Boot Selection Popup Menu" by pressing F8 (middle of the picture); I have found that this is the only reliable way to select the boot device when multiple devices have bootable media.

2.jpg - SATA Promise display replaces the AMIBIOS display and lists all available SAT drives. The Promise driver also discovers a bootable CD/DVD in the drive and display the block message in the centre of the display. The DVD drive spins up at the time when the block message appears and seems to remain spinning for the remainder of the boot sequence.

3.jpg - SATA Promise display replaced by the "Boot Selection Menu". Three SATA drives are indicated; I am selecting the third one which is the DVD drive.

4.jpg - Just before the timer expires on this display, the activity light on the DVD drive starts to flash.

5.jpg - Sorry about the fuzziness but I thik you'll know what it says.

6.jpg - The activity light on the DVD drive continues to flash until the progress bar reaches about 90%, then a long pause until about 15 seconds after 100%, some more flashing (3 seconds) and then  the "Cannot find root filesystem" warning.

7.jpg - Having gone through the boot several times, I tried accessing the TTY1 (F1) when the progression splash screen is first displayed. This shows that other error messages are displayed prior to the "Cannot find root filesystem" message. I  have not found other errors on any of the other TTYs.
Comment 13 Colin Leavett-Brown 2009-04-24 20:32:53 EDT
Created attachment 341260 [details]
Live CD boot sequence jpgs
Comment 14 Colin Leavett-Brown 2009-04-25 21:15:22 EDT
Well, on second thoughts, your post from #11 might be on the right track. I thought I would see if the Ubuntu Live CD had any problems booting and I found that it did; COMRESET errors and kernel panics. Immediately tried the F11 Beta live CD and it booted. Tried it again and no go. I've now managed to boot it twice, in about 50 attempts. In attempting to boot the Live CD, I would always access TTY1 when the progression splash screen appears. If the first message was a COMRESET error, I would CTL+ALT+Del and try again. The first message on a successful attempt was "Unable to find oersistent overlay". Does the drive spin down during the boot? Well it slows down just exactly when the progression splash screen appears.
Comment 15 Colin Leavett-Brown 2009-04-26 21:01:11 EDT
Also, checked the drive firmware level and it is SB00; current version on the Samsung site is SB03. Downloaded the latest version to upgrade the drive, but it is embedded in a MS Windows executable. What do you think about upgrading the firmware (all levels say support is for 2000/XP/Vista) and do you have any guidance about how to do this under Fedora?
Comment 16 Colin Leavett-Brown 2009-05-04 00:01:17 EDT
Disconnected the TSSTcorp SATA DVD drive, plugged in the old coaster maker (Lite-On SOHW-1693S IDE DVD drive) tried the Live CD; booted just fine. So, please could you answer the following 4 questions:

1. Is there a problem free, recommended SATA DVDRW drive with better support for Linux from the manufacturer? Neither Samsung nor LG, the most recommended I've found, provide firmware support for Linux. 

2. Are any driver changes contemplated to overcome these, apparently wide spread, problems (web documents lots of problems with TSSYcorp/Samsung drives, even under Windows)? 

3. Assuming that it is a problem with the drive/firmware, how would you upgrade the firmware under Fedora (wine doesn't seem to help)?

4. Any other suggestions?

Thanks for your help.
Comment 17 Chris Lumens 2009-05-04 13:54:59 EDT
Reassigning to kernel to deal with these hardware/driver-specific questions.  Glad you at least have some idea on what's going on here.
Comment 18 Chuck Ebbert 2009-05-07 01:42:05 EDT
TSST DVD drives are notoriously buggy under linux.  One major problem is that many of them are not really SATA drives but are really old-style ATA drives with an internal SATA bridge.
Comment 19 Colin Leavett-Brown 2009-05-20 17:49:08 EDT
Okay, so I managed to get F11 Preview to install from the IDE DVD drive. However, F11 still does not recognize the presence of the SATA DVD. We're not trying to boot off it anymore, just trying to read off it, but the device does not appear to be visible to the OS. How should we proceed? Open a new report? Diagnostics?
Comment 20 Bug Zapper 2009-06-09 09:25:21 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 21 Bug Zapper 2010-04-27 09:32:40 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 22 Bug Zapper 2010-06-28 07:43:40 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.