Bug 494624 - Add tuna interface to perf-counters in 2.6.29 RT kernel
Add tuna interface to perf-counters in 2.6.29 RT kernel
Status: CLOSED DUPLICATE of bug 666958
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: realtime-utilities (Show other bugs)
Development
All Linux
low Severity medium
: ---
: ---
Assigned To: Arnaldo Carvalho de Melo
David Sommerseth
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-07 11:46 EDT by Clark Williams
Modified: 2016-05-22 19:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-08 09:34:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clark Williams 2009-04-07 11:46:46 EDT
Description of problem:

New CPU cores have a builtin set of registers known as performance counters or perfcounters. The 2.6.29-rtX RT patch series contains snapshots of the -tip versions of code to manage access to perfcounters. Tuna should add code to display the contents of available perfcounters during a tuning session.
Comment 1 Arnaldo Carvalho de Melo 2011-02-28 12:18:13 EST
Support for using the perf events to notice the creation/destruction of threads has been commited upstream and should get into a MRG test package soon.
Comment 2 Arnaldo Carvalho de Melo 2012-05-08 09:30:17 EDT
Tuna should use the perf infrastrucure to stop polling /proc and instead get perf events notifications for new threads.
Comment 3 Arnaldo Carvalho de Melo 2012-05-08 09:34:05 EDT

*** This bug has been marked as a duplicate of bug 666958 ***

Note You need to log in before you can comment on or make changes to this bug.