Bug 494675 - monodevelop freezes randomly
monodevelop freezes randomly
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: monodevelop (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Christian Krause
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-07 14:28 EDT by Fabian Deutsch
Modified: 2010-06-28 07:43 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 07:43:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Novell 492923 None None None Never

  None (edit)
Description Fabian Deutsch 2009-04-07 14:28:00 EDT
Description of problem:
md freezes randomly at no specific time or class or action. No exception is beeing thrown.

Version-Release number of selected component (if applicable):
1.fc11

How reproducible:
Quite regularly. Might be related to compiling (using F5).

Steps to Reproduce:
1. Open MD
2. Open your project
3. Do some things and compile your stuff quite often.
  
Actual results:
MD crashes after a couple of minutes/compilations.

Expected results:
MD behaves stable/

Additional info:
Comment 1 Paul F. Johnson 2009-04-16 11:26:18 EDT
Not happening at this end. Can you run it through mono-debugger and see if that puts anything up?
Comment 2 Lars Chebørløv brix 2009-04-30 14:58:41 EDT
I have the same problem.

In order to avoid restarting Monodevelop over and over I now build using:

mdtool build -c release solution.sln

It seems that once in a while mdtool hangs and this might cause monodevelop to hang.

I have seen it hang with the output:

MonoDevelop Build Tool

and:

MonoDevelop Build Tool
Loading solution: ./solution.sln
   Loading solution: ./solution.sln
      Loading projects ..
Comment 3 Lars Chebørløv brix 2009-04-30 15:05:01 EDT
BTW I am using monodevelop 2.0+ dfsg-2ubuntu1
Comment 4 Felix Möller 2009-05-28 15:24:38 EDT
The upstream bug linked to this was fixed with:
Index: monodevelop/main/src/addins/MonoDevelop.SourceEditor2/ChangeLog
===================================================================
--- monodevelop/main/src/addins/MonoDevelop.SourceEditor2/ChangeLog	(Revision 131297)
+++ monodevelop/main/src/addins/MonoDevelop.SourceEditor2/ChangeLog	(Revision 131298)
@@ -1,3 +1,10 @@
+2009-04-08  Mike Krüger  <mkrueger@novell.com>
+
+	* MonoDevelop.SourceEditor/AutoSave.cs:
+	* MonoDevelop.SourceEditor/EditActions.cs:
+	* MonoDevelop.SourceEditor/SourceEditorView.cs: Worked on "Bug
+	  492923 - MD hangs while editing text".
+

As https://bugzilla.novell.com/show_bug.cgi?id=492923#c3 states this bug was caused by the new autosave feature (added two days before).

The fedora build does not even include this new feature. Therefore the upstream bug certainly does not match exactly.
Comment 5 Bug Zapper 2009-06-09 09:26:21 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Christian Krause 2009-07-17 10:58:45 EDT
I've tried to reproduce the problem in a fully updated F11 installation, but I could not reproduce it so far.

Do you still see the problem?

if yes:
1. Which version of monodevelop and mono do you use?

2. please get a backtrace when monodevelop is hanging:
a) you should have started monodevelop in an xterm
b) killall -QUIT monodevelop

The backtrace will be printed out on the xterm. Please attach it to this bug report.
Comment 7 Fabian Deutsch 2009-07-17 12:31:19 EDT
This error did not appear again.
If so i'll repoen this bug.
Comment 8 Fabian Deutsch 2009-08-18 12:48:42 EDT
I have to reopen this bug.
This bug might be related to the MVC oder Texttemplate Addin.

As tinkering around with an MVC app, MD ist just unusable as it crashes every couple of minutes.
Comment 9 Fabian Deutsch 2009-08-18 13:02:23 EDT
A way to reproduce this problem quite:
1. Create a new ASP.NET MVC project
2. Edit Views/Home/index.aspx
3. Press Strg+s (Save) while moving the mouse over the code-view
4. Run the application
4. MD freezes.

I also experience this bug more often when mousetweaks is running.
Comment 10 Michel Alexandre Salim 2009-09-21 04:21:24 EDT
Well, since Lars is on Ubuntu, this is clearly an upstream bug.

For those on Fedora, does the updated Mono 2.4.2.3 help? Otherwise, try also installing the new monodevelop 2.1.0 from Rawhide.
Comment 11 Steve Joiner 2009-11-20 16:42:07 EST
I am also experiencing this bug where monodevelop freezes at seemingly random times.  I am using Fedora 11 with the latest updates.  Here are my versions:

monodevelop-2.0-7.fc11.i586
mono-core-2.4.2.3-2.fc11.i586

Here is a backtrace after the freeze happens.

"<unnamed thread>" tid=0x0x9d4b40 this=0x0x3eed8 thread handle 0x404 state : not waiting owns ()
  at (wrapper managed-to-native) object.__icall_wrapper_mono_array_new_specific (intptr,int) <0x00004>
  at (wrapper managed-to-native) object.__icall_wrapper_mono_array_new_specific (intptr,int) <0xffffffff>
  at System.Text.Encoding.GetChars (byte[],int,int) <0x0002f>
  at System.Text.Encoding.GetString (byte[],int,int) <0x0001c>
  at System.Text.UTF8Encoding.GetString (byte[],int,int) <0x00016>
  at System.Text.Encoding.GetString (byte[]) <0x00026>
  at GLib.Marshaller.Utf8PtrToString (intptr) <0x00087>
  at Gtk.ToolButton.get_Label () <0x00022>
  at MonoDevelop.Components.Commands.CommandToolButton.Update (MonoDevelop.Components.Commands.CommandInfo) <0x00053>
  at MonoDevelop.Components.Commands.CommandToolButton.MonoDevelop.Components.Commands.ICommandUserItem.Update (object) <0x0003d>
  at MonoDevelop.Components.Commands.CommandToolbar.Update (object) <0x0018b>
  at MonoDevelop.Components.Commands.CommandManager.UpdateToolbars () <0x000aa>
  at MonoDevelop.Components.Commands.CommandManager.UpdateStatus () <0x0001a>
  at GLib.Timeout/TimeoutProxy.Handler () <0x00034>
  at (wrapper native-to-managed) GLib.Timeout/TimeoutProxy.Handler () <0xffffffff>
  at (wrapper managed-to-native) Gtk.Application.gtk_main () <0x00004>
  at (wrapper managed-to-native) Gtk.Application.gtk_main () <0xffffffff>
  at Gtk.Application.Run () <0x0000a>
  at MonoDevelop.Ide.Gui.IdeApp.Run () <0x0000a>
  at MonoDevelop.Ide.Gui.IdeStartup.Run (string[]) <0x00bc3>
  at MonoDevelop.Startup.SharpDevelopMain.Main (string[]) <0x00061>
  at (wrapper runtime-invoke) MonoDevelop.Startup.SharpDevelopMain.runtime_invoke_int_object (object,intptr,intptr,intptr) <0xffffffff>
Comment 12 Steve Joiner 2009-11-23 16:26:47 EST
Running monodevelop with the --debug option makes this problem go away for me.
Comment 13 Bug Zapper 2010-04-27 09:33:00 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 14 Bug Zapper 2010-06-28 07:43:59 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.