This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 494702 - iss_parent line in rhn_server_iss.conf does not work
iss_parent line in rhn_server_iss.conf does not work
Status: CLOSED NOTABUG
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Satellite Synchronization (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Pradeep Kilambi
Jeff Browning
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-07 16:08 EDT by Jeff Browning
Modified: 2009-04-08 17:02 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-07 17:10:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Browning 2009-04-07 16:08:58 EDT
Description of problem:
The iss_parent option in the rhn_server_iss.conf file does not actually impact the satellite-sync command.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Install two satellites (master and slave)
2. Copy the RHN-ORG-TRUSTED-SSL-CERT from the master to the slave
3. Add the slave to the master's rhn_server_iss.conf as a permitted slave and restard the httpd on the master.
4. On the slave, add the following lines to the rhn_server_iss.conf file

iss_ca_chain=<path of RHN-ORG-TRUSTED-SSL-CERT>
iss_parent=<master satellite>

5. Restart httpd on the slave.
6. On the slave, run a satellite-sync -l
  
Actual results:
The sync contacts webqa rather than the master satellite defined in the conf file.

Expected results:
Since the CERT and the master are both defined in the .conf file, the satellite-sync should default to the master when no alternative iss-parent= is defined.

Additional info:
Defining the iss-parent= in the command line works as expected. Thus, the iss_ca_chain line is working.
Comment 1 Pradeep Kilambi 2009-04-07 17:10:34 EDT
your step-4 is incorrect:

its rhn_server.conf on slave, not rhn_server_iss.conf

# Name of parent for ISS.
# # If left blank rhn_parent is taken by default.
# # This option can be overriden on satellite-sync command line.
iss_parent      =
iss_ca_chain    = /usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT

Note You need to log in before you can comment on or make changes to this bug.