This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 494741 - LOOKUP function does not work as expected on unsorted search vector
LOOKUP function does not work as expected on unsorted search vector
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openoffice.org (Show other bugs)
5.2
i386 Linux
low Severity medium
: rc
: ---
Assigned To: Caolan McNamara
desktop-bugs@redhat.com
:
: 583490 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-07 19:07 EDT by Dmitri Pal
Modified: 2010-04-19 03:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-08 11:36:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
demo using hlookup (8.98 KB, application/vnd.oasis.opendocument.spreadsheet)
2009-04-08 11:33 EDT, Caolan McNamara
no flags Details

  None (edit)
Comment 4 Caolan McNamara 2009-04-08 11:33:17 EDT
Created attachment 338732 [details]
demo using hlookup
Comment 5 Caolan McNamara 2009-04-08 11:36:17 EDT
"The search vector for the LOOKUP must be sorted ascending, otherwise the search will not return any usable results."

Which is also the case for Excel (which presumably is where this misery originated), and 
Low
Medium
High
Giant
is not in alphabetical order.

This can be pulled off with HLOOKUP and the flag for "don't sort" as in the attached example, but LOOKUP requires a sorted search vector.
Comment 7 Caolan McNamara 2010-04-19 03:54:56 EDT
*** Bug 583490 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.