Bug 494749 - virt-manager 0.7.0 can't connect to centos 5.3 localhost in rw mode
virt-manager 0.7.0 can't connect to centos 5.3 localhost in rw mode
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: virt-manager (Show other bugs)
unspecified
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Berrange
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-07 20:08 EDT by Joseph Shraibman
Modified: 2010-03-16 13:18 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-24 15:02:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joseph Shraibman 2009-04-07 20:08:37 EDT
Description of problem:
[Tue, 07 Apr 2009 16:17:41 virt-manager 20811] DEBUG (connection:431) Scheduling background open thread for qemu:///system
[Tue, 07 Apr 2009 16:17:41 virt-manager 20811] DEBUG (connection:561) Background thread is running
[Tue, 07 Apr 2009 16:17:41 virt-manager 20811] ERROR (connection:551) Read/write connection failed for qemu:///system, falling back on read-only.
Traceback (most recent call last):
  File "/usr/local/share/virt-manager/virtManager/connection.py", line 536, in _try_open
    self.vmm = libvirt.openAuth(self.uri,
AttributeError: 'module' object has no attribute 'openAuth'
[Tue, 07 Apr 2009 16:17:41 virt-manager 20811] DEBUG (connection:599) Background open thread complete, scheduling notify
[Tue, 07 Apr 2009 16:17:41 virt-manager 20811] DEBUG (connection:608) Notifying open result

Version-Release number of selected component (if applicable):
0.7.0 built from tarball

How reproducible:
Actually I can't reproduce it anymore.  I kept switching back between the built-in virt-manager and 0.7.0, and I don't know what I did but now when I start 0.7.0 I get:

[Tue, 07 Apr 2009 19:36:29 virt-manager 21457] INFO (virt-manager:127) Application startup
[Tue, 07 Apr 2009 19:36:30 virt-manager 21458] DEBUG (engine:74) About to connect to uris ['qemu:///system']
[Tue, 07 Apr 2009 19:36:30 virt-manager 21458] DEBUG (connection:156) Bonding masters are: None
[Tue, 07 Apr 2009 19:36:30 virt-manager 21458] DEBUG (connection:179) Got physical device /org/freedesktop/Hal/devices/net_00_30_48_c6_55_
e0
[Tue, 07 Apr 2009 19:36:30 virt-manager 21458] DEBUG (connection:241) Adding net device eth0 00:30:48:c6:55:e0 /sys/class/net/eth0 bridge
br0
[Tue, 07 Apr 2009 19:36:30 virt-manager 21458] DEBUG (connection:213) Checking for VLANs on /sys/class/net/eth0
[Tue, 07 Apr 2009 19:36:30 virt-manager 21458] DEBUG (connection:179) Got physical device /org/freedesktop/Hal/devices/net_00_30_48_c6_55_
e1
[Tue, 07 Apr 2009 19:36:30 virt-manager 21458] DEBUG (connection:241) Adding net device eth1 00:30:48:c6:55:e1 /sys/class/net/eth1 bridge
br1
[Tue, 07 Apr 2009 19:36:30 virt-manager 21458] DEBUG (connection:213) Checking for VLANs on /sys/class/net/eth1
[Tue, 07 Apr 2009 19:36:30 virt-manager 21458] ERROR (virt-manager:323) 'NoneType' object has no attribute 'set_active'

So I don't even get far enough to try to connect.

Additional Info:
> rpm -qa | egrep "(virt|kvm|qemu)"
libvirt-python-0.3.3-14.el5_3.1
kmod-kvm-36-3
libvirt-0.3.3-14.el5_3.1
virt-viewer-0.0.2-2.el5
qemu-0.10.1-1.el5.rf
kvm-36-1
python-virtinst-0.300.2-12.el5
virt-manager-0.5.3-10.el5
Comment 1 Cole Robinson 2009-04-15 12:23:21 EDT
This was brought up on the mailing list. My response there was:

The version of libvirt on your machine lacks the openAuth command, so we
are falling back to read-only mode. We could try to detect this and just
try the plain 'open' command instead.

That said, if you are using virt-manager 0.7.0 on centos, you should
probably update libvirt beyond the stock centos version as well, since
that is where most of the features come from.
Comment 2 R P Herrold 2009-04-15 12:35:42 EDT
I affirm that I too am reproduceably unable to connect top a completely stock CentOS 5.3 x86_64 dom0 instance, using virt-manager and the following packages:

As the original reporter has added non-stock items, I confirm his initial reporting issue against a stock 5.3 install.  Please advise if this needs to be cloned.  I see it is being carried against "Virtualization Tools 4.4", and the subject line mentions: "virt-manager 0.7.0", although his report also mentions virt-manager-0.5.3-10.el5  as the installed environment

-- Russ herrold

[herrold@centos-5 ~]$ rpm -qa | egrep "(virt|kvm|qemu)"
libvirt-0.3.3-14.el5_3.1
libvirt-0.3.3-14.el5_3.1
virt-viewer-0.0.2-2.el5
qemu-0.9.0-4
libvirt-python-0.3.3-14.el5_3.1
virt-manager-0.5.3-10.el5
python-virtinst-0.300.2-12.el5
[herrold@centos-5 ~]$

... each are completely stock CentOS 5.3 offerings.

[herrold@centos-5 ~]$ rpm -qi libvirt virt-viewer qemu libvirt-python virt-manager python-virtinst | grep  Host
Install Date: Thu 02 Apr 2009 09:53:07 AM EDT      Build Host: builder10.centos.org
Install Date: Thu 02 Apr 2009 09:53:08 AM EDT      Build Host: builder10.centos.org
Install Date: Tue 14 Apr 2009 03:17:27 PM EDT      Build Host: builder15.centos.org
Install Date: Tue 16 Sep 2008 05:43:56 PM EDT      Build Host: builder6
Install Date: Thu 02 Apr 2009 09:53:16 AM EDT      Build Host: builder10.centos.org
Install Date: Tue 14 Apr 2009 03:17:22 PM EDT      Build Host: builder10.centos.org
Install Date: Thu 02 Apr 2009 10:05:19 AM EDT      Build Host: builder16.centos.org
[herrold@centos-5 ~]$

There seems to be some missing dbus files, per strace:

[root@centos-5 ~]# strace virt-manager 2>&1  | grep ENOENT | tail -20
open("/usr/lib64/python2.4/site-packages/dbus/traceback.so", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.4/site-packages/dbus/tracebackmodule.so", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.4/site-packages/dbus/traceback.py", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.4/site-packages/dbus/traceback.pyc", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib64/python2.4/site-packages/dbus/decorators", 0x7fff4f0db1a0) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.4/site-packages/dbus/decorators.so", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.4/site-packages/dbus/decoratorsmodule.so", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib64/python2.4/site-packages/dbus/_util", 0x7fff4f0da010) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.4/site-packages/dbus/_util.so", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.4/site-packages/dbus/_utilmodule.so", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib64/python2.4/site-packages/dbus/re", 0x7fff4f0d8e80) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.4/site-packages/dbus/re.so", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.4/site-packages/dbus/remodule.so", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.4/site-packages/dbus/re.py", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.4/site-packages/dbus/re.pyc", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib64/python2.4/site-packages/dbus/inspect", 0x7fff4f0da010) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.4/site-packages/dbus/inspect.so", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.4/site-packages/dbus/inspectmodule.so", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.4/site-packages/dbus/inspect.py", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.4/site-packages/dbus/inspect.pyc", O_RDONLY) = -1 ENOENT (No such file or directory)
[root@centos-5 ~]#       
                      
No obviously missing package for these exists:

[herrold@centos-5 dbus]$ sudo yum whatprovides /usr/lib64/python2.4/site-packages/dbus/inspect.py
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
Importing additional filelist information
Warning: 3.0.x versions of yum would erronously match against filenames.
 You can use "*//usr/lib64/python2.4/site-packages/dbus/inspect.py" and/or "*bin//usr/lib64/python2.4/site-packages/dbus/inspect.py" to get that behaviour
No Matches found
[herrold@centos-5 dbus]$ sudo yum provides "*//usr/lib64/python2.4/site-packages/dbus/inspect.py"
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
No Matches found
[herrold@centos-5 dbus]$ sudo yum provides *//usr/lib64/python2.4/site-packages/dbus/inspect.py
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
No Matches found
[herrold@centos-5 dbus]$ 

Checking that directory (which appears to be un-owned):

[herrold@centos-5 dbus]$ pwd ; rpm -V dbus-python
/usr/lib64/python2.4/site-packages/dbus
[herrold@centos-5 dbus]$ 

[herrold@centos-5 ~]$ sudo rpm -V dbus ; rpm -q dbus ; sudo package-cleanup --problems
Password:
.......T  c /etc/rc.d/init.d/messagebus
.......T  d /usr/share/man/man1/dbus-cleanup-sockets.1.gz
.......T  d /usr/share/man/man1/dbus-daemon.1.gz
.......T  d /usr/share/man/man1/dbus-monitor.1.gz
.......T  d /usr/share/man/man1/dbus-send.1.gz
.......T  d /usr/share/man/man1/dbus-uuidgen.1.gz
.......T  c /etc/dbus-1/session.conf
S.5....T  c /etc/dbus-1/system.conf
dbus-1.1.2-12.el5
dbus-1.1.2-12.el5
Setting up yum
Reading local RPM database
Processing all local requires
No problems found
[herrold@centos-5 ~]$ 

I run it thru the following cleanup to clear the dbus rpm -V errors:

 1012  Apr 15 12:21 sudo rpm -e dbus --allmatches --nodeps
 1013  Apr 15 12:22 sudo rm -rf  /etc/dbus-1/session.conf /etc/dbus-1/system.conf /etc/rc.d/init.d/messagebus
 1014  Apr 15 12:22 sudo yum -y install dbus

As the dbus removal sometimes runs through a %pre or %post scripts error, I add this in some reproducers:

[herrold@centos-5 ~]$ sudo rpm -e dbus --allmatches --nodeps --noscripts

and follow it with relabel and reboot to remove SELinux state issues from the mix:

[herrold@centos-5 rc.d]$ sudo touch /.autorelabel
Comment 3 Cole Robinson 2009-09-24 15:02:19 EDT
This shouldn't be an issue anymore with current upstream, I believe. Closing as UPSTREAM.

Note You need to log in before you can comment on or make changes to this bug.