Bug 494778 - e100 driver will not work properly during F11 Beta install due to missing firmware
e100 driver will not work properly during F11 Beta install due to missing fir...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-08 00:01 EDT by Jason
Modified: 2009-09-10 10:17 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 10:17:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason 2009-04-08 00:01:16 EDT
Description of problem:
Cannot properly initialize the ethernet interface in Compaq DL380 using Fedora 11 Beta install medi.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Attempt to do a network install in F11 Beta, or have problem and attempt to initiate network for traceback utility.
  
Actual results:
network initialization fails

Expected results:
network initiaizes

Additional info:
'lspci -vv' output for interface:
00:02.0 Ethernet controller: Intel Corporation 82557/8/9/0/1 Ethernet Pro 100 (rev 08)
	Subsystem: Compaq Computer Corporation NC3163 Fast Ethernet NIC (embedded, WOL)
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 64 (2000ns min, 14000ns max), Cache Line Size: 32 bytes
	Interrupt: pin A routed to IRQ 11
	Region 0: Memory at c4fff000 (32-bit, non-prefetchable) [size=4K]
	Region 1: I/O ports at 2400 [size=64]
	Region 2: Memory at c4e00000 (32-bit, non-prefetchable) [size=1M]
	[virtual] Expansion ROM at 60000000 [disabled] [size=1M]
	Capabilities: [dc] Power Management version 2
		Flags: PMEClk- DSI+ D1+ D2+ AuxCurrent=0mA PME(D0+,D1+,D2+,D3hot+,D3cold+)
		Status: D0 PME-Enable- DSel=0 DScale=2 PME-
	Kernel driver in use: e100

'ifconfig -a' output:
eth0      Link encap:Ethernet  HWaddr 00:02:A5:29:3A:C2  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:6 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:504 (504.0 b)  TX bytes:504 (504.0 b)

'ifconfig eth0 up' output:
SIOCSIFFLAGS: No such file or directory

output on tty4 that looks related:
<6>e100 0000:00:02.0 firmware: requesting e100/d101m_ucode.bin
<3>e100 eth0: e100_request_firmware: Failed to load firmware "e100/d101m_ucode.bin": -2
<13>APr  7 22:57:33 firmware.sh[1798]: Cannot find  firmware file 'e100/d101m_ucode.bin'
Comment 1 Chuck Ebbert 2009-04-08 07:42:28 EDT
The file is in the kernel-firmware package, which should be on the install disk since the kernel requires that package.
Comment 2 Chris Lumens 2009-04-08 16:18:35 EDT
The problem here is that the e100 driver expects the firmware in a subdirectory, but we're just tossing them all into /lib/firmware.  This should be fixed in the next build of anaconda.
Comment 3 Bug Zapper 2009-06-09 09:28:10 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Matt Domsch 2009-06-13 23:43:56 EDT
I'm seeing this in Fedora 11 final.  Not sure what subdirectory it should be found in, but the kernel looks for e100/d101m_ucode.bin, and is failing to find it.
Comment 5 frank 2009-08-23 07:53:03 EDT
is there any work around in the meantime to get the e100 driver to look for firmware in the place where it currently is?  is there something that can be put on the install command line that will cause the driver to look where it can find the firmware?
Comment 6 Piotr Maślanka 2009-09-01 13:02:02 EDT
There is a workaround. Go to Rescue Mode, and after being dropped to shell issue:

cd /lib/firmware
cp e100/* .
anaconda

That should drop to graphical installer
Comment 7 Jason Montleon 2009-09-09 20:42:00 EDT
This card is working again in Fedora 12 Alpha.

Note You need to log in before you can comment on or make changes to this bug.