Bug 494864 - no way to give proxy option to yum easily
no way to give proxy option to yum easily
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-08 08:55 EDT by stef
Modified: 2014-01-21 18:08 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-08 09:01:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description stef 2009-04-08 08:55:33 EDT
Description of problem:
When you are behind a proxy server to access the world you have to give the option 'proxy=http://proxy.mydomain:port' in the /etc/yum.conf file.

However you have to edit manually this file since no GUI tool can give this option.
The 'Software Update Preferences' and 'Software Sources' tools does not give any option to specify an proxy, and the proxy preferences in 'Network Proxy Preferences' are just ignored.

A more user friendly tool is necessary here.

Version-Release number of selected component (if applicable):
ALL

How reproducible:
always

Steps to Reproduce:
1.be behind a proxy server
2.try to use yum or the 'Update System' tool
3.
  
Actual results:
fails due to being unable to get the repositories

Expected results:
yum uses the proxy preference defined in 'Network Proxy Preferences' or a new option in 'Software Sources'

Additional info:
Comment 1 seth vidal 2009-04-08 09:01:47 EDT
You can also define the proxy environment variable which yum will honor, like most other applications on the system do.
Comment 2 stef 2009-04-08 09:22:19 EDT
This is also true, but nevertheless you have to manually edit your .profile or your /etc/yum.conf, a graphical tool would be much more user-friendly for this.
Comment 3 seth vidal 2009-04-08 09:36:02 EDT
you can just set the proxy value on the commandline

PROXY=http://myproxy/ yum install foo


if you want a graphical app for setting environment variables I think you'll need to find a program dedicated to doing that b/c I don't think it is a yum bug.

Note You need to log in before you can comment on or make changes to this bug.