Bug 494867 - Rawhide i386 fails to boot - not syncing: No init found. Try passing init= option to kernel.
Rawhide i386 fails to boot - not syncing: No init found. Try passing init= o...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Blocker/F11FinalBlocker 494832
  Show dependency treegraph
 
Reported: 2009-04-08 09:26 EDT by James Laska
Modified: 2013-09-02 02:34 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-13 13:56:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Boot log (15.52 KB, text/plain)
2009-04-08 09:26 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2009-04-08 09:26:38 EDT
Created attachment 338707 [details]
Boot log

Description of problem:

Unable to boot rawhide/i386.  The boot process fails with:

Failed to execute /init
Kernel panic - not syncing: No init found.  Try passing init= option to kernel.

Version-Release number of selected component (if applicable):

anaconda-11.5.0.40-1.i586.rpm  kernel-2.6.29.1-52.fc11.i586.rpm
glibc-2.9.90-12.i586.rpm       rpm-4.7.0-0.beta1.9.fc11.i586.rpm
glibc-2.9.90-12.i686.rpm

How reproducible:


Steps to Reproduce:
1. Attempt to boot the boot.iso or pxeboot images from rawhide
  
Actual results:

See attached dmesg.log for complete boot log

Expected results:

Anaconda stage#1 should start


Additional info:
Comment 1 Panu Matilainen 2009-04-13 08:41:23 EDT
Possibly related to glibc.i586 breakage but unlikely have anything to do with rpm directly. Passing on to anaconda for now...
Comment 2 Chris Lumens 2009-04-13 11:35:06 EDT
Are you still seeing this?  I'm guessing not, since it looks like you're hitting the dbus thing now.
Comment 3 James Laska 2009-04-13 11:38:25 EDT
Thanks, I was going to revisit this once I got a little further into the install.  But you are right, I'm observing systems starting loader so I believe we can close this issue.  

I still have no idea what the root cause was?  Any thoughts?
Comment 4 Chris Lumens 2009-04-13 13:56:23 EDT
This definitely sounds like the glibc problems people were seeing the other day.  I do believe init is dynamically linked now and problems with the version of glibc on the initrd would lead to problems starting init.

Note You need to log in before you can comment on or make changes to this bug.