Bug 494880 - Uploading fails
Uploading fails
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mediawiki (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-08 10:25 EDT by Orion Poplawski
Modified: 2009-07-31 13:38 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.15.1-48.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-19 06:20:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2009-04-08 10:25:46 EDT
Description of problem:

With the current package, uploads default to /usr/share/mediawiki/images instead of the local wiki images directory.

This is the change I've used:

--- mediawiki-1.13.0/includes/Setup.php.orig    2008-08-08 04:19:27.000000000 -0600
+++ mediawiki-1.13.0/includes/Setup.php 2008-09-12 10:57:27.000000000 -0600
@@ -45,7 +45,7 @@
 if( $wgLogo === false ) $wgLogo = "$wgStylePath/common/images/wiki.png";

 if( $wgUploadPath === false ) $wgUploadPath = "$wgScriptPath/images";
-if( $wgUploadDirectory === false ) $wgUploadDirectory = "$IP/images";
+if( $wgUploadDirectory === false ) $wgUploadDirectory = "$DIR/images";

 if( $wgMathPath === false ) $wgMathPath = "{$wgUploadPath}/math";
 if( $wgMathDirectory === false ) $wgMathDirectory = "{$wgUploadDirectory}/math";

Version-Release number of selected component (if applicable):
mediawiki-1.14.0-45.el5
Comment 1 Ricky Zhou 2009-06-21 20:03:47 EDT
Hi, this is due to a Fedora-only patch that we're discussing in bug #484855. I'm going to mark this as a duplicate of that bug for now so that we can centralize discussion there, feel free to reopen if I'm mistaken in doing this.

*** This bug has been marked as a duplicate of bug 484855 ***
Comment 2 Fedora Update System 2009-07-11 16:55:16 EDT
mediawiki-1.15.0-47.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/mediawiki-1.15.0-47.fc10
Comment 3 Fedora Update System 2009-07-11 16:55:31 EDT
mediawiki-1.15.0-47.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/mediawiki-1.15.0-47.fc11
Comment 4 Fedora Update System 2009-07-19 06:20:30 EDT
mediawiki-1.15.1-48.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2009-07-19 06:33:47 EDT
mediawiki-1.15.1-48.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.