Bug 494882 - urlgrabber produces incorrect output over serial console
urlgrabber produces incorrect output over serial console
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-urlgrabber (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: James Antill
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-08 10:33 EDT by James Laska
Modified: 2013-09-02 02:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-08 11:01:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
console output (60.65 KB, text/plain)
2009-04-08 10:33 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2009-04-08 10:33:04 EDT
Created attachment 338716 [details]
console output

Description of problem:

When upgrading a system using 'yum upgrade' while connected via a serial console

Version-Release number of selected component (if applicable):

Tested rawhide and F-10 (python-urlgrabber-3.0.0-10.fc10)

How reproducible:


Steps to Reproduce:
1. Perform a virt install of rawhide (or F-10)
2. After install, boot the system
3. Run 'yum update' while connected to the serial console
  
Actual results:

See the "Downloading packages" section in http://fpaste.org/paste/8369 (also attached)

Expected results:


Additional info:
Comment 1 James Laska 2009-04-08 10:38:25 EDT
As recommended by James Antill, running the following script while connected to a serial console:

# python -c "import struct, termios, fcntl; fd=1; buf = 'abcdefgh'; buf = fcntl.ioctl(fd, termios.TIOCGWINSZ, buf); print struct.unpack('hhhh', buf)[1];"
0
Comment 2 James Antill 2009-04-08 11:01:56 EDT
 Please reopen if I screwed something up with the fix, thanks :).

http://koji.fedoraproject.org/koji/taskinfo?taskID=1285394
Comment 3 James Laska 2009-04-08 11:02:23 EDT
Testing with the above packages confirms the issue is fixed on serial consoles.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.