This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 494890 - Could not open the address “ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof”: Failed to execute child process "/usr/lib/firefox-3.0b4pre/firefox" (No such file or directory)
Could not open the address “ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof”: ...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-08 10:47 EDT by Michal Nowak
Modified: 2013-03-07 21:05 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-08 13:29:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Nowak 2009-04-08 10:47:41 EDT
Description of problem:

write FTP address ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof to gnome-terminal, point cursor on the link, press Control and Mouse1; this should open the link specified app (Firefox in my case). But the result is strange window without title and with text:

"""
Could not open the address “ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof”:
Failed to execute child process "/usr/lib/firefox-3.0b4pre/firefox" (No such file or directory)
"""

and the link is not open.

Version-Release number of selected component (if applicable):

gnome-terminal-2.26.0-1.fc11.x86_64

How reproducible:

always

Additional info:

Strange on this window is that the terminal itself still active but the error window is not in the task bar, resulting in not being able to select it via Mod-Tab. /usr/bin/firefox is the place where Firefox is located and should be used, perhaps.
Comment 1 Matthias Clasen 2009-04-08 11:56:52 EDT
gconftool-2 --type string -s /desktop/gnome/url-handlers/ftp/command "firefox %s"

should fix things for you. 

I guess this is firefox installing itself as default ftp handler, and getting it wrong...
Comment 2 Christopher Aillon 2009-04-08 13:29:10 EDT
This actually sounds like you downloaded an upstream binary, and let it set itself as the default.  We disable that bit in our builds because gnome-default-applications-properties is the preferred method, and because firefox gets it wrong.
Comment 3 Michal Nowak 2009-04-08 13:38:47 EDT
True. The problem's not present in fresh Rawhide install.

Note You need to log in before you can comment on or make changes to this bug.