Bug 494922 - Intel multihead on ThinkPad X200 doesn't work
Intel multihead on ThinkPad X200 doesn't work
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-08 14:09 EDT by Amit Shah
Modified: 2014-06-23 08:59 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 07:44:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (132.92 KB, text/plain)
2009-04-16 02:16 EDT, Amit Shah
no flags Details

  None (edit)
Description Amit Shah 2009-04-08 14:09:51 EDT
Description of problem:

http://www.smolts.org/client/show/pub_5641980e-0bae-43f8-a38e-7432d580a0f1

I have the Live USB of the F11 Beta release made from the 64-bit gnome live cd.

- Booting with VGA monitor connected: no display on external monitor at all

- gnome-display-properties:
  - Shows one Lenovo monitor and two "unknown" monitors. Identifies my laptop screen as unknown as well as lenovo (top left corner of the screen shows multiple overlapped boxes in diff. colours)
   - shows one of the unknown monitors as 'on' but there's no display.
   - Fn+F7 doesn't actually do anything (switch between laptop and ext. displays)

I also tried:
- switch all 'unknown' monitors to 'off' (initially, 3 of those)
- then there was only one unknown alongside the lenovo one
- switch it 'on'
- the 'unknown' one got cloned and there were more
- still no display on the external monitor
- If I click 'apply', laptop screen is "shifted" to the left, can only see a part of the screen. I wait for the timeout for the screen to be restored but that doesn't happen, instead the screen goes blank.
- Switch to a VT, that doesn't work. But if I switch to ctrl+alt+f1, I get shown VT2 but it doesn't accept any input. I can then switch to VTs 3, 4, etc. A switch to VT 1 dumps the text in VT2 but doesn't accept any input (X might be dead?) xorg.0.log doesn't have anything interesting.

dmesg has lots of these:
i915 0000:00:02.0: VGA-1: no EDID data
i915 0000:00:02.0: VGA-1: no EDID data
i2c-adapter i2c-2: unable to read EDID block.
i915 0000:00:02.0: DVI-D-1: no EDID data
i2c-adapter i2c-2: unable to read EDID block.
i915 0000:00:02.0: DVI-D-1: no EDID data
i2c-adapter i2c-3: unable to read EDID block.
i915 0000:00:02.0: DVI-D-2: no EDID data
i2c-adapter i2c-3: unable to read EDID block.
i915 0000:00:02.0: DVI-D-2: no EDID data

I also noted there was one line that said something like 'invalid framebuffer 14' at the tail of the dmesg output from the drm subsystem (don't have the exact line, sorry).

xrandr output:
Screen 0: minimum 320 x 200, current 1280 x 800, maximum 8192 x 8192
VGA1 connected (normal left inverted right x axis y axis)
   1024x768       60.0  
   800x600        60.3  
   640x480        59.9  
LVDS1 connected 1280x800+0+0 (normal left inverted right x axis y axis) 261mm x 163mm
   1280x800       60.0*+   50.0  
DVI1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768       60.0* 
   800x600        60.3  
   640x480        59.9  
DVI2 connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768       60.0* 
   800x600        60.3  
   640x480        59.9
Comment 1 Matěj Cepl 2009-04-10 11:31:49 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available), /var/log/dmesg, and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Amit Shah 2009-04-16 02:16:07 EDT
Created attachment 339790 [details]
Xorg.0.log
Comment 3 Amit Shah 2009-04-16 02:17:33 EDT
No xorg.conf; attached Xorg.0.log.

I tested this with F11-snap1 as well.

BTW, I also get a lot of these in my kernel dmesg:

Xorg:3382 freeing invalid memtype d685b000-d685c000
Xorg:3382 freeing invalid memtype d685c000-d685d000
Xorg:3382 freeing invalid memtype d685d000-d685e000
Xorg:3382 freeing invalid memtype d685e000-d685f000
Xorg:3382 freeing invalid memtype d685f000-d6860000
Xorg:3382 freeing invalid memtype d6860000-d6861000
Xorg:3382 freeing invalid memtype d6861000-d6862000

...

Xorg:3382 freeing invalid memtype d74f5000-d74f6000
Xorg:3382 freeing invalid memtype d74f6000-d74f7000
Xorg:3382 freeing invalid memtype d74f7000-d74f8000
Xorg:3382 freeing invalid memtype d74f8000-d74f9000
Xorg:3382 freeing invalid memtype d74f9000-d74fa000
Xorg:3382 freeing invalid memtype d74fa000-d74fb000
Xorg:3382 freeing invalid memtype d74fb000-d74fc000
Xorg:3382 freeing invalid memtype d74fc000-d74fd000
Xorg:3382 freeing invalid memtype d74fd000-d74fe000
Xorg:3382 freeing invalid memtype d74fe000-d74ff000
Xorg:3382 freeing invalid memtype d74ff000-d7500000
Comment 4 Adam Williamson 2009-04-16 18:29:16 EDT
Thanks for the info. One more thing: can you test with KMS disabled? Boot with 'nomodeset' as a kernel parameter, and see if that changes the behaviour. Thanks!

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Amit Shah 2009-04-25 00:22:08 EDT
bug 494923 has the details of how multihead behaves with kms and without kms on my laptop and the relevant xorg.log and xrandr output.

I tried this without kms and I could only "mirror" the outputs -- when both my vga and lvds were restricted to 1024x768. I couldn't have a left/right setting since my lvds was set to 1280x800 and the vga out was capped at 1024x768.
Comment 6 Adam Williamson 2009-04-28 19:33:47 EDT
oh, you'll need to add a Virtual line to /etc/X11/xorg.conf for side-by-side configuration to work with KMS disabled.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Bug Zapper 2009-06-09 09:30:02 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Matěj Cepl 2009-11-05 13:25:48 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages. For packages from updates-testing repository you can use command

yum upgrade --enablerepo='*-updates-testing'

Alternatively, you can also try to test whether this bug is reproducible with the upcoming Fedora 12 distribution by downloading LiveMedia of F12 Beta available at http://alt.fedoraproject.org/pub/alt/nightly-composes/ . By using that you get all the latest packages without need to install anything on your computer. For more information on using LiveMedia take a look at https://fedoraproject.org/wiki/FedoraLiveCD .

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 10 Matěj Cepl 2010-02-26 07:25:52 EST
Could you please reply to the previous question? If you won't reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[Note please, that this is machine generated comment for large amount of bugs; due to some technical issues, it is possible we've missed some of the responses -- it is happens, please, just a make a comment about that; that we will see. Thank you]
Comment 11 Bug Zapper 2010-04-27 09:34:15 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 Bug Zapper 2010-06-28 07:44:58 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.