Bug 494960 - Cannot install tomcat5-jsp and thus eclipse-cdt
Cannot install tomcat5-jsp and thus eclipse-cdt
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: tomcat5 (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Devrim GÜNDÜZ
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Blocker/F11FinalBlocker
  Show dependency treegraph
 
Reported: 2009-04-08 16:09 EDT by Matěj Cepl
Modified: 2009-04-15 15:23 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-15 15:06:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matěj Cepl 2009-04-08 16:09:54 EDT
[root@viklef tmp]# yum install eclipse-cdt 
Loaded plugins: aliases, allowdowngrade, changelog, dellsysidplugin2,
              : fastestmirror, list-data, merge-conf, remove-with-leaves,
              : security, verify
Loading mirror speeds from cached hostfile
 * livna: ftp-stud.fht-esslingen.de
livna                                                    | 2.4 kB     00:00     
rawhide                                                  | 3.4 kB     00:00     
rawhide-debuginfo                                        | 2.7 kB     00:00     
rpmfusion-free-rawhide                                   | 3.3 kB     00:00     
rpmfusion-nonfree-rawhide                                | 3.3 kB     00:00     
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package eclipse-cdt.x86_64 1:5.0.1-4.fc11 set to be updated
--> Processing Dependency: eclipse-platform >= 1:3.4.0 for package: eclipse-cdt
--> Processing Dependency: eclipse-platform for package: eclipse-cdt
--> Running transaction check
---> Package eclipse-platform.x86_64 1:3.4.2-9.fc11 set to be updated
--> Processing Dependency: eclipse-rcp = 1:3.4.2-9.fc11 for package: eclipse-platform
--> Processing Dependency: sat4j >= 2.0.3 for package: eclipse-platform
--> Processing Dependency: jakarta-commons-el >= 1.0-9 for package: eclipse-platform
--> Processing Dependency: tomcat5-jasper-eclipse >= 5.5.26-1.5 for package: eclipse-platform
--> Processing Dependency: jetty >= 5.1.14-1.6 for package: eclipse-platform
--> Processing Dependency: lucene-contrib >= 2.3.1-3.4 for package: eclipse-platform
--> Processing Dependency: jsch >= 0.1.39 for package: eclipse-platform
--> Processing Dependency: mx4j >= 2.1 for package: eclipse-platform
--> Processing Dependency: jakarta-commons-launcher for package: eclipse-platform
--> Processing Dependency: ant-jsch for package: eclipse-platform
--> Processing Dependency: ant-commons-net for package: eclipse-platform
--> Processing Dependency: ant-apache-bcel for package: eclipse-platform
--> Processing Dependency: ant-apache-resolver for package: eclipse-platform
--> Processing Dependency: ant-apache-log4j for package: eclipse-platform
--> Processing Dependency: ant-apache-bsf for package: eclipse-platform
--> Processing Dependency: ant-nodeps for package: eclipse-platform
--> Processing Dependency: jakarta-commons-pool for package: eclipse-platform
--> Processing Dependency: ant-trax for package: eclipse-platform
--> Processing Dependency: ant-swing for package: eclipse-platform
--> Processing Dependency: ant-commons-logging for package: eclipse-platform
--> Processing Dependency: jakarta-commons-dbcp for package: eclipse-platform
--> Processing Dependency: regexp for package: eclipse-platform
--> Processing Dependency: ant-apache-oro for package: eclipse-platform
--> Processing Dependency: ant-apache-regexp for package: eclipse-platform
--> Processing Dependency: ant-antlr for package: eclipse-platform
--> Processing Dependency: jakarta-commons-digester for package: eclipse-platform
--> Processing Dependency: jakarta-commons-beanutils for package: eclipse-platform
--> Processing Dependency: jakarta-commons-fileupload for package: eclipse-platform
--> Processing Dependency: ant-junit for package: eclipse-platform
--> Processing Dependency: jakarta-commons-collections for package: eclipse-platform
--> Processing Dependency: jakarta-commons-modeler for package: eclipse-platform
--> Processing Dependency: ant-javamail for package: eclipse-platform
--> Processing Dependency: ant-jdepend for package: eclipse-platform
--> Running transaction check
---> Package ant-antlr.x86_64 0:1.7.1-9.2.fc11 set to be updated
--> Processing Dependency: ant = 1.7.1-9.2.fc11 for package: ant-antlr
--> Processing Dependency: antlr for package: ant-antlr
---> Package ant-apache-bcel.x86_64 0:1.7.1-9.2.fc11 set to be updated
--> Processing Dependency: bcel for package: ant-apache-bcel
---> Package ant-apache-bsf.x86_64 0:1.7.1-9.2.fc11 set to be updated
--> Processing Dependency: bsf for package: ant-apache-bsf
---> Package ant-apache-log4j.x86_64 0:1.7.1-9.2.fc11 set to be updated
--> Processing Dependency: log4j for package: ant-apache-log4j
---> Package ant-apache-oro.x86_64 0:1.7.1-9.2.fc11 set to be updated
--> Processing Dependency: oro for package: ant-apache-oro
---> Package ant-apache-regexp.x86_64 0:1.7.1-9.2.fc11 set to be updated
---> Package ant-apache-resolver.x86_64 0:1.7.1-9.2.fc11 set to be updated
---> Package ant-commons-logging.x86_64 0:1.7.1-9.2.fc11 set to be updated
---> Package ant-commons-net.x86_64 0:1.7.1-9.2.fc11 set to be updated
--> Processing Dependency: jakarta-commons-net for package: ant-commons-net
---> Package ant-javamail.x86_64 0:1.7.1-9.2.fc11 set to be updated
--> Processing Dependency: jaf >= 1.0.1-5jpp for package: ant-javamail
--> Processing Dependency: javamail >= 1.2-5jpp for package: ant-javamail
---> Package ant-jdepend.x86_64 0:1.7.1-9.2.fc11 set to be updated
--> Processing Dependency: jdepend for package: ant-jdepend
---> Package ant-jsch.x86_64 0:1.7.1-9.2.fc11 set to be updated
---> Package ant-junit.x86_64 0:1.7.1-9.2.fc11 set to be updated
--> Processing Dependency: junit for package: ant-junit
---> Package ant-nodeps.x86_64 0:1.7.1-9.2.fc11 set to be updated
---> Package ant-swing.x86_64 0:1.7.1-9.2.fc11 set to be updated
---> Package ant-trax.x86_64 0:1.7.1-9.2.fc11 set to be updated
---> Package eclipse-rcp.x86_64 1:3.4.2-9.fc11 set to be updated
--> Processing Dependency: eclipse-swt = 1:3.4.2-9.fc11 for package: eclipse-rcp
--> Processing Dependency: icu4j-eclipse >= 3.8.1-3 for package: eclipse-rcp
---> Package jakarta-commons-beanutils.x86_64 0:1.7.0-11.3.fc11 set to be updated
---> Package jakarta-commons-collections.x86_64 0:3.2.1-2.fc11 set to be updated
---> Package jakarta-commons-dbcp.x86_64 0:1.2.1-12.5.fc11 set to be updated
---> Package jakarta-commons-digester.x86_64 0:1.7-8.3.fc11 set to be updated
---> Package jakarta-commons-el.x86_64 0:1.0-9.4.fc10 set to be updated
---> Package jakarta-commons-fileupload.x86_64 1:1.0-8.3.fc11 set to be updated
---> Package jakarta-commons-launcher.x86_64 0:1.1-3.4.fc11 set to be updated
---> Package jakarta-commons-modeler.x86_64 0:2.0-5.3.fc11 set to be updated
---> Package jakarta-commons-pool.x86_64 0:1.3-11.5.fc11 set to be updated
---> Package jetty.x86_64 0:5.1.14-2.10.fc11 set to be updated
--> Processing Dependency: tomcat5-jasper >= 5.5.26-1.5 for package: jetty
--> Processing Dependency: jsp for package: jetty
---> Package jsch.noarch 0:0.1.39-2.1.fc11 set to be updated
--> Processing Dependency: jzlib >= 1.0.5 for package: jsch
---> Package lucene-contrib.x86_64 0:2.3.1-4.4.fc11 set to be updated
---> Package mx4j.x86_64 1:3.0.1-7.9.fc11 set to be updated
--> Processing Dependency: axis >= 1.1 for package: mx4j
---> Package regexp.x86_64 0:1.5-3.2.fc11 set to be updated
---> Package sat4j.noarch 0:2.0.3-1.fc11 set to be updated
---> Package tomcat5-jasper-eclipse.noarch 0:5.5.27-5.9.fc11 set to be updated
--> Running transaction check
---> Package ant.x86_64 0:1.7.1-9.2.fc11 set to be updated
--> Processing Dependency: java-devel >= 1.5.0 for package: ant
---> Package antlr.x86_64 0:2.7.7-5.fc11 set to be updated
---> Package axis.x86_64 0:1.2.1-4.1.fc10 set to be updated
--> Processing Dependency: wsdl4j for package: axis
--> Processing Dependency: jakarta-commons-discovery for package: axis
---> Package bcel.x86_64 0:5.2-6.1.fc11 set to be updated
---> Package bsf.x86_64 0:2.3.0-14.fc11 set to be updated
--> Processing Dependency: tomcat5-jsp-2.0-api for package: bsf
---> Package classpathx-jaf.x86_64 0:1.0-12.fc10 set to be updated
---> Package classpathx-mail.x86_64 0:1.1.1-8.1.fc11 set to be updated
---> Package eclipse-swt.x86_64 1:3.4.2-9.fc11 set to be updated
---> Package icu4j-eclipse.x86_64 0:3.8.1-5.fc11 set to be updated
---> Package jakarta-commons-net.noarch 0:1.4.1-5.3.fc11 set to be updated
---> Package jakarta-oro.x86_64 0:2.0.8-5.2.fc11 set to be updated
---> Package jdepend.x86_64 0:2.6-8.4.fc11 set to be updated
---> Package junit.x86_64 0:3.8.2-5.4.fc11 set to be updated
---> Package jzlib.x86_64 0:1.0.7-6.3.fc11 set to be updated
---> Package log4j.x86_64 0:1.2.14-5.3.fc11 set to be updated
---> Package tomcat5-jasper.noarch 0:5.5.27-5.9.fc11 set to be updated
--> Processing Dependency: tomcat5-servlet-2.4-api = 5.5.27-5.9.fc11 for package: tomcat5-jasper
---> Package tomcat6-jsp-2.1-api.noarch 0:6.0.18-9.2.fc11 set to be updated
--> Processing Dependency: tomcat6-servlet-2.5-api = 6.0.18-9.2.fc11 for package: tomcat6-jsp-2.1-api
--> Running transaction check
---> Package jakarta-commons-discovery.x86_64 1:0.4-4.2.fc11 set to be updated
---> Package java-1.5.0-gcj-devel.x86_64 0:1.5.0.0-25.fc11 set to be updated
--> Processing Dependency: eclipse-ecj >= 3.2.1 for package: java-1.5.0-gcj-devel
--> Processing Dependency: libgcj-src >= 4.1.2-5 for package: java-1.5.0-gcj-devel
--> Processing Dependency: gcc-java >= 4.1.2-5 for package: java-1.5.0-gcj-devel
--> Processing Dependency: /usr/bin/gcj for package: java-1.5.0-gcj-devel
---> Package tomcat5-jasper.noarch 0:5.5.27-5.9.fc11 set to be updated
--> Processing Dependency: tomcat5-servlet-2.4-api = 5.5.27-5.9.fc11 for package: tomcat5-jasper
---> Package tomcat5-jsp-2.0-api.noarch 0:5.5.27-5.9.fc11 set to be updated
--> Processing Dependency: tomcat5-servlet-2.4-api = 5.5.27-5.9.fc11 for package: tomcat5-jsp-2.0-api
---> Package tomcat6-servlet-2.5-api.noarch 0:6.0.18-9.2.fc11 set to be updated
---> Package wsdl4j.x86_64 0:1.5.2-6.5.fc11 set to be updated
--> Running transaction check
---> Package ecj.x86_64 1:3.4.2-4.fc11 set to be updated
---> Package gcc-java.x86_64 0:4.4.0-0.31 set to be updated
--> Processing Dependency: libgcj-devel = 4.4.0-0.31 for package: gcc-java
---> Package libgcj-src.x86_64 0:4.4.0-0.31 set to be updated
---> Package tomcat5-jasper.noarch 0:5.5.27-5.9.fc11 set to be updated
--> Processing Dependency: tomcat5-servlet-2.4-api = 5.5.27-5.9.fc11 for package: tomcat5-jasper
---> Package tomcat5-jsp-2.0-api.noarch 0:5.5.27-5.9.fc11 set to be updated
--> Processing Dependency: tomcat5-servlet-2.4-api = 5.5.27-5.9.fc11 for package: tomcat5-jsp-2.0-api
--> Running transaction check
---> Package libgcj-devel.x86_64 0:4.4.0-0.31 set to be updated
---> Package tomcat5-jasper.noarch 0:5.5.27-5.9.fc11 set to be updated
--> Processing Dependency: tomcat5-servlet-2.4-api = 5.5.27-5.9.fc11 for package: tomcat5-jasper
---> Package tomcat5-jsp-2.0-api.noarch 0:5.5.27-5.9.fc11 set to be updated
--> Processing Dependency: tomcat5-servlet-2.4-api = 5.5.27-5.9.fc11 for package: tomcat5-jsp-2.0-api
--> Finished Dependency Resolution
tomcat5-jasper-5.5.27-5.9.fc11.noarch from rawhide has depsolving problems
  --> Missing Dependency: tomcat5-servlet-2.4-api = 5.5.27-5.9.fc11 is needed by package tomcat5-jasper-5.5.27-5.9.fc11.noarch (rawhide)
tomcat5-jsp-2.0-api-5.5.27-5.9.fc11.noarch from rawhide has depsolving problems
  --> Missing Dependency: tomcat5-servlet-2.4-api = 5.5.27-5.9.fc11 is needed by package tomcat5-jsp-2.0-api-5.5.27-5.9.fc11.noarch (rawhide)
Error: Missing Dependency: tomcat5-servlet-2.4-api = 5.5.27-5.9.fc11 is needed by package tomcat5-jsp-2.0-api-5.5.27-5.9.fc11.noarch (rawhide)
Error: Missing Dependency: tomcat5-servlet-2.4-api = 5.5.27-5.9.fc11 is needed by package tomcat5-jasper-5.5.27-5.9.fc11.noarch (rawhide)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
[root@viklef tmp]#
Comment 1 Andrew Overholt 2009-04-08 16:32:56 EDT
There were no recent changes to tomcat AFAICT.  I was able to install from rawhide yesterday.  Perhaps something else is wrong?
Comment 2 Matěj Cepl 2009-04-08 18:43:18 EDT
This computer was upgraded from Fedora 10 updates-testing and it had tomcat5-servlet-2.4-api-0:5.5.27-6.1.fc10.noarch (which being newer than tomcat5-servlet-2.4-api-0:5.5.27-5.9.fc11.noarch blocked it from installation).

Just that you should make sure users can upgrade from F10.
Comment 3 Andrew Overholt 2009-04-08 18:51:08 EDT
Devrim/David:  is this a simple matter of bumping the release in rawhide and rebuilding?
Comment 4 David Walluck 2009-04-08 22:31:28 EDT
It looks like the release in F10 is actually newer than rawhide, in which case, merging with F10 and bumping the release to 6.2 seems like it's in order.
Comment 5 Andrew Overholt 2009-04-09 09:39:30 EDT
(In reply to comment #4)
> It looks like the release in F10 is actually newer than rawhide, in which case,
> merging with F10 and bumping the release to 6.2 seems like it's in order.  

Can you take care of this ASAP, please, David?  The F-11 freeze is on Tuesday.  Thanks!
Comment 6 Tom "spot" Callaway 2009-04-15 14:20:25 EDT
All branches were brought to the same level (6.2) and I fixed a minor bug in how it was exporting CLASSPATH in the spec.

http://koji.fedoraproject.org/koji/taskinfo?taskID=1300738
Comment 7 Tom "spot" Callaway 2009-04-15 15:06:46 EDT
Tagged for F-11 final. Closing.
Comment 8 Andrew Overholt 2009-04-15 15:23:28 EDT
(In reply to comment #6)
> All branches were brought to the same level (6.2) and I fixed a minor bug in
> how it was exporting CLASSPATH in the spec.
> 
> http://koji.fedoraproject.org/koji/taskinfo?taskID=1300738  

Thanks, spot!

Note You need to log in before you can comment on or make changes to this bug.