Bug 494994 - Twinkle srpm doesn't build without qt3-devel
Twinkle srpm doesn't build without qt3-devel
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: twinkle (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-08 20:04 EDT by Cory Jaeger
Modified: 2009-04-09 10:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-09 10:53:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cory Jaeger 2009-04-08 20:04:57 EDT
Description of problem:
.spec file should be updated to include build requirement of qt3-devel or to add --disable-qt-check to %configure

Version-Release number of selected component (if applicable):
1.4.2-1

How reproducible:
Always

Steps to Reproduce:
1. Download src.rpm
2. rpmbuild --rebuild it
  
Actual results:
Build fails with complaint of missing qt-mt.pc

Expected results:
Successful build
Comment 1 Kevin Fenzi 2009-04-08 20:24:55 EDT
The spec has a BuildRequire on kdelibs3-devel, which should require qt3-devel... 

Is that not being pulled in?
Comment 2 Cory Jaeger 2009-04-08 20:52:18 EDT
Arrg.  I forgot that I had removed BuildRequire kdelibs3-devel last night.  I was building a custom rpm that installs without all the kde fluff and kde-addressbook tie-in.

As it's really a problem with mucking about with the .spec and not strictly a problem with the .spec I offer my apologies. My bad.

I can understand why sub-dependancies wouldn't be included.  Although if qt3-devel had been in there it would have saved me an hour figuring out how to build my non-kde rpm.
Comment 3 Kevin Fenzi 2009-04-08 22:16:35 EDT
Yeah, sorry about that. :( 

I suppose I could add qt3-devel in there just in case... 

Anyhow, shall we close this now?
Comment 4 Cory Jaeger 2009-04-09 10:53:53 EDT
Yeah.  I suspect that most people who would take the time to edit the .spec file and make a non-kde build of twinkle would be able to eventually figure out what was wrong.  And it's not really a bug when it's due to end-user customization of the package so closing this would probably be best.

Note You need to log in before you can comment on or make changes to this bug.