Bug 494996 - gnome-appearance-properties segfaults with policykit error
gnome-appearance-properties segfaults with policykit error
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: PolicyKit (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-08 20:07 EDT by Dennis Jacobfeuerborn
Modified: 2013-03-05 22:58 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 04:13:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Jacobfeuerborn 2009-04-08 20:07:26 EDT
After the last boot my windows are rendered with the wrong theme. When I tried to start gnome-appearance-properties to reset it I got the following response:

[WARN  3600] polkit-error.c:143:polkit_error_get_error_message(): error != NULL
 Not built with -rdynamic so unable to print a backtrace

** (gnome-appearance-properties:3600): WARNING **: Failed to initialize PolicyKit context: (null)
[WARN  3600] polkit-error.c:156:polkit_error_free(): error != NULL
 Not built with -rdynamic so unable to print a backtrace

(gnome-appearance-properties:3600): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(gnome-appearance-properties:3600): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed

(gnome-appearance-properties:3600): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(gnome-appearance-properties:3600): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
Segmentation fault

This happens with the following packages installed:
control-center-2.24.0.1-13.fc10.i386
PolicyKit-0.9-4.fc10.i386
PolicyKit-gnome-0.9-3.fc10.i386
Comment 1 Dennis Jacobfeuerborn 2009-04-10 22:46:58 EDT
I'm seeing the same error when I start palimpsest from gnome-disk-utility-0.1-0.git20080720.fc10 so I'm reassigning this to the PolicyKit component.

I noticed that I only get these errors when I try to run the tools as regular user. When I start them as root the messages disappear and the programs start properly.
Comment 2 C. M. Trindade 2009-08-11 19:56:04 EDT
I also have a problem with gnome-appearance-properties in fc10. When I run it as user and select a menu style the OS logs off. This only happens if my Fedora is installed on a Sata disk, on an Ata disk there is no problem. I got no debug info, could have some if Linux did not log off so quickly.

I am using kernel 2.6.27.25. The version of the packages is the same.
Comment 3 C. M. Trindade 2009-08-20 17:14:04 EDT
Ok, its not the same bug as Dennis but its by the same app. See the debug info from dmesg:

mtrr: base(0xc14e8000) is not aligned on a size(0x785000) boundary
[drm:drm_mode_getfb] *ERROR* invalid framebuffer id
executing set pll
executing set crtc timing
[drm] DAC-6: set mode 1152x864 1f
SELinux: initialized (dev fuse, type fuse), uses genfs_contexts

The debug info is always the same except for line that mentions the display. at last I managed to send this bug to the Gnome Team.
Comment 4 Bug Zapper 2009-11-18 04:58:49 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 C. M. Trindade 2009-12-06 20:32:44 EST
My error is not with policykit, I could not add a new bug and wrote here, so you can close this bug if you want. The gnome-appearance-properties has some memory issues in FC10 i386.
In 64-bit FC12 that I have tested, it does not log off but am unable the change the desktop backround even with Make Default. Even after todays updates.
Comment 6 C. M. Trindade 2009-12-10 10:25:48 EST
Anyway my problem was overcome by installing 64-bit FC10.
On the other hand any 64-bit OS seems unable to compile the FILO payload (used with Coreboot), it has a problem compiling unsigned integers. Could this problem extend to other apps?
Comment 7 Bug Zapper 2009-12-18 04:13:08 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.