Bug 495002 - g-p-m dims the display and warns when *plugging* AC power.
g-p-m dims the display and warns when *plugging* AC power.
Status: CLOSED DUPLICATE of bug 511176
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-08 22:07 EDT by Gustavo Maciel Dias Vieira
Modified: 2009-08-20 08:23 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-20 08:23:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gustavo Maciel Dias Vieira 2009-04-08 22:07:27 EDT
In rawhide, g-p-m dims the display and shows a warning that the baterry is discharging when *plugging* AC power. Also, the display is brightened when the AC power is unplugged.

Version-Release number of selected component (if applicable):
gnome-power-manager-2.26.0-1.fc11.x86_64

How reproducible:
Currently, it is deterministic. 

The machine is a HP Pavilion dv4-1125br.
Comment 1 Gustavo Maciel Dias Vieira 2009-04-08 22:13:34 EDT
Actually, it seems to be a bit more complicated. The bahavior above happens when the battery is charging. If it 100% charged, g-p-m does not detect AC power status changes. It stays in the plugged and 100% charged until the next reboot.

In both situations /proc/acpi/battery/BAT0/state shows the correct state of the system.
Comment 2 Gustavo Maciel Dias Vieira 2009-05-01 14:01:48 EDT
The problem persists in the Preview Release. It's improved a bit, the icon now correctly display the status (a little plug or just the battery). But, the message about the battery discharge and the dimming of the screen continue reversed.

Current version: gnome-power-manager-2.26.1-2.fc11.x86_64

Oh, and this is a regression. It worked perfectly in F10.
Comment 3 Richard Hughes 2009-06-03 04:12:22 EDT
Can you try installing https://admin.fedoraproject.org/updates/F11/FEDORA-2009-5740 and https://admin.fedoraproject.org/updates/F11/FEDORA-2009-5728 and then reboot please. If it fixes things, please report that as positive karma for the update. Thanks.
Comment 4 Gustavo Maciel Dias Vieira 2009-06-03 13:28:08 EDT
The problem persists with these updates.

The problem I reported in comment #1 seems very similar to bug #499948. In this case (100% charged) both /proc/acpi and hal shows the correct state. "devkit-power --dump" shows the battery as charged even without AC power.

Regarding the original problem, a battery discharge message is still displayed when puggling AC, but the screen does not dim. Actually, the screem seems to be always fully lit no matter what happens now (may be a configuration problem, but I have not touched the settings).
Comment 5 Bug Zapper 2009-06-09 09:31:05 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Richard Hughes 2009-08-20 08:23:41 EDT

*** This bug has been marked as a duplicate of bug 511176 ***

Note You need to log in before you can comment on or make changes to this bug.