Bug 495007 - PulseAudio Bug(?) on totem : "Error : Disconnected: Connection terminated" on others just hangs.
PulseAudio Bug(?) on totem : "Error : Disconnected: Connection terminated" on...
Status: CLOSED DUPLICATE of bug 472339
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-08 22:51 EDT by Luckis P
Modified: 2009-04-09 19:43 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-09 19:43:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 350451 None None None Never

  None (edit)
Description Luckis P 2009-04-08 22:51:37 EDT
Description of problem:
When playing video or audio files at some point the application hangs. Mplayer hangs with no output, xine hangs, rhythmbox stops playing and Totem displays an error and hangs, totems error is "Error: Disconnected: Connection terminated"

Version-Release number of selected component (if applicable):
pulseaudio 0.9.15-test7   (with previous versions i didn't have that issue)

How reproducible:
Always.

Steps to Reproduce:
Play any multimedia file with any application.
  
Actual results:
The application hangs. 

Additional info:
Full Error feedback from totem ran with option "--debug" : 
[luckis@pc ~]$ totem --debug
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
I: caps.c: Dropping root privileges.
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
/usr/lib/python2.6/site-packages/gdata/tlslite/utils/cryptomath.py:9: DeprecationWarning: the sha module is deprecated; use the hashlib module instead
  import sha
** Message: Error: Disconnected: Connection terminated
pulsesink.c(451): gst_pulsesink_is_dead (): /GstPlayBin:play/GstBin:abin/GstBin:audiosinkbin/GstPulseSink:audio-sink

I am not sure if a backtrace would be useful if it is please ask for one and i will be more than happy to get it, now from pulseaudio or totem or whatever is on your judgement.
Thanks.
Comment 1 Andrew Jamison 2009-04-08 23:34:00 EDT
I also have similar problems with this in addition once the disconnected error hits even the system-config-sound tool craps out saying waiting for sound system which aparently is never ready. a reboot fixes this temporarily.
Comment 2 Andrew Jamison 2009-04-09 00:03:22 EDT
here is my current alsa-info output 

http://www.alsa-project.org/db/?f=069543c9bd0db9e08e80cefb66fe64fb07858862
Comment 3 Andrew Jamison 2009-04-09 00:13:13 EDT
These errors are outputed in the terminal when running pulseaudio in verbose mode when it crashes

E: alsa-util.c: snd_pcm_avail() returned a value that is exceptionally large: 4293883140 bytes (8113913 ms).
E: alsa-util.c: Most likely this is a bug in the ALSA driver 'snd_intel8x0'. Please report this issue to the ALSA developers.
E: alsa-util.c: snd_pcm_delay() returned a value that is exceptionally large: 1624612 bytes (3069 ms).
E: alsa-util.c: Most likely this is a bug in the ALSA driver 'snd_intel8x0'. Please report this issue to the ALSA developers.
E: rtpoll.c: Assertion 'usec <= ((pa_usec_t) 1000000ULL)*60ULL*60ULL' failed at pulsecore/rtpoll.c:548, function pa_rtpoll_set_timer_relative(). Aborting.
Aborted

I can then reload pulseaudio and it will work for a few minutes before crashing all over again
Comment 4 Lennart Poettering 2009-04-09 14:30:58 EDT
Andrew, your issue is already reported as bug 472339.

Luckis, could you please run PA in verbose mode on a terminal? Most likely your issue too is either 472339 or 485734.
Comment 5 Luckis P 2009-04-09 17:39:22 EDT
(In reply to comment #4)
> Andrew, your issue is already reported as bug 472339.
> 
> Luckis, could you please run PA in verbose mode on a terminal? Most likely your
> issue too is either 472339 or 485734.  

Ok i did and i think it is related to both alsa and pulseaudio, here is the output:
D: alsa-sink.c: Wakeup from ALSA!
E: alsa-util.c: snd_pcm_avail() returned a value that is exceptionally large: 4294939480 bytes (24347729 ms).
E: alsa-util.c: Most likely this is a bug in the ALSA driver 'snd_intel8x0'. Please report this issue to the ALSA developers.
D: protocol-native.c: Underrun on 'Playback Stream', 0 bytes in queue.
(...) "These are to make the comment shorter, the above message is repeated."
D: protocol-native.c: Requesting rewind due to end of underrun.
(...)
D: protocol-native.c: Requesting rewind due to end of underrun.
E: alsa-util.c: snd_pcm_delay() returned a value that is exceptionally large: 420728 bytes (2385 ms).
E: alsa-util.c: Most likely this is a bug in the ALSA driver 'snd_intel8x0'. Please report this issue to the ALSA developers.
E: rtpoll.c: Assertion 'usec <= ((pa_usec_t) 1000000ULL)*60ULL*60ULL' failed at pulsecore/rtpoll.c:548, function pa_rtpoll_set_timer_relative(). Aborting.
Aborted

i could try to attach gdb to pulseaudio and get a backtrace, would that be more helpful? i am not sure if it would.
Comment 6 Lennart Poettering 2009-04-09 19:43:58 EDT
No need for that.

*** This bug has been marked as a duplicate of bug 472339 ***

Note You need to log in before you can comment on or make changes to this bug.