Bug 495024 - segfault/internal error in g++ 4.4.0
segfault/internal error in g++ 4.4.0
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-09 03:08 EDT by Evan Klitzke
Modified: 2009-04-10 07:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-10 07:48:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
preprocessd source, referenced from g++ crash (784.80 KB, text/plain)
2009-04-09 03:08 EDT, Evan Klitzke
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNU Compiler Collection 39713 None None None Never

  None (edit)
Description Evan Klitzke 2009-04-09 03:08:50 EDT
Created attachment 338867 [details]
preprocessd source, referenced from g++ crash

I'm getting a segfault from gcc (well, g++ actually) when trying to compile the
latest thrift code in their master branch (git://git.thrift-rpc.org/thrift.git
at commit 8554399237e54f2b4d6eaa457f9f8be898b56969).

The output of my make invocation before the segfault looks like this:

libtool: compile:  g++ -DHAVE_CONFIG_H -I. -I../.. -I/usr/include -I./src -Wall -g -O2 -MT TBinaryProtocol.lo -MD -MP -MF .deps/TBinaryProtocol.Tpo -c src/protocol/TBinaryProtocol.cpp -o TBinaryProtocol.o >/dev/null 2>&1
mv -f .deps/TBinaryProtocol.Tpo .deps/TBinaryProtocol.Plo
/bin/sh ../../libtool --tag=CXX   --mode=compile g++ -DHAVE_CONFIG_H -I. -I../..  -I/usr/include -I./src  -Wall -g -O2 -MT TCompactProtocol.lo -MD -MP -MF .deps/TCompactProtocol.Tpo -c -o TCompactProtocol.lo `test -f 'src/protocol/TCompactProtocol.cpp' || echo './'`src/protocol/TCompactProtocol.cpp
libtool: compile:  g++ -DHAVE_CONFIG_H -I. -I../.. -I/usr/include -I./src -Wall -g -O2 -MT TCompactProtocol.lo -MD -MP -MF .deps/TCompactProtocol.Tpo -c src/protocol/TCompactProtocol.cpp  -fPIC -DPIC -o .libs/TCompactProtocol.o
src/protocol/TCompactProtocol.cpp: In member function ‘virtual uint32_t apache::thrift::protocol::TCompactProtocol::readDouble(double&)’:
src/protocol/TCompactProtocol.cpp:581: warning: dereferencing type-punned pointer will break strict-aliasing rules
src/protocol/TCompactProtocol.cpp:574: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/cc582wCb.out file, please attach this to your bugreport.
make[3]: *** [TCompactProtocol.lo] Error 1
make[3]: Leaving directory `/home/evan/git/thrift/lib/cpp'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/evan/git/thrift/lib'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/evan/git/thrift'
make: *** [all] Error 2

I will attach the referenced preprocessed source file to this bug report.

I'm running an up to date version of Fedora 11 Beta. Here's what yum says about my gcc-c++:

Name       : gcc-c++
Arch       : x86_64
Version    : 4.4.0
Release    : 0.31
Size       : 12 M
Repo       : installed
Comment 1 Jakub Jelinek 2009-04-10 07:48:17 EDT
Tracking this upstream.

Note You need to log in before you can comment on or make changes to this bug.