Bug 495034 - udev + mdadm endless loop
udev + mdadm endless loop
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mdadm (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Doug Ledford
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-09 04:49 EDT by Yanko Kaneti
Modified: 2009-04-22 07:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-22 07:59:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Yanko Kaneti 2009-04-09 04:49:58 EDT
mdadm-3.0-0.devel3.5.fc11.x86_64

After mdadm-3.0-0.devel3.2  udev + mdadm get int the folowing endless dance.


# udevadm monitor
....
UDEV  [1239266575.473953] change   /devices/virtual/block/md5 (block)
UEVENT[1239266575.510739] change   /devices/virtual/block/md5 (block)
UDEV  [1239266575.516114] change   /devices/virtual/block/md5 (block)
UEVENT[1239266575.552984] change   /devices/virtual/block/md5 (block)
....

This is excuted repeatedly
/sbin/mdadm --detail --export /dev/block/9:5

The looping stops if I downgrade to mdadm-3.0-0.devel3.2 on the fly.

# blkid 
/dev/mapper/x2-root: UUID="0a71eece-0467-4349-b38e-f76a32dc8d5e" SEC_TYPE="ext2" TYPE="ext3" 
/dev/x2/root: UUID="0a71eece-0467-4349-b38e-f76a32dc8d5e" SEC_TYPE="ext2" TYPE="ext3" 
/dev/sdb1: UUID="O9hbhy-0SPt-a33F-0YWv-MatH-mlOz-XD4Fu5" TYPE="lvm2pv" 
/dev/sda1: LABEL="/boot" UUID="f704f962-35ea-4c11-a79a-f1768ca8fb82" SEC_TYPE="ext2" TYPE="ext3" 
/dev/sda2: UUID="mz9VKl-E6Ar-lTfh-vfBU-hChR-SrsK-r6gOZq" TYPE="lvm2pv" 
/dev/sdc1: UUID="AryLba-cIwd-G5YJ-Qneb-2LYK-3FQv-TgVU59" TYPE="lvm2pv" 
/dev/mapper/TV-TV: LABEL="TV" UUID="1e8ab763-970f-4c08-aa67-c58bc4cfee3c" SEC_TYPE="ext2" TYPE="ext3" 
/dev/dm-1: TYPE="swap" UUID="a76efde9-a5a0-4265-87fe-7c8807b2a264" 
/dev/sda3: UUID="wO6wh1-fEXm-x1ts-50zy-DzSq-H3i0-0abHiZ" TYPE="lvm2pv" 
/dev/sdd1: UUID="6acbb49e-eded-04cb-7ae1-f26adf04560f" TYPE="mdraid" 
/dev/mapper/x2-swap: TYPE="swap" UUID="a76efde9-a5a0-4265-87fe-7c8807b2a264" 
/dev/x2/swap: TYPE="swap" UUID="a76efde9-a5a0-4265-87fe-7c8807b2a264" 
/dev/sdd2: UUID="Jj0XAK-rJFY-ORfN-llrn-tdln-uYXa-zmIDlB" TYPE="lvm2pv" 
/dev/md5: UUID="O9hbhy-0SPt-a33F-0YWv-MatH-mlOz-XD4Fu5" TYPE="lvm2pv" 
/dev/dm-2: LABEL="tempTV" UUID="44a40889-0d75-48b1-af51-f471856a2379" SEC_TYPE="ext2" TYPE="ext3" 
/dev/mapper/tempTV-tempTV: LABEL="tempTV" UUID="44a40889-0d75-48b1-af51-f471856a2379" TYPE="ext3" 

# cat /etc/mdadm.conf 
MAILADDR root
ARRAY /dev/md5 level=raid1 num-devices=2 UUID=9eb4cb6a:cb04eded:6af2e17a:0f5604df

# cat /etc/fstab 
/dev/x2/root            /                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
/dev/x2/swap            swap                    swap    defaults        0 0
LABEL=TV		/TV			ext3	defaults	1 0
LABEL=tempTV		/TV/temp		ext3	defaults	1 0
Comment 1 Yanko Kaneti 2009-04-20 16:43:17 EDT
This no longer happens with mdadm-3.0-0.devel3.6.fc11
Comment 2 Doug Ledford 2009-04-22 07:59:33 EDT
Which doesn't make much sense considering that the only change in mdadm-3.0-0.devel3.6.fc11 was to move the mdadm map file from /dev/md/mdadm.map to /dev/.mdadm.map.  In any case, closing out since it no longer happens.

Note You need to log in before you can comment on or make changes to this bug.