Bug 495038 - Failed to link .fedora-upload-ca.cert
Failed to link .fedora-upload-ca.cert
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fedora-packager (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-09 05:53 EDT by Alex Hudson (Fedora Address)
Modified: 2009-07-11 13:19 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.3.4-3.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-11 13:07:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
missing check patch (664 bytes, patch)
2009-05-24 12:58 EDT, Brennan Ashton
no flags Details | Diff

  None (edit)
Description Alex Hudson (Fedora Address) 2009-04-09 05:53:26 EDT
Description of problem:

I received this error when setting up a clean fedora packager environment:

$ fedora-packager-setup 
Setting up Fedora packager environment
Saved: /home/alexh/.fedora-server-ca.cert
Linking: ~/.fedora-server-ca.cert to ~/.fedora-upload-ca.cert
Traceback (most recent call last):
  File "/usr/bin/fedora-packager-setup", line 131, in <module>
    main()
  File "/usr/bin/fedora-packager-setup", line 117, in main
    os.unlink(upload_ca_cert)
OSError: [Errno 2] No such file or directory: '/home/alexh/.fedora-upload-ca.cert'

Linking that file manually with ln -s allowed the command to proceed.

Version-Release number of selected component (if applicable):

fedora-packager-0.3.3-1.fc11.noarch
Comment 1 Brennan Ashton 2009-05-24 12:58:19 EDT
Created attachment 345256 [details]
missing check patch
Comment 2 Brennan Ashton 2009-05-24 13:00:13 EDT
The issue is that it is only checking to see if the file is no linked, it then assumes that the file is real and then trys to delete it.  The patch adds a check to see if the file is actually there first.
Comment 3 Bug Zapper 2009-06-09 09:31:46 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Fedora Update System 2009-06-24 01:58:52 EDT
fedora-packager-0.3.4-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/fedora-packager-0.3.4-2.fc11
Comment 5 Fedora Update System 2009-06-24 02:14:52 EDT
fedora-packager-0.3.4-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/fedora-packager-0.3.4-2.fc10
Comment 6 Fedora Update System 2009-06-26 22:42:18 EDT
fedora-packager-0.3.4-2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update fedora-packager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-6961
Comment 7 Fedora Update System 2009-06-26 22:50:33 EDT
fedora-packager-0.3.4-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update fedora-packager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6995
Comment 8 Fedora Update System 2009-07-06 17:16:07 EDT
fedora-packager-0.3.4-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/fedora-packager-0.3.4-3.fc10
Comment 9 Fedora Update System 2009-07-06 17:16:17 EDT
fedora-packager-0.3.4-3.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/fedora-packager-0.3.4-3.fc11
Comment 10 Luya Tshimbalanga 2009-07-08 14:41:16 EDT
The issue is resolved, I added karma to updates page.
Comment 11 Fedora Update System 2009-07-11 13:07:36 EDT
fedora-packager-0.3.4-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2009-07-11 13:19:17 EDT
fedora-packager-0.3.4-3.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.