Bug 495047 - Emacs spell checking modes only see the current locale dictionary.
Summary: Emacs spell checking modes only see the current locale dictionary.
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: emacs
Version: 11
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Karel Klíč
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-04-09 12:03 UTC by Gustavo Maciel Dias Vieira
Modified: 2013-03-03 22:59 UTC (History)
10 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-06-28 11:45:51 UTC


Attachments (Terms of Use)

Description Gustavo Maciel Dias Vieira 2009-04-09 12:03:15 UTC
The version of Emacs in F11 beta, after correctly configured to use huspell, only sees the default dictionary for the current locale. Especifically, this appears to be a dictionary named "", that huspell maps to the current set locale.

The problem is that I sometimes edit text in another language. I was used to change spell dictionaries using the Tools|Spell Checking|Change Dictionary... menu option. Currently, this option does not list all installed dictionaries and selecting one of the list will lock the Emacs process in the next spell checking operation. 

Version-Release number of selected component (if applicable):
emacs-22.3-10.fc11.x86_64

A workaround to this problem is starting Emacs in the locale you want to spell check. For example, if your locale isn't English and you want to spell check in US English, use:
$ LC_ALL=en_US.UTF-8 emacs &

Comment 1 Marcel Kyas 2009-05-05 14:37:45 UTC
I see similar problems. Either, emacs locks up, e.g., when changing from a german dictionary to "english", or I get the following error in emacs messages buffer:

Ispell process killed
Local Ispell dictionary set to british
Starting new Ispell process [british] ...
Error in post-command-hook: (error Can't open affix or dictionary files.
@(#) International Ispell Version 3.2.06 (but really Hunspell 1.2.8))

I have the british dictionary installed on my machine:

$ rpm -q hunspell-en
hunspell-en-0.20090216-2.fc11.noarch

$ ll /usr/share/myspell/en_GB.*
-rw-r--r--. 1 root root  27449 26. Mai 2005  /usr/share/myspell/en_GB.aff
-rw-r--r--. 1 root root 527349 25. Feb 05:44 /usr/share/myspell/en_GB.dic

Comment 2 Gustavo Maciel Dias Vieira 2009-06-03 20:05:37 UTC
It seems that the "" dictionary is defined in ispell-dictionary-alist as the nil dictionary. 

(nil "[A-Za-z]" "[^A-Za-z]" "[']" nil
      ("-B")
      nil iso-8859-1)

This has the following additional problems: 1) It doesn't parse correctly word boundaries for words not composed of only ASCII characters. 2) It assumes iso-8859-1 dictionaries.

As I can't change dictionary configurations, portuguese dictionaries are unusable out of the box, even if I set the locale correctly in my session or configure a dictionary entry manually in my .emacs.

Sorry for noticing it so late, but this means the Fedora 9 dictionary unification is a failure for Emacs. A workaround is to install aspell.

Comment 3 Bug Zapper 2009-06-09 13:32:23 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 4 Piotr Piotrowski 2009-06-11 15:35:53 UTC
Is this a duplicate of bug 498556? Anyway I have just upgraded to Fedora 11 (release version) and I have temporarly moved back to aspell.

Comment 5 Alex Bennee 2009-06-30 16:09:58 UTC
I'm seeing this problem as well. Whatever the default emacs magic for using ispell is it kills and hangs waiting for hunspell. I have aspell installed but the ispell package is still being hi-jacked by hunspell which I can't uninstall without the system dissapearing.

Comment 6 Gustavo Maciel Dias Vieira 2009-07-14 19:17:02 UTC
(In reply to comment #4)
> Is this a duplicate of bug 498556? 

No, I have the locale correctly set, and "huspell -a" works in the command line.

Comment 7 Gustavo Maciel Dias Vieira 2009-07-14 19:37:44 UTC
I investigated this issue further and discovered that, at least in my machine, the huspell process locks because of wrong paramenters in ispell-dictionary-alist. For example, it can't find the named dictionary. As most of the entries in this list are not for hunspell or the hunspell dictionaries shipped with Fedora, changing a dictionary is sure to break things. Moreover, we have the word boundaries and character enconding problems.

So, the solution is simple. Redefine ispell-dictionary-alist to contain entries correctly configured to all the hunspell dictionaries shipped by Fedora, using the opportunity to fix the other issues.

As an example, I have set a limited number of dictionaries (the ones I use) in my .emacs (inspired by http://www.emacswiki.org/emacs/InteractiveSpell):

; Resets the dictionary list for the hunspell dictionaries.
(setq ispell-dictionary-alist
      '(
        (nil     "[A-Za-z]" "[^A-Za-z]" "[']" nil ("-d" "en_US") nil utf-8)
        ("en_US" "[A-Za-z]" "[^A-Za-z]" "[']" nil ("-d" "en_US") nil utf-8)
        ("pt_BR" "[a-zàáâãçéêíóôõúüA-ZÀÁÂÃÇÉÊÍÓÔÕÚÜ]"
         "[^a-zàáâãçéêíóôõúüA-ZÀÁÂÃÇÉÊÍÓÔÕÚÜ]" "" nil 
         ("-d" "pt_BR") nil utf-8)
        ))
(eval-after-load "ispell"
  (progn
    (setq ispell-dictionary "pt_BR"
          ispell-extra-args '("-i" "utf-8")
          ispell-silently-savep t)))
;(setq-default ispell-program-name "hunspell")

This gets rid of the default locale based dictionary (that doesn't work due to the word boundary problem), and sets UTF-8 as the default encoding (see ispell-extra-args). 

If we can complete this with entries for the other hunspell dictionaries, this should solve this bug.

Comment 8 Daniel Novotny 2009-09-30 12:13:46 UTC
hello,
is the problem solved in new emacs 23.1, to which we updated F11?

Comment 9 Alex Bennee 2009-10-05 09:10:50 UTC
The update to 23.1 in F11 certainly solved my problem with spelling add-ons. I can't speak for the original poster though. Certainly my .emacs selects UK English fine as the default.

Comment 10 Gustavo Maciel Dias Vieira 2009-10-05 14:33:47 UTC
No, the problem isn't solved.

I've tried to mimic as best as I could the out-of-the-box situation. Now I see messages informing me that pt_BR dictionary can't be found. Also, If I try to change dictionaries, none can be found. However, no lockups.

The explanation for this is simple. Since version 22.3-14.fc11, Emacs in Fedora requires aspell (see bug# 508033). This makes the locking problem go away. However, aspell isn't the default spell checker for Fedora, so no aspell dictionaries are installed. The user has to manually discover this and fix it by installing the dictionaries. I consider this (manually installing and using aspell) a workaround, not a fix.

As the dictionary lists are not changed, Emacs still locks when I manually set to use hunspell. Using the dictionary configuration of comment# 7 fixes it. I've had to change the configuration in 23.1 to use ispell-local-dictionary-alist, as ispell-dictionary-alist was being overwritten in this version (not in 22.x).

Comment 11 Bug Zapper 2010-04-27 13:35:02 UTC
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 12 Mikko Huhtala 2010-06-12 09:02:01 UTC
This bug is still there in F13 with 

emacs-23.2-1.fc13.i686
aspell-0.60.6-11.fc13.i686
hunspell-1.2.8-17.fc13.i686

Emacs requires aspell, but is not configured to use it by default (ispell-program-name is nil and the aspell dictionaries are not installed).

I did 

(setq ispell-program-name "/usr/bin/hunspell")

and that led to Emacs locking up when trying to change dictionaries. Strangely the Emacs user interface seemed to list dictionaries that were not installed for hunspell, so the lock-up may be because of changing to a non-existent dictionary.

Comment 13 Bug Zapper 2010-06-28 11:45:51 UTC
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.