Bug 495054 - sphinx 0.6.1 is available
sphinx 0.6.1 is available
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-sphinx (Show other bugs)
11
All All
low Severity medium
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-09 09:18 EDT by Stefan Seefeld
Modified: 2009-08-28 17:56 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.6.2-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-28 17:56:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Seefeld 2009-04-09 09:18:48 EDT
python-sphinx-0.6.1 is already available. Could you please provide rpms for that ?
Comment 1 Michel Alexandre Salim 2009-04-17 15:39:52 EDT
It's currently being built for Fedora 11. There are some incompatible changes due to the switch to Jinja2, so I'm probably not going to update F-9 and F-10 unless otherwise requested.
Comment 2 Michel Alexandre Salim 2009-04-17 16:00:00 EDT
Correction: this will be pushed after F-11 comes out; it's not worth breaking the package freeze
Comment 3 John Poelstra 2009-06-08 15:29:09 EDT
Adding 'FutureFeature' keyword to avoid rawhide rebase.
Comment 4 Toshio Ernie Kuratomi 2009-07-15 03:18:59 EDT
ping, Michel, did you forget to push the build now that F11 is out? ;-)
Comment 5 Mitchell Berger 2009-08-03 09:22:50 EDT
At this point, Sphinx 0.6.2 has become available, and there's another
ticket opened by FEver for it
(see https://bugzilla.redhat.com/show_bug.cgi?id=512438).
The details of its changelog indicate that it has several bugfixes
since 0.6.1, and there don't appear to be any backwards-incompatible
changes.

So, at this point, would it be possible to update to 0.6.2 and push the
updates out at least to F11?  Just yesterday, I received a report of
someone on F11 tripping over Sphinx bug 6
(http://bitbucket.org/birkenfeld/sphinx/issue/6/fix-html-generation-for-tocs)
which was fixed way back in 0.6.
Comment 6 Mitchell Berger 2009-08-11 02:56:05 EDT
Hi Michel - it's been four months since we've heard from you about
python-sphinx.  Can you please reply and let us know what's going
on and when we can expect to see a new version in F11?
Comment 7 Toshio Kuratomi 2009-08-17 16:26:16 EDT
I've built 0.6.2 for rawhide. Michel, What do you think about building this for F-11 as well?

It does have incompatibilites for people who are using custom templates.  Otherwise it looks like mostly bugfixes and enhancements.
Comment 8 Fedora Update System 2009-08-20 02:23:11 EDT
python-sphinx-0.6.2-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/python-sphinx-0.6.2-1.fc11
Comment 9 Michel Alexandre Salim 2009-08-20 02:24:01 EDT
Package built -- sorry for the delay. Toshio, thanks for working on the patch.
Comment 10 Fedora Update System 2009-08-20 16:54:37 EDT
python-sphinx-0.6.2-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-sphinx'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-8774
Comment 11 Fedora Update System 2009-08-28 17:55:57 EDT
python-sphinx-0.6.2-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.