Bug 495069 - [UEFI Test Day] boot.iso fails on Apple Macintosh mini with Intel CPU
[UEFI Test Day] boot.iso fails on Apple Macintosh mini with Intel CPU
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-09 11:29 EDT by John Reiser
Modified: 2009-05-07 10:52 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Comment #1 should probably find its way into release notes in some way.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-07 10:42:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2009-04-09 11:29:00 EDT
Description of problem: Apple Macintosh mini with Intel CPU fails to get into anaconda after booting from boot.iso.


Version-Release number of selected component (if applicable):
md5sum
b9453d62e04d61734a7558969e60e6fe  http://mirror.hiwaay.net/pub/fedora/linux/releases/test/11-Beta/Fedora/i386/os/images/boot.iso

How reproducible: every time


Steps to Reproduce:
1. Download Fedora 11 Beta i386 images/boot.iso, and burn to CD-RW.
2. Boot CD-RW on Apple Macintosh mini Intel CPU [power off, poweron, hold down Option key during chime]
3. Choose either "Windows" or "EFI Boot" icon (picture of CD) as boot choice.  (The other choice is MacOS picture of harddrive.)
  
Actual results: Choosing "EFI Boot" gives "no startup disk" logo (slowly flashing question mark in 3cm icon of gray folder), then after a few seconds switches to Apple logo and regular boot MacOS 10.5.6 from harddrive.

Choosing "Windows" gives a text display (white letters on black background):"
    1.

    2.
Select CD-ROM Boot Type :"
then waits forever with no response to keyboard (which is connected via USB.)  Power off is only working option.


Expected results: Enters anaconda to begin install of Fedora.


Additional info: Booting the Fedora 11 Beta i386 DVD in either Install or Rescue mode, or booting the Fedora 11 Beta i386 netinst CD, gets into anaconda succesfully.  If these work, then why does boot.iso fail?

To file this bug report, I clicked the bugzilla link on the QA TestDay page, but "&component=uefi" did not select any component; so, I picked efibootmgr as closest.
Comment 1 Peter Jones 2009-05-07 10:42:51 EDT
This is actually two separate firmware problems.

The first is that Apple's EFI firmware doesn't support booting EFI CDs.

The second is that Apple's BootCamp (BIOS) firmware doesn't correctly handle multiple el-torito boot blocks, and instead presents the user with a text menu and no keyboard driver.

The latter is the reason we haven't made the regular CD/DVD install media EFI bootable; so you can still use it on machines with firmware broken in this manner.

There is no way for us to support EFI-bootable CDs on current Apple hardware.
Comment 2 Peter Jones 2009-05-07 10:52:13 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
Comment #1 should probably find its way into release notes in some way.

Note You need to log in before you can comment on or make changes to this bug.