Bug 495133 - fix taskomatic errata notifier to take into account channel_id while before sending out notifications
fix taskomatic errata notifier to take into account channel_id while before ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Other (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Justin Sherrill
Devan Goodwin
:
Depends On:
Blocks: 149695 456985
  Show dependency treegraph
 
Reported: 2009-04-09 16:49 EDT by Pradeep Kilambi
Modified: 2009-09-10 16:35 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:35:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pradeep Kilambi 2009-04-09 16:49:41 EDT
We fixed the database and backend to populate channel_id for a given errata as part of bug#149695 into the rhnErrataQueue. This bug is to fix taskomatic to take the new channel_id field into account so we dont spam any registered use with errata notifications  instead of those only relevant to this channel.
Comment 1 Justin Sherrill 2009-04-15 11:44:05 EDT
commit: 
b2dd55c..1113137

fixing send notifications button as well
1113137..e009ff0
Comment 3 Justin Sherrill 2009-05-11 10:35:23 EDT
On a newly installed satellite:

1.  Sync RHEL 5 i386
2.  Register a system to the i386 channel
3.  Sync RHEL 5 x86_64

Expected results:

You should NOT receive ~100 emails about errata.  (Previously you would even though there were no systems registered to the newly synced channel).
Comment 4 Devan Goodwin 2009-07-02 14:00:35 EDT
Verified. Performed the steps above and did not receive a slew of errata emails. (none actually)
Comment 5 Devan Goodwin 2009-07-02 15:24:39 EDT
Hold that thought, shortly after x86_64 channel synced I got a bunch of errata emails even though the x86 channel and system had been sitting for over a day. Received about 25 emails.


There is 1 affected system registered in 'Overview' (only systems for
which you have explicitly enabled Errata Alerts are shown).

Release    Arch       Profile Name
---------- ---------- ---------------------------------------------
5Server    i686       dhcp77-106.rhndev.redhat.com




Is this correct behavior?
Comment 6 Devan Goodwin 2009-07-02 15:29:48 EDT
Checked with Justin, he agrees this sounds off. 

Sync completed for satellite-sync -c rhel-x86_64-server-5:

    Import complete:
        Begin time: Thu Jul  2 08:33:36 2009
        End time:   Thu Jul  2 12:57:37 2009
        Elapsed:    4 hours, 24 minutes, 0 seconds

But I was not syncing the i386 channel.

Emails started arriving dated 1pm.

Moving to fails QA.
Comment 7 Justin Sherrill 2009-07-02 16:12:20 EDT
This is a sat sync issue, so prad's gonna fix it as part of bug 149695
Comment 9 Devan Goodwin 2009-07-17 07:55:05 EDT
I need clarification on something with this, if I register a system with errata to i386 channel, *before* syncing the x86_64 channel, will I get errata emails?

I got a bunch again but I'm not sure if they're because of the x86_64 sync or legit for the i386 channel the system is registered too.
Comment 10 Devan Goodwin 2009-07-17 08:22:23 EDT
I think this fails_qa again, sounds like I shouldn't be getting emails for pre-existing errata and based on the test plan above, I got the same 20 odd messages several hours after the x86_64 satellite-sync completed.

Satellite-5.3.0-RHEL4-re20090714.0-i386-embedded-oracle.iso
Comment 11 Devan Goodwin 2009-07-20 07:45:12 EDT
Ok I am not so sure, repeated the test on another system and the emails did *NOT* get sent out. The other system where the error did occur was having other issues in taskomatic errata mailing code, so these likely were the cause. Going to move this back to verified.
Comment 12 Brandon Perkins 2009-09-10 16:35:25 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.