Bug 495138 - Arora 0.6 doesn't follow system's Qt style.
Arora 0.6 doesn't follow system's Qt style.
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: arora (Show other bugs)
10
All Linux
medium Severity low
: ---
: ---
Assigned To: Jaroslav Reznik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-09 17:25 EDT by Joonas Sarajärvi
Modified: 2009-05-29 22:39 EDT (History)
1 user (show)

See Also:
Fixed In Version: 0.7.0-1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-10 03:43:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joonas Sarajärvi 2009-04-09 17:25:47 EDT
Description of problem:
The new Arora from updates-testing, together with other updates there, doesn't follow the Qt style that is set in KDE's settings. 

Version-Release number of selected component (if applicable):
arora-0.6-1.fc10.i386

How reproducible:
Always.

Steps to Reproduce:
1. Install KDE and Arora 0.6.
2. Run some Qt apps, like VLC or Quassel.
3. Run Arora.
  
Actual results:
Arora's look differs greatly from other Qt 4 apps' look. The theme used seems to be plastique.

Expected results:
All Qt apps follow the Qt style that is selected in KDE's settings.

Additional info:
The same bug seems to apply to Rawhide.
Comment 1 Jaroslav Reznik 2009-04-10 03:43:28 EDT
Arora developers say that there're some issues with current Oxygen theme and decided not to use it, so when Arora detects Oxygen, fallbacks to Plastique. These fixes are already in 4.3, so it'll be working again once KDE 4.3 is released... 

You can run Arora with style option: "arora -style oxygen".

I'm closing this bug as WONTFIX but I'll look how many and which changes in Oxygen are commited and maybe then I can possibly backport it to 4.2 branch.
Comment 2 Joonas Sarajärvi 2009-04-10 10:49:02 EDT
Thanks for the quick response and useful bits on the issue. Good to know that this is intentional, and  just a temporary solution.
Comment 3 Fedora Update System 2009-05-25 14:58:30 EDT
arora-0.7.0-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/arora-0.7.0-1.fc10
Comment 4 Jaroslav Reznik 2009-05-25 15:02:06 EDT
Looks like Arora upstream changed their mind and now Oxygen is again supported - even buggy. They ask to fill bugs to Oxygen upstream instead of disable-workaround.
Comment 5 Fedora Update System 2009-05-29 22:36:41 EDT
arora-0.7.0-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2009-05-29 22:39:29 EDT
arora-0.7.0-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.