Bug 495148 - Bad default mixer initialization
Bad default mixer initialization
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: alsa-utils (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
:
Depends On:
Blocks: AlsaVolume
  Show dependency treegraph
 
Reported: 2009-04-09 18:16 EDT by Sam Garrett
Modified: 2009-05-21 11:52 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-21 05:08:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of alsa-info.sh (23.53 KB, text/plain)
2009-04-10 07:11 EDT, Sam Garrett
no flags Details
alsa-info for Ensoniq AudioPCI ENS1370 (14.41 KB, text/plain)
2009-05-13 10:48 EDT, Peter F. Patel-Schneider
no flags Details

  None (edit)
Description Sam Garrett 2009-04-09 18:16:14 EDT
Description of problem:
PCM volume is set to less than 100% by default, but cannot be turned up in the audio applet.  This results in dramatically reduced sound capabilities in several makes and models of laptop/notebook computers.


Version-Release number of selected component (if applicable):
pulseaudio-0.9.15-8.test7.fc11.x86_64

How reproducible:
Every time.

Steps to Reproduce:
1. Turn up all volume levels in audio applet.  Run alsamixer at command line and observe PCM volume level.
2. Play media with audio.
3. Use alsamixer to increase PCM volume.  Play media again, hear difference.
  
Actual results:
Reduced PCM audio output by default, which can be changed at the command-line.

Expected results:
Full PCM audio output by default, which can be changed through the sound control applet.

Additional info:

The PCM volume can be set using alsamixer at the command line as a short-term workaround.
Comment 1 Benjamin Kingston 2009-04-09 18:41:17 EDT
Also applies to Intel HDAudio devices. These have "front" and need to be turned up in addition to PCM.
Comment 2 Lennart Poettering 2009-04-09 19:42:03 EDT
If the PCM slider is not initialized properly by default this is a problem with the alsa default mixer database.

Reassigning to alsa-utils.

Sam, please tell us which sound card you have, i.e. paste the output of alsa-info.sh --no-upload.
Comment 3 Sam Garrett 2009-04-10 07:11:43 EDT
Created attachment 339082 [details]
Output of alsa-info.sh

Output of alsa-info.sh attached.
Comment 4 Jaroslav Kysela 2009-04-10 08:15:03 EDT
You may change /lib/alsa/init/hda files for your systems, but setting everything to max as default seems insane to me so I might not accept your changes. With the default settings sound should be hearable, but not on max.

Lennart, why mixer applet does not allow to control also the hardware mixer? It's gnome issue?
Comment 5 Lennart Poettering 2009-04-10 11:00:38 EDT
Not sure if it should be at max. But it should be at a level that 'makes sense', i.e. that everything has a good volume on default initialization.

PA only exposes one volume control, which is usually 'Master' (if available), not 'PCM'.
Comment 6 Sam Garrett 2009-04-10 18:22:59 EDT
I'm okay with dropping the PCM max default part if we can get full mixer control back.  Seems someone decided to oversimplify the interface at some point.
Comment 7 Peter F. Patel-Schneider 2009-05-13 10:46:43 EDT
I had a similar problem with an Ensoniq AudioPCI ENS1370.  In my case the effective volume was 0!  I used alsamixer -c to set everything "flat" and then the pulseaudio volume controls worked well.

I'm attaching my alsa-info.txt file.
Comment 8 Peter F. Patel-Schneider 2009-05-13 10:48:50 EDT
Created attachment 343780 [details]
alsa-info for Ensoniq AudioPCI ENS1370

I initially had zero effective volume and had to rescue the situation with alsamixer -c
Comment 9 Adam Williamson 2009-05-14 16:13:55 EDT
Well, this is basically an AlsaVolume bug, so setting it as blocking that.

Jaroslav, as with all the other AlsaVolume cases, as Lennart said, we need the default ALSA setting to be 'sane' so that Pulse can effectively adjust the volume: the default should be such that Pulse modifying the Master slider gives a useful range of control.

Sam: Pulse-type mixers are intended to be simplified to this level, they will not be made more complex in this respect. It ought to be possible for the underlying ALSA elements to be set such that the single control in a Pulse-type mixer gives a reasonable volume range.
Comment 10 Lennart Poettering 2009-05-17 19:03:24 EDT
Peter, please create a bug report for your hardware.
Comment 11 Adam Williamson 2009-05-19 20:18:25 EDT
indeed, Peter, we need separate bugs for all different cards that exhibit this problem, we cannot combine them into one. please file a separate report according to the instructions here:

https://bugzilla.redhat.com/show_bug.cgi?id=497966#c1
Comment 12 Peter F. Patel-Schneider 2009-05-19 22:10:36 EDT
Done 
https://bugzilla.redhat.com/show_bug.cgi?id=501276
Comment 13 Jaroslav Kysela 2009-05-21 05:08:47 EDT
The alsa-utils-1.0.20-3 package should fix this issue. Reopen this bug if the problem persist.

Note You need to log in before you can comment on or make changes to this bug.