Bug 495149 - Booting EFI: can't start Xorg with "intel" driver
Booting EFI: can't start Xorg with "intel" driver
Status: CLOSED DUPLICATE of bug 494390
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
rawhide
i586 Linux
low Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-09 18:19 EDT by Mildred
Modified: 2009-05-25 15:31 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-25 15:31:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf used to force vesa driver, The same is used to force intel driver (219 bytes, text/plain)
2009-04-11 11:55 EDT, Mildred
no flags Details
Xorg.0.log legacy mode, no KMS (374.10 KB, text/plain)
2009-04-11 11:57 EDT, Mildred
no flags Details
Xorg.0.log.old EFI, nomodeset, no video driver specified on kernel cmdline (10.59 KB, text/plain)
2009-04-11 12:02 EDT, Mildred
no flags Details
Xorg.0.log.old EFI, KMS enabled, no video driver specified on kernel cmdline (13.01 KB, text/plain)
2009-04-11 12:26 EDT, Mildred
no flags Details

  None (edit)
Description Mildred 2009-04-09 18:19:10 EDT
Description of problem:

It only occurs when booting from EFI. (I also have a problem when booting from legacy BIOS with KMS enabled but it seems different, I can go as far as seeing the mouse cursor then).

I boot Fedora with the following grub command line:

root (hd0,3)
kernel /boot/vmlinuz-2.6.29.1-54.fc11.i586 root=/dev/sda4 rhgb ro
initrd ...

In that case, I get a Plymouth running nicely. If I press ESC, I get into console mode where I can see the startup messages running. Works nicely until Xorg try to start. Then, the computer freeze completely, the screen is left with what was on it. Keyboard doesn't work the slightest bit. I can tell it's when Xoth is starting because the message I can see on the console are the messages displayed just before Xorg starts. In my case:

Starting Avahi daemon ... [OK]
Registering binary handler for Windows applications [OK]

(those are the last lines)
The only solution, hard-reboot. CTRL-ALT-DEL doesn't work.


Now, when I try to disable the kernel modesetting using the following command line in GRUB:

kernel /boot/vmlinuz-2.6.29.1-54.fc11.i586 root=/dev/sda4 nomodeset rhgb ro

I get a jammed screen during the startup. When Xorg tries to start, I get my screen blinking for something like 3à seconds perhaps. It seems that it's the backlight that's blinking. Sometimes the screen go black, sometimes I get the same jammed pattern but brighter, alternating with the usual dim jammed pattern.

After some times, xorg seems tried to start, and I get stillness (the screen is still jammed). Ctrl-Alt-Del restart the computer.


Then I tried to start using different video devices in the kernel command line (video=efifb, video=vga16fb, video=intelfb). Doesn't changes anything.

I tried to set an xorg.conf file with Device "intel", but it doesn't change anything (I guess xorg autodetected "intel", so it shouldn't have any effect).

If I put Device "vesa", and start with KMS, I get the framebuffer console working. When xorg tries to start, it blinks very quickly and for no more than two seconds, then stops. I can then enjoy the framebuffer text console. I can login successfully on /dev/tty2.



Version-Release number of selected component (if applicable): rawhide 9 april 2009
How reproducible: always
Actual results: can't start Xorg
Expected results: to be able to start Xorg
Smolt profile: http://www.smolts.org/client/show/pub_1b47fd66-9ccf-497f-8314-ad2c42673f02

I should be able to provide more information if requested.
Comment 1 Mildred 2009-04-09 18:21:51 EDT
I got Fedora rawhide by installing Fedora 10 in legacy mode (BIOS emulation) and upgrading it. I currently use it with no problem provided that I disable KMS (nomodeset)
Comment 2 Matěj Cepl 2009-04-10 13:05:03 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report from both EFI and non-EFI boot as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Mildred 2009-04-11 11:55:03 EDT
Created attachment 339185 [details]
xorg.conf used to force vesa driver, The same is used to force intel driver

Thanks.
I'm attaching here the simple xorg.conf that I used to force driver intel or vesa in X.org. Now that I think of it, I should test the driver fbdev as well (I read it somewhere on the Internet)
Comment 4 Mildred 2009-04-11 11:57:55 EDT
Created attachment 339186 [details]
Xorg.0.log legacy mode, no KMS

Attached also the Xorg log that I get when booting Fedora as a legacy system (BIOS emulation), KMS disabled.
Comment 5 Mildred 2009-04-11 12:02:26 EDT
Created attachment 339187 [details]
Xorg.0.log.old EFI, nomodeset, no video driver specified on kernel cmdline
Comment 6 Mildred 2009-04-11 12:26:11 EDT
Created attachment 339188 [details]
Xorg.0.log.old EFI, KMS enabled, no video driver specified on kernel cmdline

I Noticed that when I started Fedora in EFI mode, with kernel modesetting, I had a jammed screen for perhaps less than a second, before I could see Plymouth.

And while Plymouth was running, the last 5 lines of pixels (approximatively) seemed wrong. Sort of jammed in a way. It seems that they display some part of the Plymouth animation, but not so that they formed any meaningful image.

I hope that those log files are enough :)

Thanks
Mildred
Comment 7 Mildred 2009-05-24 05:06:55 EDT
For quick reference:

00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03)
00:02.1 Display controller [0380]: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller [8086:27a6] (rev 03)

complete output of lspci -nn

00:00.0 Host bridge [0600]: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub [8086:27a0] (rev 03)
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03)
00:02.1 Display controller [0380]: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller [8086:27a6] (rev 03)
00:07.0 Performance counters [1101]: Intel Corporation Device [8086:27a3] (rev 03)
00:1b.0 Audio device [0403]: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller [8086:27d8] (rev 02)
00:1c.0 PCI bridge [0604]: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 [8086:27d0] (rev 02)
00:1c.1 PCI bridge [0604]: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 [8086:27d2] (rev 02)
00:1d.0 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 [8086:27c8] (rev 02)
00:1d.1 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 [8086:27c9] (rev 02)
00:1d.2 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 [8086:27ca] (rev 02)
00:1d.3 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 [8086:27cb] (rev 02)
00:1d.7 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller [8086:27cc] (rev 02)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev e2)
00:1f.0 ISA bridge [0601]: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge [8086:27b9] (rev 02)
00:1f.1 IDE interface [0101]: Intel Corporation 82801G (ICH7 Family) IDE Controller [8086:27df] (rev 02)
00:1f.2 IDE interface [0101]: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE Controller [8086:27c4] (rev 02)
00:1f.3 SMBus [0c05]: Intel Corporation 82801G (ICH7 Family) SMBus Controller [8086:27da] (rev 02)
01:00.0 Ethernet controller [0200]: Marvell Technology Group Ltd. 88E8053 PCI-E Gigabit Ethernet Controller [11ab:4362] (rev 22)
02:00.0 Network controller [0280]: Atheros Communications Inc. AR5008 Wireless Network Adapter [168c:0024] (rev 01)
03:03.0 FireWire (IEEE 1394) [0c00]: Agere Systems FW322/323 [11c1:5811] (rev 61)
Comment 8 Adam Williamson 2009-05-25 15:31:44 EDT
This looks to be a dupe of 494390 - same adapter 8086:27a2 in a Mac system, same symptom (no X without 'nomodeset').

*** This bug has been marked as a duplicate of bug 494390 ***

Note You need to log in before you can comment on or make changes to this bug.