Bug 495167 - Install to existing LVM structure fails; erroneous "not enough space available"
Install to existing LVM structure fails; erroneous "not enough space available"
Status: CLOSED DUPLICATE of bug 492614
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-09 22:10 EDT by Ronald L Humble
Modified: 2009-04-13 10:20 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-13 10:20:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ronald L Humble 2009-04-09 22:10:16 EDT
Description of problem:Install to existing LVM structure fails with erroneous error not enough space available when ample space is present.


Version-Release number of selected component (if applicable):FC11 Beta CDROMS 090331 issue; anaconda


How reproducible:
Chose Install/upgrade existing Fedora (fc9)
Chose to format three existing LVM partitions to ext4; /boot ext2 filesystem not formatted but bootloader upgraded
Anaconda formatted and correctly reported size of three LVM partitions
labeled root (10240MB) usr (15360MB) and var (51200MB). However even when package selection was reduced to 1225MB in size, anaconda reported not enough space available.
* Exit installer then the above repeated with exact same results.
* Third attempt with existing LVM structure but DID NOT choose format for root, usr, var
 Anaconda did not report more space was needed on this third attempt, and installed from CDROM #1 and #2 without further problems.


Steps to Reproduce:
1.
2.
3.
  
Actual results: Anaconda complained not enough space was available in error after formatting existing LVM partitions to ext4. Exit installer leaving empty formatted LVM partitions.


Expected results: Expect anaconda to proceed with installation to existing LVM partitions formatted to ext4 when (it appears) there is ample room in fact available for installation.


Additional info:
Comment 1 Chris Lumens 2009-04-13 10:20:37 EDT

*** This bug has been marked as a duplicate of bug 492614 ***

Note You need to log in before you can comment on or make changes to this bug.