Bug 495182 - Merkaartor crashes directly after startup
Merkaartor crashes directly after startup
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: merkaartor (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Sven Lankes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-10 02:27 EDT by Egon Kastelijn
Modified: 2009-04-13 15:44 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.13.1-1.fc10.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-13 15:44:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Egon Kastelijn 2009-04-10 02:27:05 EDT
Description of problem:
Merkaartor crashes directly after startup

Version-Release number of selected component (if applicable):
FC10 merkaartor.i386  0.12-2.fc10

How reproducible:
Install a Fedora 10 system and do a 'yum update'

Steps to Reproduce:
1. Install a Fedora 10 system
2. yum -y update
3. merkaartor
  
Actual results:
Merkaartor crashes with the following error:

$ merkaartor 
X Error: RenderBadGlyphSet (invalid GlyphSet parameter) 165
  Extension:    148 (RENDER)                               
  Minor opcode: 25 (RenderCompositeGlyphs32)               
  Resource id:  0x0                                        
X Error: RenderBadGlyphSet (invalid GlyphSet parameter) 165
  Extension:    148 (RENDER)                               
  Minor opcode: 25 (RenderCompositeGlyphs32)               
  Resource id:  0x0                                        
X Error: RenderBadGlyphSet (invalid GlyphSet parameter) 165
  Extension:    148 (RENDER)                               
  Minor opcode: 25 (RenderCompositeGlyphs32)               
  Resource id:  0x0                                        
X Error: RenderBadGlyphSet (invalid GlyphSet parameter) 165
  Extension:    148 (RENDER)                               
  Minor opcode: 25 (RenderCompositeGlyphs32)               
  Resource id:  0x0                                        
X Error: RenderBadGlyphSet (invalid GlyphSet parameter) 165
  Extension:    148 (RENDER)                               
  Minor opcode: 25 (RenderCompositeGlyphs32)               
  Resource id:  0x0                                        
X Error: RenderBadGlyphSet (invalid GlyphSet parameter) 165
  Extension:    148 (RENDER)                               
  Minor opcode: 25 (RenderCompositeGlyphs32)               
  Resource id:  0x0                                        
X Error: RenderBadGlyphSet (invalid GlyphSet parameter) 165
  Extension:    148 (RENDER)                               
  Minor opcode: 25 (RenderCompositeGlyphs32)               
  Resource id:  0x0                                        
X Error: RenderBadGlyphSet (invalid GlyphSet parameter) 165
  Extension:    148 (RENDER)                               
  Minor opcode: 25 (RenderCompositeGlyphs32)               
  Resource id:  0x0                                        
X Error: RenderBadGlyphSet (invalid GlyphSet parameter) 165
  Extension:    148 (RENDER)                               
  Minor opcode: 25 (RenderCompositeGlyphs32)               
  Resource id:  0x0                                        
X Error: RenderBadGlyphSet (invalid GlyphSet parameter) 165
  Extension:    148 (RENDER)                               
  Minor opcode: 25 (RenderCompositeGlyphs32)               
  Resource id:  0x0                                        
X Error: RenderBadGlyphSet (invalid GlyphSet parameter) 165
  Extension:    148 (RENDER)                               
  Minor opcode: 25 (RenderCompositeGlyphs32)               
  Resource id:  0x0                                        
X Error: RenderBadGlyphSet (invalid GlyphSet parameter) 165
  Extension:    148 (RENDER)                               
  Minor opcode: 25 (RenderCompositeGlyphs32)               
  Resource id:  0x0                                        
X Error: RenderBadGlyphSet (invalid GlyphSet parameter) 165
  Extension:    148 (RENDER)                               
  Minor opcode: 25 (RenderCompositeGlyphs32)               
  Resource id:  0x0                                        
X Error: RenderBadGlyphSet (invalid GlyphSet parameter) 165
  Extension:    148 (RENDER)                               
  Minor opcode: 25 (RenderCompositeGlyphs32)               
  Resource id:  0x0                                        
X Error: RenderBadGlyphSet (invalid GlyphSet parameter) 165
  Extension:    148 (RENDER)                               
  Minor opcode: 25 (RenderCompositeGlyphs32)               
  Resource id:  0x0                                        
X Error: RenderBadGlyphSet (invalid GlyphSet parameter) 165
  Extension:    148 (RENDER)                               
  Minor opcode: 25 (RenderCompositeGlyphs32)               
  Resource id:  0x0                                        
X Error: RenderBadGlyphSet (invalid GlyphSet parameter) 165
  Extension:    148 (RENDER)                               
  Minor opcode: 25 (RenderCompositeGlyphs32)               
  Resource id:  0x0                                        
X Error: RenderBadGlyphSet (invalid GlyphSet parameter) 165
  Extension:    148 (RENDER)                               
  Minor opcode: 25 (RenderCompositeGlyphs32)               
  Resource id:  0x0                                        
X Error: RenderBadGlyphSet (invalid GlyphSet parameter) 165
  Extension:    148 (RENDER)                               
  Minor opcode: 25 (RenderCompositeGlyphs32)               
  Resource id:  0x0                                        
X Error: RenderBadGlyphSet (invalid GlyphSet parameter) 165
  Extension:    148 (RENDER)                               
  Minor opcode: 25 (RenderCompositeGlyphs32)               
  Resource id:  0x0                                        
X Error: RenderBadGlyphSet (invalid GlyphSet parameter) 165
  Extension:    148 (RENDER)                               
  Minor opcode: 25 (RenderCompositeGlyphs32)               
  Resource id:  0x0                                        
X Error: RenderBadGlyphSet (invalid GlyphSet parameter) 165
  Extension:    148 (RENDER)                               
  Minor opcode: 25 (RenderCompositeGlyphs32)               
  Resource id:  0x0                                        
merkaartor: symbol lookup error: merkaartor: undefined symbol: _ZN8QPainter8fillRectERK5QRectRK6QColor
$

Expected results:
A normal startup of Merkaartor

Additional info:
I think Merkaartor has a new RPM-dependancy: glyph-keeper
When I do a 'yum -y install glyph-keeper' then most of the errors disappear.
The error looks like this now:

$ merkaartor
merkaartor: symbol lookup error: merkaartor: undefined symbol: _ZN8QPainter8fillRectERK5QRectRK6QColor
$
Comment 1 Till Maas 2009-04-10 02:41:17 EDT
(In reply to comment #0)
> Description of problem:
> Merkaartor crashes directly after startup
> 
> Version-Release number of selected component (if applicable):
> FC10 merkaartor.i386  0.12-2.fc10

I have merkaartor-0.12-2.fc10 (x86_64)
                             
> X Error: RenderBadGlyphSet (invalid GlyphSet parameter) 165
>   Extension:    148 (RENDER)                               
>   Minor opcode: 25 (RenderCompositeGlyphs32)               
>   Resource id:  0x0                                        
> merkaartor: symbol lookup error: merkaartor: undefined symbol:
> _ZN8QPainter8fillRectERK5QRectRK6QColor
> $

and merkaartor starts up silently.

> Additional info:
> I think Merkaartor has a new RPM-dependancy: glyph-keeper
> When I do a 'yum -y install glyph-keeper' then most of the errors disappear.
> The error looks like this now:

I do not have glyph-keeper installed and do not get the errors. Which windowmanager are you using? I use here gnome.
 
> $ merkaartor
> merkaartor: symbol lookup error: merkaartor: undefined symbol:
> _ZN8QPainter8fillRectERK5QRectRK6QColor

This looks like it belongs to Qt, not sure, why this happened. Google returns only two search results where others have problems on Windows or with digikam.
Comment 2 Sven Lankes 2009-04-10 20:16:34 EDT
Could you please double check you're really running 0.12-2.fc10? The bug sounds a lot like you're running the (recently released) update to 0.13 which I screwed up by not properly testing it.

It has been built against qt 4.5 which isn't available as an update for f10 yet. I'm working on pushing another update which fixes this.

(PS: I have never seen the glyph-related warnings either and I'm pretty sure they're not part of the actual issue here).
Comment 3 Egon Kastelijn 2009-04-11 03:14:36 EDT
Excuse me.
I reported the wrong merkaartor version.  :(
I am running merkaartor 0.13.1-1.fc10

I am having the problem on multiple systems (i386 & x86_64).
I get the same error under KDE and Gnome.

I now use a workaround (rollback):
rpm -e merkaartor
yum -y install merkaartor-0.12-2.fc10

kind regards,

   Egon
Comment 4 Rex Dieter 2009-04-11 07:58:26 EDT
Confirmed that merkaartor-0.13.1-1.fc10 was built against and requires qt-4.5.0 still in updates-testing.

Doing another build here against qt-4.4.x.
Comment 5 Rex Dieter 2009-04-11 08:16:45 EDT
please test:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1290816
Comment 6 Egon Kastelijn 2009-04-11 12:52:34 EDT
Hi,

I downloaded and tested the mentioned RPM.
It works fine now.

I am seeing some other (gui-related) issues, but they are not related to this issue.

Thanks for the quick rebuild!

kind regards,

   Egon
Comment 7 Fedora Update System 2009-04-11 14:50:56 EDT
merkaartor-0.13.1-1.fc10.1 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/merkaartor-0.13.1-1.fc10.1
Comment 8 Fedora Update System 2009-04-13 15:44:52 EDT
merkaartor-0.13.1-1.fc10.1 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.