This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 495207 - [2.6.29.1-54.fc11.x86_64] "name_count maxed, losing inode data: dev=00:05, inode=8192" reported in dmesg
[2.6.29.1-54.fc11.x86_64] "name_count maxed, losing inode data: dev=00:05, in...
Status: CLOSED DUPLICATE of bug 445757
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-10 07:28 EDT by James
Modified: 2011-04-24 03:01 EDT (History)
19 users (show)

See Also:
Fixed In Version: kernel-2.6.29.5-186.fc11.x86_64
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-12 09:41:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Complete dmesg showing the messages. (44.07 KB, text/plain)
2009-04-10 07:28 EDT, James
no flags Details
dmesg from fc12 (44.52 KB, text/plain)
2009-12-29 16:21 EST, collura
no flags Details
i node references frim fc12 (4.10 KB, text/plain)
2009-12-29 16:23 EST, collura
no flags Details

  None (edit)
Description James 2009-04-10 07:28:12 EDT
Created attachment 339083 [details]
Complete dmesg showing the messages.

Description of problem:
A number of lines reading

name_count maxed, losing inode data: dev=00:05, inode=8192

have been observed in dmesg. I don't know the significance of these; complete dmesg attached.

Version-Release number of selected component (if applicable):
kernel-2.6.29.1-54.fc11.x86_64
Comment 1 Chuck Ebbert 2009-04-10 19:38:28 EDT
kernel/auditsc.c:894:

static int audit_inc_name_count(struct audit_context *context,
                                const struct inode *inode)
{
        if (context->name_count >= AUDIT_NAMES) {
                if (inode)
                        printk(KERN_DEBUG "name_count maxed, losing inode data: "
                               "dev=%02x:%02x, inode=%lu\n",
                               MAJOR(inode->i_sb->s_dev),
                               MINOR(inode->i_sb->s_dev),
                               inode->i_ino);
Comment 2 Bug Zapper 2009-06-09 09:36:29 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 James 2009-06-16 09:20:28 EDT
Not seen in kernel-2.6.29.5-186.fc11.x86_64, closing for now.
Comment 4 James 2009-07-05 06:31:51 EDT
Spoke too soon, still in kernel-2.6.29.6-211.fc11.x86_64.
Comment 5 Jonathan Underwood 2009-07-27 19:18:27 EDT
Present with 2.6.29.6-213.fc11.i586,reopening.

Smolt profile
http://www.smolts.org/client/show/pub_1de95ca5-e78e-48f8-9fc7-239c4cf453ed (public)
Comment 6 Daniel Rowe 2009-08-30 10:31:51 EDT
Also seeing this issue on 2.6.29.6-217.2.16.fc11.x86_64.
Comment 7 Magnus Glantz 2009-08-30 18:17:48 EDT
I'm seeing this on 2.6.29.6-217.2.16.fc11.i686.PAE.
Comment 8 Magnus Glantz 2009-09-19 08:44:14 EDT
I'm not seeing this on 2.6.30.5-43.fc11.i686.PAE.
Comment 9 long 2009-09-24 19:23:05 EDT
however I do see it on 2.6.30.5-43.fc11.x86_64
Comment 10 James 2009-09-25 04:12:05 EDT
Does anyone know exactly what this message implies?
Comment 11 Christian Krause 2009-10-18 11:59:46 EDT
I'm seeing the same problem in F10:

kernel-PAE-2.6.27.37-170.2.104.fc10.i686

name_count maxed, losing inode data: dev=00:05, inode=3835
Comment 12 Magnus Glantz 2009-10-18 16:45:16 EDT
I'm not seeing this on 2.6.30.8-64.fc11.i686.PAE.
Comment 13 Guido Grazioli 2009-10-29 16:58:28 EDT
I'm experiencing that on 2.6.30.9-90.fc11.i686.PAE

Please note this bug is probably duplicate of bug 445757
Comment 14 Michael Breuer 2009-10-31 13:23:42 EDT
I'm seeing this as well - 2.6.30.9-90.fc11.x86_64... same message, same device, inode 9805.
Comment 15 Andrew McNabb 2009-11-12 17:30:29 EST
I'm having this in kernel-2.6.30.9-96.fc11.x86_64.
Comment 16 Michael Breuer 2009-11-12 17:48:17 EST
Note: not seeing this after upgrading to a newer kernel.
Comment 17 Madhav Diwan 2009-11-24 02:23:54 EST
This is still a problem in Fedora 12 X86_64 and Fedora 11 i686 : my Fedora12 was upgraded via Rawhide in the last week so it is probably not fixed in Rawhide either.

Issue seems to be related to /sys and auditsc.c ( maybe only at boot ?? )
 The inums listed on both the i686 Fedora 11 server (server1) and the x86_64 Fedora 12 server (server2) are found via a sudo find in /sys

Looking through the source , at the moment I can not find where sysfs creates inodes , but it is late and I have not looked in ramfs or at kobject , I will continue looking , but I hope the assignees have an idea or two.


My rudimentary data is below:

for Fedora 12 X86_64   

uname = Linux server2.xxx.xxx 2.6.31.5-127.fc12.x86_64 #1 SMP Sat Nov 7 21:11:14 EST 2009 x86_64 x86_64 x86_64 GNU/Linux

inode=11105

dmesg:

ALSA sound/pci/hda/patch_realtek.c:1197: realtek: Enabling init ASM_ID=0xe601 CODEC_ID=10ec0885
input: HDA Digital PCBeep as /devices/pci0000:00/0000:00:14.2/input/input5
name_count maxed, losing inode data: dev=00:05, inode=11105
name_count maxed, losing inode data: dev=00:05, inode=11105
name_count maxed, losing inode data: dev=00:05, inode=11105
name_count maxed, losing inode data: dev=00:05, inode=11105
name_count maxed, losing inode data: dev=00:05, inode=11105
name_count maxed, losing inode data: dev=00:05, inode=11105
name_count maxed, losing inode data: dev=00:05, inode=11105
name_count maxed, losing inode data: dev=00:05, inode=11105
name_count maxed, losing inode data: dev=00:05, inode=11105
name_count maxed, losing inode data: dev=00:05, inode=11105
name_count maxed, losing inode data: dev=00:05, inode=11105
name_count maxed, losing inode data: dev=00:05, inode=11105
name_count maxed, losing inode data: dev=00:05, inode=11105
name_count maxed, losing inode data: dev=00:05, inode=11105
name_count maxed, losing inode data: dev=00:05, inode=11105
name_count maxed, losing inode data: dev=00:05, inode=11105
name_count maxed, losing inode data: dev=00:05, inode=11105
name_count maxed, losing inode data: dev=00:05, inode=11105
name_count maxed, losing inode data: dev=00:05, inode=11105
name_count maxed, losing inode data: dev=00:05, inode=11105
name_count maxed, losing inode data: dev=00:05, inode=11105
name_count maxed, losing inode data: dev=00:05, inode=11105
name_count maxed, losing inode data: dev=00:05, inode=11105
kvm: Nested Paging enabled
device-mapper: multipath: version 1.1.0 loaded
EXT3 FS on sda2, internal journal


[madhav@server2 ~]$ sudo find / -inum 11105
/sys/module/i2c_piix4/drivers/pci:piix4_smbus

############################################################

for Fedora 11 i686 

uname = Linux server1.xxx.xxx 2.6.30.9-96.fc11.i586 #1 SMP Tue Nov 3 23:33:04 EST 2009 i686 i686 i386 GNU/Linux

inode=5883

dmesg:

ALSA sound/pci/hda/hda_codec.c:3817:    inputs: mic=0x1a, fmic=0x1e, line=0x1b, fline=0x0, cd=0x1f, aux=0x0
usb-storage: device scan complete
scsi 4:0:0:0: Direct-Access     Generic  USB SD Reader    1.00 PQ: 0 ANSI: 0
scsi 4:0:0:1: Direct-Access     Generic  USB CF Reader    1.01 PQ: 0 ANSI: 0
scsi 4:0:0:2: Direct-Access     Generic  USB SM Reader    1.02 PQ: 0 ANSI: 0
scsi 4:0:0:3: Direct-Access     Generic  USB MS Reader    1.03 PQ: 0 ANSI: 0
sd 4:0:0:0: Attached scsi generic sg4 type 0
sd 4:0:0:1: Attached scsi generic sg5 type 0
sd 4:0:0:2: Attached scsi generic sg6 type 0
sd 4:0:0:3: Attached scsi generic sg7 type 0
sd 4:0:0:0: [sdd] Attached SCSI removable disk
sd 4:0:0:1: [sde] Attached SCSI removable disk
sd 4:0:0:2: [sdf] Attached SCSI removable disk
sd 4:0:0:3: [sdg] Attached SCSI removable disk
end_request: I/O error, dev fd0, sector 0
end_request: I/O error, dev fd0, sector 0
Buffer I/O error on device fd0, logical block 0
end_request: I/O error, dev fd0, sector 0
Buffer I/O error on device fd0, logical block 0
end_request: I/O error, dev fd0, sector 0
Buffer I/O error on device fd0, logical block 0
name_count maxed, losing inode data: dev=00:05, inode=5883
name_count maxed, losing inode data: dev=00:05, inode=5883
name_count maxed, losing inode data: dev=00:05, inode=5883
name_count maxed, losing inode data: dev=00:05, inode=5883
name_count maxed, losing inode data: dev=00:05, inode=5883
name_count maxed, losing inode data: dev=00:05, inode=5883
name_count maxed, losing inode data: dev=00:05, inode=5883
name_count maxed, losing inode data: dev=00:05, inode=5883
name_count maxed, losing inode data: dev=00:05, inode=5883
name_count maxed, losing inode data: dev=00:05, inode=5883
name_count maxed, losing inode data: dev=00:05, inode=5883
name_count maxed, losing inode data: dev=00:05, inode=5883
name_count maxed, losing inode data: dev=00:05, inode=5883
name_count maxed, losing inode data: dev=00:05, inode=5883
name_count maxed, losing inode data: dev=00:05, inode=5883
name_count maxed, losing inode data: dev=00:05, inode=5883
name_count maxed, losing inode data: dev=00:05, inode=5883
name_count maxed, losing inode data: dev=00:05, inode=5883
name_count maxed, losing inode data: dev=00:05, inode=5883
name_count maxed, losing inode data: dev=00:05, inode=5883
name_count maxed, losing inode data: dev=00:05, inode=5883
name_count maxed, losing inode data: dev=00:05, inode=5883
name_count maxed, losing inode data: dev=00:05, inode=5883
name_count maxed, losing inode data: dev=00:05, inode=5883
name_count maxed, losing inode data: dev=00:05, inode=5883
device-mapper: multipath: version 1.0.5 loaded
EXT3 FS on sdc2, internal journal
kjournald starting.  Commit interval 5 seconds


[madhav@server1 ~]$ sudo find / -inum 5883
[sudo] password for madhav: 
/sys/devices/pci0000:00/0000:00:1d.7/usb1/devnum
find: `/proc/22090/task/22090/fd/5': No such file or directory
find: `/proc/22090/task/22090/fdinfo/5': No such file or directory
find: `/proc/22090/fd/5': No such file or directory
find: `/proc/22090/fdinfo/5': No such file or directory
Comment 18 Michael Breuer 2009-11-26 11:37:38 EST
FYI - this is gone for me as of rawhide - 2.6.32 rc5.
Comment 19 collura 2009-12-29 16:20:22 EST
for what its worth i have similar name_count lines in dmesg (see attached) with fc12 but i am only running 2.6.31.9-174.fc12.x86_64.
  
i did a clean install of fc12 during november or so but dont know if it occurred previous to that install of fc12.  

i just happened to run across it now while looking for a problem i seem to have lately of reading from various usb devices.
Comment 20 collura 2009-12-29 16:21:37 EST
Created attachment 380848 [details]
dmesg from fc12
Comment 21 collura 2009-12-29 16:23:12 EST
Created attachment 380849 [details]
i node references frim fc12
Comment 22 Jarod Wilson 2010-01-12 11:33:10 EST
Still showing up with 2.6.32.3-17.fc12 (x86_64).
Comment 23 Eric Paris 2010-02-12 09:41:08 EST

*** This bug has been marked as a duplicate of bug 445757 ***
Comment 24 Kit Gerrits 2011-04-24 03:01:38 EDT
Actually, that bug is about the lack of a newline character messing up a buffer.
This error message was used as an example of that bug.

People have started reporting this bug in there, but those reports belong here.

Note You need to log in before you can comment on or make changes to this bug.