Bug 495219 - grubby --args modifies "module" line instead of "kernel" line
grubby --args modifies "module" line instead of "kernel" line
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mkinitrd (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Brian Lane
Release Test Team
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-10 10:10 EDT by Karel Volný
Modified: 2011-03-03 15:16 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-03 15:16:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Volný 2009-04-10 10:10:39 EDT
Description of problem:
I need to automate Xen kernel configuration. For that purpose I am trying to use grubby. However, it appends the needed parameter to "modules" line instead of "kernel" line.

Version-Release number of selected component (if applicable):
mkinitrd-5.1.19.6-44

How reproducible:
always

Steps to Reproduce:
1. yum install kernel-xen
2. cp /boot/grub/grub.conf /boot/grub/grub.conf~
3. grubby --set-default=`rpm -ql kernel-xen | grep /xen.gz`
4. grubby --args="dom0_max_vcpus=1" --update-kernel=`rpm -ql kernel-xen | grep /xen.gz`
5. diff /boot/grub/grub.conf~ /boot/grub/grub.conf
  
Actual results:
10c10
< default=1
---
> default=0
17c17
<       module /vmlinuz-2.6.18-136.el5xen ro root=/dev/VolGroup00/LogVol00 console=ttyS0,115200
---
>       module /vmlinuz-2.6.18-136.el5xen ro root=/dev/VolGroup00/LogVol00 console=ttyS0,115200 dom0_max_vcpus=1


Expected results:
10c10
< default=1
---
> default=0
16c16
<       kernel /xen.gz-2.6.18-136.el5
---
>       kernel /xen.gz-2.6.18-136.el5 dom0_max_vcpus=1


Additional info:
Note also that combining --args and --set-default into one commandline does not work. However I, am not sure whether it isn't a feature rather than bug ...
Comment 4 Alexander Todorov 2010-10-18 07:28:16 EDT
qa_ack+, easy to test.

However modifying the Xen parameters vs. regular kernel parameters using a single option --args is not a good idea IMHO. We need a --xen-args parameter to distinguish between Xen parameters and regular kernel parameters.
Comment 6 RHEL Product and Program Management 2011-01-11 15:13:04 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 7 RHEL Product and Program Management 2011-01-11 18:06:19 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.

Note You need to log in before you can comment on or make changes to this bug.