Bug 495227 - automatically loads acer_wmi module which prevents built-in wireless from working
automatically loads acer_wmi module which prevents built-in wireless from wor...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-10 10:57 EDT by Craig White
Modified: 2009-04-16 18:38 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-16 18:38:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
lscpi -v output (8.71 KB, text/plain)
2009-04-10 10:58 EDT, Craig White
no flags Details
dmidecode output (10.13 KB, text/plain)
2009-04-10 10:59 EDT, Craig White
no flags Details

  None (edit)
Description Craig White 2009-04-10 10:57:32 EDT
Description of problem:

Installed Fedora-11-Beta-i586 as an upgrade to Fedora-10. Wireless was previously working in Fedora 10. After upgrade to Beta and then update to latest packages, wireless still wasn't working.

Computer - Acer Aspire One
Model # ZG5
various particulars, 160 Gb HD, 1 Gb RAM, 8.9 inch screen
lspci -v and dmidecode output attached to bug report


Version-Release number of selected component (if applicable):

various versions of kernels on this laptop since I got it...
# grep kernel /var/log/yum.log
Jan 15 21:00:38 Installed: kernel-2.6.27.9-159.fc10.i686
Jan 15 21:12:35 Installed: kernel-2.6.27.9-159.fc10.i686
Jan 27 11:24:58 Installed: kernel-2.6.27.12-170.2.5.fc10.i686
Jan 27 11:26:08 Installed: kernel-2.6.27.12-170.2.5.fc10.i686
Feb 19 10:36:05 Installed: kernel-2.6.27.15-170.2.24.fc10.i686
Feb 19 10:41:14 Installed: kernel-2.6.27.15-170.2.24.fc10.i686
Mar 02 15:30:29 Installed: kernel-2.6.27.19-170.2.35.fc10.i686
Mar 02 15:31:42 Installed: kernel-2.6.27.19-170.2.35.fc10.i686
Wireless worked fine through all of Fedora 10 above

Here's when/where it went wrong
Apr 08 16:08:22 Installed: kernel-2.6.29.1-54.fc11.i586


How reproducible:
Install Fedora-11-Beta and update on Acer Aspire One

Steps to Reproduce:

1. Buy an Acer Aspire One
2. Install Fedora-11-Beta
  
Actual results:
entries in /var/log/messages include...
Apr  8 21:03:31 aspire-one kernel: acer-wmi: Acer Laptop ACPI-WMI Extras
Apr  8 21:03:40 aspire-one NetworkManager: <info>  Found radio killswitch /org/freedesktop/Hal/devices/platform_acer_wmi_rfkill_acer_wireless_wlan

Wireless no workee

Expected results:

Wireless workee

Additional info:

Fix was relatively simple...

modprobe -r acer_wmi

which produced the following entry in /var/log/messages...
Apr  9 15:58:40 aspire-one kernel: acer-wmi: Acer Laptop WMI Extras unloaded

and I ended up adding...
# cat /etc/modprobe.d/blacklist-acer.conf
blacklist acer_wmi

Not sure if that was useful but it made sense to me.
Comment 1 Craig White 2009-04-10 10:58:42 EDT
Created attachment 339099 [details]
lscpi -v output
Comment 2 Craig White 2009-04-10 10:59:09 EDT
Created attachment 339100 [details]
dmidecode output
Comment 3 Chuck Ebbert 2009-04-10 17:36:20 EDT
This was fixed April 3 and the updated kernel with the fix (2.6.29.1-52) has been available since April 7 .
Comment 4 Craig White 2009-04-10 22:39:39 EDT
I gather then the problem was the Fedora-11-Beta upgrade which included this kernel...

kernel-2.6.29-0.258.2.3.rc8.git2.fc11.i586

and even though I upgraded after first boot, the kernel module was already loaded.

Thanks - were you going to 'close' the bug report?
Comment 5 Steven Usdansky 2009-04-11 12:18:02 EDT
not fixed in F11 snapshot 1 with kernel-2.6.29.1-54.f11.i586
Comment 6 Adam Williamson 2009-04-14 14:20:15 EDT
Switching back to assigned based on Steven's comment that it's not fixed with a newer revision than Chuck cited.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Chuck Ebbert 2009-04-15 12:48:33 EDT
If the machine in question is the hard-drive model, that should be fixed in the next kernel (after 2.6.29.1-73.) We were only blacklisting that module for the AAO with flash drive in the earlier update.
Comment 8 Adam Williamson 2009-04-15 12:57:07 EDT
Steven, can you test with the next kernel when it shows up in Koji or Rawhide? Thanks.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 9 phil 2009-04-16 18:11:13 EDT
this behaviour has been fixed in F11 beta with kernel-2.6.2-9.1-85.fc11.i586 from koji, the thing is that as the acer_wmi module can't access anything on the acer aspire one's (all of the 8.9" versions anyway) wmi implementation so it should never be loaded on these machines, i never noticed any bad effects on F10 but i blacklisted it way back in december anyway just to be safe.

anyway thanks for the fix :)

phil
Comment 10 phil 2009-04-16 18:15:18 EDT
*kernel-2.6.29.1-85.fc11.i586 :)
Comment 11 Adam Williamson 2009-04-16 18:38:09 EDT
Thanks for confirming the fix.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.