Bug 495249 - installing from dvd exception error ejecting cdrom at end of package install
installing from dvd exception error ejecting cdrom at end of package install
Status: CLOSED DUPLICATE of bug 492459
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-10 14:53 EDT by Tim Scofield
Modified: 2009-04-12 01:05 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 495247
Environment:
Last Closed: 2009-04-12 01:05:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Scofield 2009-04-10 14:53:32 EDT
+++ This bug was initially created as a clone of Bug #495247 +++
but the error is slightly different:
NameError: global name 'device' is not defined

anaconda 11.5.0.38 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devices.py", line 2687, in eject
    log.warning("error ejecting cdrom %s: %s" % (device, e))
  File "/usr/lib/anaconda/installmethod.py", line 47, in doMethodComplete
    dev.eject()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1317, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 79, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 1338, in handleRenderCallback
    self.currentWindow.renderCallback()
NameError: global name 'device' is not defined

Local variables in innermost frame:
fd: 78
_isys: <module '_isys' from '/usr/lib/anaconda/_isys.so'>
e: (5, 'Input/output error')
self: OpticalDevice instance (0x7ffbb1993290) --
  description =   name = sr0  status = True  parents = []
  kids = 0
  uuid = None  format = <storage.formats.fs.Iso9660FS object at 0x7ffbb19934d0>  size = 0
  major = 11  minor = 0  exists = True
  sysfs path = /devices/pci0000:00/0000:00:1f.2/host1/target1:0:0/1:0:0:0/block/sr0  label = None
  target size = 0  path = /dev/sr0
  format args = []

Full traceback attached
Comment 1 Tim Scofield 2009-04-10 15:19:37 EDT
Anaconda hung shortly on the package installation screen. It seemed to have installed all of the packages.

I was able to reboot the system and finish the installation,
but yum is not able to do an update at the moment. 

...

Think I've got yum working now. Seems to be related to yum not recognizing the http_proxy environment variable
Comment 2 David Timms 2009-04-12 01:05:55 EDT
(In reply to comment #0)
> +++ This bug was initially created as a clone of Bug #495247 +++
> but the error is slightly different:
> NameError: global name 'device' is not defined
this seems to be a dupe of bug 492459, since the first part of the trace is identical, but the second part referencing scsi nodes differs.

if you still think this traceback is unique, please re-open ;0

*** This bug has been marked as a duplicate of bug 492459 ***

Note You need to log in before you can comment on or make changes to this bug.