Bug 495290 - exception at device scanning
exception at device scanning
Status: CLOSED DUPLICATE of bug 495156
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-11 05:43 EDT by Marek Mahut
Modified: 2009-04-13 10:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-13 10:45:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot and logs (177.26 KB, application/x-gzip)
2009-04-11 05:45 EDT, Marek Mahut
no flags Details
correct archive (177.84 KB, application/x-gzip)
2009-04-11 05:54 EDT, Marek Mahut
no flags Details

  None (edit)
Description Marek Mahut 2009-04-11 05:43:45 EDT
Description of problem:

Anaconda crashes with exception when scanning devices (after select keyboard screen).

Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/formats/fs.py", line 517, in mount
    raise FSError("mount failed: %s" % e)
  File "/usr/lib/anaconda/storage/formats/fs.py", line 213, in _getExistingSize
    self.mount(mountpoint=tmppath, options="ro")
  File "/usr/lib/anaconda/storage/formats/fs.py", line 164, in __init__
    self._size = self._getExistingSize()
  File "/usr/lib/anaconda/storage/formats/__init__.py", line 89, in getFormat
    fmt = fmt_class(*args, **kwargs)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1465, in handleUdevDeviceFormat
    device.format = formats.getFormat(*args, **kwargs)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1166, in addUdevDevice
    self.handleUdevDeviceFormat(info, device)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1588, in populate
    self.addUdevDevice(dev)
  File "/usr/lib/anaconda/storage/__init__.py", line 283, in reset
    self.devicetree.populate()
  File "/usr/lib/anaconda/storage/__init__.py", line 72, in storageInitialize
    storage.reset()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1323, in nextClicked
    self.anaconda.dispatch.gotoNext()
FSError: mount failed: (2, None)


Version-Release number of selected component (if applicable):

anaconda-11.5.0.42-1.i586
Fedora 11 snapshot 1

How reproducible:

always, for the moment

Steps to Reproduce:
1. Boot Fedora 11 snapshot 1
2. "Install to hard drive"
3. Select "U.S. english" and click on next... install anyway...
4. Anaconda starts device scan and crashes
Comment 1 Marek Mahut 2009-04-11 05:45:01 EDT
Created attachment 339162 [details]
screenshot and logs
Comment 2 Marek Mahut 2009-04-11 05:54:24 EDT
Created attachment 339163 [details]
correct archive
Comment 3 Chris Lumens 2009-04-13 10:45:19 EDT

*** This bug has been marked as a duplicate of bug 495156 ***

Note You need to log in before you can comment on or make changes to this bug.