Bug 495298 - Unable to build RPM due to ~/engine/*.so read-only permissions
Unable to build RPM due to ~/engine/*.so read-only permissions
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openssl (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Tomas Mraz
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-11 07:59 EDT by Steve Snyder
Modified: 2013-04-21 12:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-14 03:15:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CentOS 3589 None None None Never

  None (edit)
Description Steve Snyder 2009-04-11 07:59:03 EDT
Description of problem:

The binary RPMs of openssl cannot be built because the 'strip' util finds the target shared library to be unwriteable.  The failing return code of strip stops the packaging process after successful compiling/linking.

Version-Release number of selected component (if applicable):

openssl-0.9.8e-7.el5.src.rpm

How reproducible:

Always

Steps to Reproduce:
1. rpmbuild --rebuild openssl-0.9.8e-7.el5.src.rpm
2.
3.
  
Actual results:

+ /usr/lib/rpm/brp-compress                                                                                                     
+ /usr/lib/rpm/brp-strip                                                                                                        
+ /usr/lib/rpm/brp-strip-static-archive                                                                                         
+ /usr/lib/rpm/brp-strip-comment-note                                                                                           
strip: unable to copy file '/home/rpmbuild/rpmbuild/TMP/openssl-0.9.8e-root/usr/lib/openssl/engines/libatalla.so' reason: Permission denied                                                                                                                     
strip: unable to copy file '/home/rpmbuild/rpmbuild/TMP/openssl-0.9.8e-root/usr/lib/openssl/engines/libcswift.so' reason: Permission denied                                                                                                                     
strip: unable to copy file '/home/rpmbuild/rpmbuild/TMP/openssl-0.9.8e-root/usr/lib/openssl/engines/libaep.so' reason: Permission denied                                                                                                                        
strip: unable to copy file '/home/rpmbuild/rpmbuild/TMP/openssl-0.9.8e-root/usr/lib/openssl/engines/lib4758cca.so' reason: Permission denied                                                                                                                    
strip: unable to copy file '/home/rpmbuild/rpmbuild/TMP/openssl-0.9.8e-root/usr/lib/openssl/engines/libsureware.so' reason: Permission denied                                                                                                                   
strip: unable to copy file '/home/rpmbuild/rpmbuild/TMP/openssl-0.9.8e-root/usr/lib/openssl/engines/libnuron.so' reason: Permission denied                                                                                                                      
strip: unable to copy file '/home/rpmbuild/rpmbuild/TMP/openssl-0.9.8e-root/usr/lib/openssl/engines/libgmp.so' reason: Permission denied                                                                                                                        
strip: unable to copy file '/home/rpmbuild/rpmbuild/TMP/openssl-0.9.8e-root/usr/lib/openssl/engines/libchil.so' reason: Permission denied                                                                                                                       
strip: unable to copy file '/home/rpmbuild/rpmbuild/TMP/openssl-0.9.8e-root/usr/lib/openssl/engines/libubsec.so' reason: Permission denied                                                                                                                      
+ /bin/fipshmac /home/rpmbuild/rpmbuild/TMP/openssl-0.9.8e-root/lib/libcrypto.so.0.9.8e                                         
error: Bad exit status from /home/rpmbuild/rpmbuild/TMP/rpm-tmp.87603 (%install)                                                

Expected results:

A set of binary RPM should be buildable from the source RPM.

Additional info:

$ cd /home/rpmbuild/rpmbuild/TMP/openssl-0.9.8e-root/usr/lib/openssl/engines/
$ ll
total 136
-r-xr-xr-x 1 rpmbuild users 14648 Apr 11 07:41 lib4758cca.so
-r-xr-xr-x 1 rpmbuild users 14604 Apr 11 07:41 libaep.so
-r-xr-xr-x 1 rpmbuild users 11064 Apr 11 07:41 libatalla.so
-r-xr-xr-x 1 rpmbuild users 18900 Apr 11 07:41 libchil.so
-r-xr-xr-x 1 rpmbuild users 16512 Apr 11 07:41 libcswift.so
-r-xr-xr-x 1 rpmbuild users  2476 Apr 11 07:41 libgmp.so
-r-xr-xr-x 1 rpmbuild users  8744 Apr 11 07:41 libnuron.so
-r-xr-xr-x 1 rpmbuild users 19036 Apr 11 07:41 libsureware.so
-r-xr-xr-x 1 rpmbuild users 14784 Apr 11 07:41 libubsec.so
Comment 1 Tomas Mraz 2009-04-14 03:15:51 EDT
Actually what is failing is not the brp-strip-comment-note script which issues just warnings and this is no regression but the fipshmac command. It fails probably because the existing openssl libraries on the system are either not fips-enabled at all or they are prelinked and fail their own checksum verification test.

This will be changed in the RHEL 5.4 openssl package as it will not require fipshmac command to build anymore.

Note You need to log in before you can comment on or make changes to this bug.